Maple User Manual

Copyright

Maplesoft, Maple, Maple Application Center, Maple Student Center, Maplet, Maple T.A., and MapleNet are all trademarks of Waterloo Maple Inc.

© Maplesoft, a division of Waterloo Maple Inc. 2007. All rights reserved. No part of this book may be reproduced, stored in a retrieval system, or transcribed, in any form or by any means — electronic, mechanical, photocopying, recording, or otherwise. Information in this document is subject to change without notice and does not represent a commitment on the part of the vendor. The software described in this document is furnished under a license agreement and may be used or copied only in accordance with the agreement. It is against the law to copy the software on any medium except as specifically allowed in the agreement.

Windows is a registered trademark of Microsoft Corporation.

Java and all Java based marks are trademarks or registered trademarks of Sun Microsystems, Inc. in the United States and other countries. Maplesoft is independent of Sun Microsystems, Inc.

All other trademarks are the property of their respective owners.

This document was produced using a special version of Maple and DocBook.

Printed in Canada

Contents

Preface ........................................................................................................ xiii
1 Document Mode .......................................................................................... 1
  1.1 Introduction ........................................................................................ 1
  1.2 In This Chapter ................................................................................ 3
  1.3 Simple Mathematical Expressions .................................................. 4
    Rational Expressions (Fractions) ......................................................... 5
    Powers ............................................................................................... 5
    Products ............................................................................................ 5
    Shortcuts for Entering Mathematical Expressions ......................... 6
    Other Expressions ........................................................................... 7
  1.4 Evaluating Expressions .................................................................... 8
  1.5 Editing Expressions and Updating Output ..................................... 9
  1.6 Entering Expressions ...................................................................... 10
    Palettes .......................................................................................... 11
    Symbol Names ................................................................................. 16
  1.7 Performing Computations ............................................................ 19
    Computing with Palettes ................................................................. 20
    Context Menus .............................................................................. 20
    Assistants and Tutors .................................................................... 26
  1.8 Document Mode Summary ............................................................ 30
  1.9 Getting Help .................................................................................. 32

2 Worksheet Mode ....................................................................................... 35
  2.1 In This Chapter .............................................................................. 36
  2.2 Input Prompt .................................................................................. 37
    Suppressing Output ......................................................................... 38
    1-D Math Input ............................................................................. 38
    Input Separators .......................................................................... 39
  2.3 Commands .................................................................................... 39
    The Maple Library ......................................................................... 40
    Top-Level Commands .................................................................. 40
    Package Commands ...................................................................... 41
  2.4 Palettes .......................................................................................... 44
  2.5 Context Menus .............................................................................. 46
  2.6 Assistants and Tutors .................................................................... 48
Lauching an Assistant or Tutor ...................................................... 48
Example: Using the Interactive Plot Builder ................................. 49
2.7 Task Templates ................................................................. 51
Viewing Task Templates ......................................................... 51
Inserting a Task Template ....................................................... 52
Performing the Task ............................................................... 53
2.8 Text Regions ...................................................................... 54
2.9 Names ............................................................................... 55
Assigning to Names ............................................................... 55
Unassigning Names ............................................................... 57
Valid Names ........................................................................... 58
2.10 Equation Labels ............................................................... 59
Displaying Equation Labels ..................................................... 59
Referring to a Previous Result .............................................. 59
Execution Groups with Multiple Outputs .............................. 61
Label Numbering Schemes ................................................... 61
Features of Equation Labels ................................................ 62
3 Performing Computations .................................................... 65
3.1 In This Chapter ................................................................. 65
3.2 Symbolic and Numeric Computation .................................. 66
Exact Computations ............................................................... 67
Floating-Point Computations ................................................. 68
Converting Exact Quantities to Floating-Point Values ............. 69
Sources of Error ...................................................................... 70
3.3 Integer Operations .......................................................... 71
Non-Base 10 Numbers and Other Number Systems ............... 74
3.4 Solving Equations ............................................................. 77
Solving Equations and Inequations ..................................... 78
Other Specialized Solvers .................................................... 88
3.5 Units, Scientific Constants, and Uncertainty .................... 95
Units ..................................................................................... 96
Scientific Constants and Element Properties .................... 104
Uncertainty Propagation .................................................. 110
3.6 Restricting the Domain ..................................................... 114
Real Number Domain ......................................................... 114
Assumptions on Variables .................................................. 116
4 Mathematical Computations .............................................................. 121
  4.1 In This Chapter ............................................................................ 123
  4.2 Algebra ........................................................................................ 124
    Polynomial Algebra ..................................................................... 124
  4.3 Linear Algebra ............................................................................ 133
    Creating Matrices and Vectors ...................................................... 133
    Accessing Entries in Matrices and Vectors ................................... 142
    Linear Algebra Computations ....................................................... 143
    Student LinearAlgebra Package .................................................... 150
  4.4 Calculus ....................................................................................... 151
    Limits ............................................................................................ 151
    Differentiation ............................................................................... 153
    Series ............................................................................................. 159
    Integration ..................................................................................... 161
    Differential Equations .................................................................... 164
    Calculus Packages ......................................................................... 164
  4.5 Optimization ............................................................................... 166
    Point-and-Click Interface .............................................................. 167
    Large Optimization Problems ....................................................... 169
    MPS(X) File Support .................................................................... 171
    Additional Information .................................................................. 171
  4.6 Statistics ...................................................................................... 171
    Probability Distributions and Random Variables .......................... 171
    Statistical Computations .............................................................. 173
    Plotting .......................................................................................... 175
    Additional Information .................................................................. 177
  4.7 Teaching and Learning with Maple ............................................ 178
    Student Packages and Tutors ........................................................ 179
5 Plots and Animations .......................................................................... 187
  5.1 In This Chapter ............................................................................ 187
  5.2 Creating Plots .............................................................................. 188
    Interactive Plot Builder ................................................................. 189
    Context Menu ................................................................................ 203
    Dragging to a Plot Region ............................................................. 206
    The plot and plot3d Commands .................................................... 207
    The plots Package ......................................................................... 210
Multiple Plots in the Same Plot Region ................................................. 213
5.3 Customizing Plots ........................................................................... 215
   Interactive Plot Builder Options .................................................... 215
   Context Menu Options ................................................................. 216
   The plot and plot3d Options ......................................................... 219
5.4 Analyzing Plots ........................................................................... 222
   Point Probe, Rotate, Pan, and Zoom Tools .................................... 222
5.5 Creating Animations .................................................................... 222
   Interactive Plot Builder .................................................................. 223
   The plots[animate] Command ....................................................... 224
5.6 Playing Animations ..................................................................... 226
   Animation Context Bar .................................................................. 226
5.7 Customizing Animations ............................................................. 228
   Interactive Plot Builder Animation Options ................................... 228
   Context Menu Options .................................................................. 228
   The animate Command Options .................................................. 229
5.8 Exporting ..................................................................................... 230
5.9 Code for Color Plates .................................................................. 230
6 Creating Mathematical Documents ..................................................... 231
6.1 In This Chapter ............................................................................ 232
6.2 Document Formatting .................................................................. 233
   Quick Character Formatting .......................................................... 233
   Quick Paragraph Formatting ......................................................... 235
   Copy and Paste ............................................................................... 236
   Sections .......................................................................................... 237
   Display Hidden Formatting Attributes ........................................... 238
   Indentation and the Tab Key .......................................................... 238
   Character and Paragraph Styles .................................................... 239
   Document Blocks ........................................................................... 247
   Typesetting ..................................................................................... 252
   Using Tables for Layout ............................................................... 252
   Formatting Lists: Bullets, Numbers, and Indent ............................ 262
   Bookmarks ..................................................................................... 264
   Inserting Images ............................................................................. 265
   Show or Hide Worksheet Content .................................................. 266
6.3 Embedded Components ............................................................... 268
Adding Graphical Interface Components .............................................. 268
Editing Component Properties: General Process ........................... 269
Removing Graphical Interface Components .................................. 269
Example Component Properties .................................................... 270
Printing and Exporting a Document with Embedded Compon-
ents ................................................................................................. 271
6.4 Creating Graded Assignments ...................................................... 271
   Creating a Question ................................................................. 271
   Viewing Questions in Maple ..................................................... 272
   Saving Test Content ............................................................... 272
6.5 Auto-Execute ................................................................................ 272
   Setting the Auto-Execute Feature .............................................. 273
   Removing the Auto-Execute Setting ......................................... 273
   Repeating Auto-Execution ...................................................... 273
   Security Levels ........................................................................ 273
6.6 Canvas .......................................................................................... 274
   Insert a Canvas ......................................................................... 274
   Drawing .................................................................................... 275
   Canvas Style ............................................................................. 275
6.7 Spell Checking ............................................................................. 276
   How to Use the Spellcheck Utility ............................................. 277
   Selecting a Suggestion .............................................................. 277
   Spellcheck Usage and the Document ....................................... 278
   User Dictionary ........................................................................ 278
6.8 Hyperlinks .................................................................................... 279
   Inserting a Hyperlink in a Document ...................................... 280
6.9 Worksheet Compatibility ............................................................. 283
7 Maple Expressions .............................................................................. 285
7.1 In This Chapter ............................................................................ 285
7.2 Creating and Using Data Structures ............................................ 285
   Expression Sequences .............................................................. 286
   Sets .......................................................................................... 287
   Lists ......................................................................................... 288
   Arrays ...................................................................................... 289
   Tables ....................................................................................... 290
   Matrices and Vectors .............................................................. 291
10.1 In This Chapter ................................................................. 363
10.2 Writing to Files ............................................................... 363
    Saving Data to a File ......................................................... 363
    Saving Expressions to a File ............................................. 365
10.3 Reading from Files ......................................................... 366
    Reading Data from a File .................................................. 366
    Reading Expressions from a File .................................... 367
10.4 Exporting to Other Formats .............................................. 369
    Exporting Documents ...................................................... 369
    MapleNet ................................................................. 372
    Maple T.A. ................................................................. 373
10.5 Connectivity ................................................................. 374
    Translating Maple Code To Other Programming Languages ..... 374
    Accessing External Products from Maple ....................... 374
    Accessing Maple from External Products ....................... 375
Index .................................................................................... 379
List of Tables

Table 1.1: Shortcuts for Entering Mathematical Expressions .................... 6
Table 1.2: Entering a Definite Integral .................................................. 13
Table 1.3: Symbol Completion Shortcut Keys ........................................ 17
Table 1.4: Summary of Document Mode Tools ....................................... 31
Table 1.5: Maple Help Resources ......................................................... 32
Table 3.1: Select Integer Commands .................................................... 73
Table 3.2: Modular Arithmetic Operators .............................................. 76
Table 3.3: Overview of Solution Methods for Important Equation Types ......................................................... 78
Table 3.4: Sample Dimensions ............................................................. 97
Table 3.5: Scientific Constants ............................................................ 105
Table 4.1: Maple Resources for Mathematical Computation ................. 121
Table 4.2: Polynomial Arithmetic Operators ........................................ 125
Table 4.3: Polynomial Coefficient and Degree Commands ..................... 130
Table 4.4: Select Other Polynomial Commands .................................... 132
Table 4.5: Additional Polynomial Help ................................................ 133
Table 4.6: Matrix and Vector Arithmetic Operators ............................... 144
Table 4.7: Select Matrix and Vector Operators ..................................... 146
Table 4.8: Select LinearAlgebra Package Commands ............................ 148
Table 4.9: Limits ................................................................................ 152
Table 4.10: Student and Instructor Resources ........................................ 178
Table 5.1: Windows of the Interactive Plot Builder ............................... 190
Table 5.2: Displaying a Plot of a Single Variable Expression ................. 192
Table 5.3: Displaying a Plot of Multiple Expressions of 1 Variable ........ 194
Table 5.4: Displaying a Plot of a Multi-variable Expression ................... 195
Table 5.5: Displaying a Conformal Plot ............................................... 197
Table 5.6: Displaying a Plot in Polar Coordinates .................................. 199
Table 5.7: Interactive Plotting ............................................................. 201
Table 5.8: The plot and plot3d Commands ........................................... 207
Table 5.9: Customizing Plots Using Interactive Plot Builder ................. 216
Table 5.10: Customizing 2-D Plots Using the Context Menu ................. 217
Table 5.11: Customizing 3-D Plots Using the Context Menu ................. 218
Table 5.12: Popular Plot Options ......................................................... 219
Table 5.13: Plot Analysis Options ....................................................... 222
Table 5.14: Creating Animations Using the Interactive Plot Builder ..... 223
Table 5.15: The animate Command .......................................................... 225
Table 5.16: Animation Options .............................................................. 226
Table 5.17: Customizing Animations Using the Context Menu .......... 229
Table 8.1: Default Clause Values .......................................................... 327
Table 8.2: Iterative Commands .............................................................. 333
Table 8.3: The seq Command ................................................................. 333
Table 8.4: The add and mul Commands ................................................ 334
Table 8.5: The select, remove, and selectremove Commands ............... 335
Table 8.6: The map Command ............................................................... 336
Table 8.7: The zip Command ................................................................. 337
Table 10.1: Summary of Content Translation When Exporting to Different Formats ................................................................. 371
Preface

The Maple Software

The Maple software is a powerful system that you can use to solve complex mathematical problems. You can also create professional quality documents, presentations, and custom interactive computational tools in the Maple environment.

You can access the power of the Maple computational engine through a variety of interfaces.

<table>
<thead>
<tr>
<th>Interface</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard Worksheet</td>
<td>Full-featured graphical user interface offering features that help you create electronic documents that show all your assumptions, the calculations, and any margin of error in your results; or hide the computations to allow your reader to focus on the problem setup and final results. The advanced formatting features help you create the customized document you need. Because the documents are live, you can edit the parameters and, with the click of a button, compute the new results. The User Manual was created using the Standard Worksheet interface to Maple. An interactive version of this manual is available in the Standard Worksheet interface. From the Help menu, select Manuals, Dictionary, and more&gt;Manuals&gt;User Manual.</td>
</tr>
<tr>
<td>Classic Worksheet</td>
<td>Basic worksheet environment for older computers with limited memory.</td>
</tr>
<tr>
<td>Command-line version</td>
<td>Command-line interface, without graphical user interfaces features, for solving very large complex problems or batch processing with scripts.</td>
</tr>
<tr>
<td>Maplesoft™ Graphing Calculator (Microsoft® Windows® only)</td>
<td>Graphical calculator interface to the Maple computational engine. Using it, you can perform simple computations and create customizable, zoomable graphs.</td>
</tr>
</tbody>
</table>
This manual describes how to use the Standard Worksheet interface. Some features are not available in the Classic Worksheet interface and Command-line version. The Standard Worksheet interface has two modes: Document mode and Worksheet mode.

**Document Mode** - Using the Document mode, you can perform quick calculations. You can enter a mathematical expression, and then evaluate, manipulate, solve, or plot with a few keystrokes or mouse clicks.

**Worksheet Mode** - The Worksheet mode is designed for:

- Interactive use through Maple commands, which may offer advanced functionality or customized control not available using context menus or other syntax-free methods
- Programmatic use of the powerful Maple language

Using either mode, you can create high quality interactive mathematical presentations or documents.

**In This Manual**

This manual provides an overview of all Maple features including:

- Performing computations
- Creating plots and animations
- Creating interactive documents
- The Maple programming language
- Using and creating custom Maplet applications
• File input and output, and using Maple with third party products
• Data structures

For a complete list of manuals, study guides, toolboxes, and other resources, visit the Maplesoft Web site at http://www.maplesoft.com.

Audience

The information in this manual is intended for Maple users who have read the Maple Getting Started Guide.

Conventions

This manual uses the following typographical conventions.

• bold font - Maple command, package name, option name, dialog, menu, and text field
• italics - new or important concept
• Note - additional information relevant to the section
• Important - information that must be read and followed

Customer Feedback

Maplesoft welcomes your feedback. For suggestions and comments related to this and other manuals, contact doc@maplesoft.com
1 Document Mode

Using the Maple software, you can create powerful interactive documents. You can visualize and animate problems in two and three dimensions. You can solve complex problems with simple point-and-click interfaces or easy-to-modify interactive documents. You can also devise custom solutions using the Maple programming language. While you work, you can document your process, providing text descriptions.

1.1 Introduction

Maple has two modes: **Document mode** and **Worksheet mode**.

Document mode is designed for quickly performing calculations. You can enter a mathematical expression, and then evaluate, manipulate, solve, or plot it with a few keystrokes or mouse clicks. This chapter provides an overview of Document mode.

Document mode sample:

Find the value of the derivative of \( \ln(x^2 + 1) \) at \( x = 4 \).

\[
\ln(x^2 + 1) \rightarrow 2 \frac{x}{x^2 + 1} \rightarrow \frac{8}{17}
\]

Integrate \( \sin\left(\frac{1}{x}\right) \) over the interval \([0, \pi]\).

\[
\int_0^\pi \sin\left(\frac{1}{x}\right) \, dx = \sin\left(\frac{1}{\pi}\right) \pi - \text{Ci}\left(\frac{1}{\pi}\right)
\]

Worksheet mode is designed for interactive use through commands and programming using the Maple language. The Worksheet mode supports the features available in Document mode described in this chapter. After review-
Worksheet mode sample:

Find the value of the derivative of \( \ln(x^2 + 1) \) at \( x = 4 \).

\[
> \ln(x^2 + 1)
\]

\[
\ln(x^2 + 1)
\]  \hspace{1cm} \text{(1.1)}

\[
> \text{diff}(1.1, x)
\]

\[
2 \frac{x}{x^2 + 1}
\]  \hspace{1cm} \text{(1.2)}

\[
> \text{eval}(1.2, x = 4)
\]

\[
\frac{8}{17}
\]

Integrate \( \sin\left(\frac{1}{x}\right) \) over the interval \( [0, \pi] \).

\[
> \int_{0}^{\pi} \sin\left(\frac{1}{x}\right) \, dx
\]

\[
\sin\left(\frac{1}{\pi}\right) \pi - \text{Ci}\left(\frac{1}{\pi}\right)
\]

**Important:** In any Maple document, you can use Document mode and Worksheet mode.

Using either mode:
• You have access to the full mathematical engine.
• You can create high quality interactive documents: easy-to-use computational tools, presentations, or publications.

Interactive document features include:

• Embedded graphical interface components, like buttons, sliders, and check boxes
• Automatic execution of marked regions when a file is opened
• Tables
• Character and paragraph formatting styles
• Hyperlinks

These features are described in Chapter 6, *Creating Mathematical Documents* (page 231).

**Note:** This chapter was created using Document mode. All other chapters were created using Worksheet mode.

### 1.2 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simple Mathematical Expressions - Introduction to Math and Text modes, and how to easily enter simple expressions</td>
<td>• Text and Math Modes</td>
</tr>
<tr>
<td></td>
<td>• Rational Expressions</td>
</tr>
<tr>
<td></td>
<td>• Powers</td>
</tr>
<tr>
<td></td>
<td>• Products</td>
</tr>
<tr>
<td></td>
<td>• Shortcuts for Entering Mathematical Expressions</td>
</tr>
<tr>
<td></td>
<td>• Other Expressions</td>
</tr>
</tbody>
</table>
1.3 Simple Mathematical Expressions

In Document mode, you can enter two types of content: *Text* and *Math*. The *Text* mode and *Math* mode icons at the left end of the toolbar indicate the current mode. The toolbar is located near the top of the Maple window, immediately below the menu bar.

To switch between Text and Math modes, press the F5 key. (Alternatively, click the *Text* mode or *Math* mode toolbar icon.) Consequently, it is easy to enter sentences containing text and inline mathematical expressions.
Entering mathematical expressions, such as \( \frac{35}{99} + \frac{1}{9} \), \( x^2 + x \), and \( x \cdot y \), is natural in Math mode.

**Rational Expressions (Fractions)**

To enter a fraction:

1. Enter the numerator.
2. Press the forward slash (/) key.
3. Enter the denominator.
4. To exit the denominator, press the right arrow key.

**Powers**

To enter a power:

1. Enter the base.
2. Press the caret (^) key.
3. Enter the exponent, which displays in math as a superscript.
4. To exit the exponent, press the right arrow key.

**Products**

To enter a product:

1. Enter the first factor.
2. Press the asterisk (*) key, which displays in math as \( \cdot \).
3. Enter the second factor.
Implied Multiplication

In most cases, you do not need to include the multiplication operator, \( \cdot \). Insert a space character between two quantities to multiply them.

**Note:** In some cases, you do not need to enter the multiplication operator or a space character. For example, Maple interprets a number followed by a variable as multiplication.

**Important:** Maple interprets a sequence of letters, for example, \( xy \), as a single variable. To specify the product of two variables, you must insert a space character (or multiplication operator), for example, \( x \ y \) or \( x \cdot y \). For more information, refer to the ?2DMathDetails help page.

Shortcuts for Entering Mathematical Expressions

Table 1.1 lists shortcut keys for entering and navigating mathematical expressions.

**Table 1.1: Shortcuts for Entering Mathematical Expressions**

<table>
<thead>
<tr>
<th>Symbol/Format</th>
<th>Key</th>
<th>Automatically Generated in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch between Math and Text modes</td>
<td>F5</td>
<td>Example using fraction: ( \frac{1}{4} ) (Math) versus 1/4 (Text)</td>
</tr>
<tr>
<td>Fraction</td>
<td>/ (forward slash)</td>
<td>( \frac{1}{4} )</td>
</tr>
<tr>
<td>Exponent</td>
<td>^ (caret)</td>
<td>( x^2 )</td>
</tr>
<tr>
<td>Subscript</td>
<td>_ (underscore)</td>
<td>( x_a )</td>
</tr>
</tbody>
</table>
For a complete list of shortcut keys, refer to the Math Shortcut and Hints help page. To access this help page in the Maple software, in Math mode enter `?MathShortcuts` and then press Enter. For information on the Maple Help System, see Getting Help (page 32).

**Other Expressions**

It is also easy to enter mathematical expressions, such as:

- Piecewise-continuous functions:  
  \[ |x| = \begin{cases} 
  -x & x < 0 \\ 
  0 & x = 0 \\ 
  x & x > 0 
  \end{cases} \]

- Limits:  
  \[ \delta(x) = \lim_{\epsilon \to 0} \epsilon |x|^{\epsilon - 1} \]
Continued fractions: \( \sqrt{2} = 1 + \frac{1}{2 + \frac{1}{2 + \frac{1}{2 + \cdots}}}. \)

and more complex expressions. For information, see Entering Expressions (page 10).

1.4 Evaluating Expressions

To evaluate a mathematical expression, place the cursor in the expression and press \( \text{Ctrl} + \text{=}(\text{Command} + \text{=}, \text{for Macintosh}). \) That is, press and hold the \( \text{Ctrl} \) (or \( \text{Command} \)) key, and then press the equal sign (\( = \)) key.

To the right of the expression, Maple inserts an equal sign and then the value of the expression.

\[
\frac{2}{9} + \frac{7}{11} = \frac{85}{99}
\]

You can replace the inserted equal sign with text or mathematical content.

To replace the equal sign:

1. Select the equal sign. Press Delete.
2. Enter the replacement text or mathematical content.

For example, you can replace the equal sign with the text "is equal to".

\[
\frac{2}{9} + \frac{7}{11} \text{ is equal to } \frac{85}{99}
\]

In mathematical content, pressing Enter evaluates the expression and displays it centered on the following line. The cursor moves to a new line below the output.
By default, Maple labels output that is generated by pressing **Enter**. For information on equation labels, see *Equation Labels* (page 59). In this manual, labels are generally not displayed.

In text, pressing **Enter** inserts a line break.

You can use the basic algebraic operators, such as **+** and **−**, with most expressions, including polynomials—see *Polynomial Algebra* (page 124)—and matrices and vectors—see *Linear Algebra* (page 133).

\[
\frac{2}{9} + \frac{7}{11} = \frac{85}{99}
\]

\[
\frac{2}{9} + \frac{7}{11}
\]

### 1.5 Editing Expressions and Updating Output

One important feature of Maple is that your documents are *live*. That is, you can edit expressions and quickly recalculate results.

**To update one computation:**

1. Edit the expression.
2. Press **Ctrl + =** (**Command + =**, for Macintosh) or **Enter**.

The result is updated.
To update a group of computations:

1. Edit the expressions.

2. Select all edited expressions and the results to recalculate.

3. Click the Execute toolbar icon ![ Execute toolbar icon ].

All selected results are updated.

To update all output in a Maple document:

- Click the Execute All toolbar icon ![ Execute All toolbar icon ].

All results in the document are updated.

1.6 Entering Expressions

Mathematical expressions can contain the following symbols.

- Numbers: integers, rational numbers, complex numbers, floating-point values, finite field elements, $i$, $\infty$, ...

- Operators: $+$, $-$, $!$, $\times$, $\div$, $\int$, $\lim_{x \to a}$, $\frac{\partial}{\partial x}$, ...

- Constants: $\pi$, $e$, ...

- Mathematical functions: $\sin(x)$, $\cos\left(\frac{\pi}{3}\right)$, $\Gamma(2)$, ...

- Names (variables): $x$, $y$, $z$, $\alpha$, $\beta$, ...

- Data structures: sets, lists, Arrays, Vectors, Matrices, ...

Maple contains over a thousand symbols. For some numbers, operators, and names, you can press the corresponding key, for example, $9$, $=$, $>$, or $x$. Most symbols are not available on the keyboard, but you can insert them easily using two methods.

To insert a symbol, you can use:
• Palettes
• Symbol names

Palettes

Palettes are collections of related items that you can insert by clicking or dragging. Palettes contain:

• Numbers and constants, like $i$ (the imaginary unit), $\pi$, and $\infty$. For example, see the Common Symbols palette (Figure 1.1).

• Layouts, like an item with a superscript and subscript. For example, see the Layout palette (Figure 1.2).

• Mathematical operations, like a definite integral with placeholders for the integrand, variable of integration, and endpoints of the interval of integration. For example, see the Expression palette (Figure 1.3).

• Specialized tools. For example, see the Matrix palette (Figure 1.4). For information on the Matrix palette, see Creating Matrices (page 133).

Figure 1.1: Common Symbols Palette  Figure 1.2: Layout Palette
Using Palettes

To insert a palette item:

1. In the palette, click the item to insert. The item is inserted at the cursor location.

2. If the item has colored placeholders, specify values for them.
   - To move to the next placeholder, press the Tab key.

Note: You can drag palette items to any location in the document.

For example, to insert the constant $\pi$:

- In the **Common Symbols** palette, click the $\pi$ symbol.

or

- From the **Common Symbols** palette, drag the $\pi$ symbol to the appropriate location in the document.

Table 1.2 shows how to enter a definite integral.
Table 1.2: Entering a Definite Integral

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In the Expression palette, click the definite integration item $\int_{a}^{b} f , dx$. Maple inserts the definite integral. The left endpoint placeholder is selected.</td>
<td>$\int_{a}^{b} f , dx$</td>
</tr>
<tr>
<td>2. Enter 0, and then press Tab. The right endpoint placeholder is selected.</td>
<td>$\int_{0}^{b} f , dx$</td>
</tr>
<tr>
<td>3. Enter 1, and then press Tab. The integrand placeholder is selected.</td>
<td>$\int_{0}^{1} f , dx$</td>
</tr>
<tr>
<td>4. Enter $e^{-x^2}$, and then press Tab. The variable of integration placeholder is selected.</td>
<td>$\int_{0}^{1} e^{-x^2} , dx$</td>
</tr>
<tr>
<td>5. Enter x.</td>
<td>$\int_{0}^{1} e^{-x^2} , dx$</td>
</tr>
</tbody>
</table>

To evaluate the integral, press Ctrl+= (Command+=, for Macintosh) or Enter. For more information, see Computing with Palettes (page 20).
Defining a Mathematical Function

To define a function of one or two variables:

1. In the Expression palette, click one of the function definition items (Figure 1.5). Maple inserts the function definition.

2. Replace the placeholder f with the function name. Press Tab.

3. Replace the parameter placeholders, x or x1, x2, with the independent variable names. Press Tab.

4. Replace the final placeholder, y, with the expression that defines the function value. Press Enter.

   $f := x \rightarrow y$
   
   $f := (x1, x2) \rightarrow y$

Figure 1.5: Function definition palette items

For example, define a function that doubles its input.

\[
twice := x \rightarrow 2 \times x
\]

\[
x \rightarrow 2x
\]

\[
twice(1342) = 2684
\]

\[
twice(y - z) = 2y - 2z
\]

Note: To insert the right arrow symbol $\rightarrow$, you can also enter the characters - >.

Important: The expression $2 \times x$ is different from the function $x \rightarrow 2x$.

For more information on functions, see Functional Operators (page 292).
Viewing and Arranging Palettes

By default, palettes are displayed in palette docks at the sides of the Maple window. If no palette dock is visible, use the following procedure.

To view palette docks:

- From the View menu, select Palettes, and then Expand Docks.

To expand a palette in a palette dock:

- Click the triangle at the left of the palette title.

To move a palette in a palette dock:

- Drag the palette (by clicking its title) to the new location.

Adding Palettes to the Palette Docks

Maple has over 20 palettes. By default, only a few palettes are in the palette docks. To add a palette to a palette dock, use the following procedure.

To add a palette:

1. Right-click (Control-click, for Macintosh) a palette dock. Maple displays a context menu—a menu that lists actions you can perform on the object—near the palette.

2. From the context menu, select Show Palette, and then select the palette.

Handwriting Palette

Finding the right symbol to insert can be time consuming. The Handwriting palette provides an efficient way to find and insert the right symbol. You draw the symbol with your mouse and then Maple matches your input against items available in the system. See Figure 1.6.
To use the Handwriting palette:

1. With your mouse, draw a symbol in the handwriting recognition region (sketch area).

2. Click the button. A list of potential matching symbols is displayed. To view more symbols (where indicated), click the drop-down arrows associated with the displayed symbols.

3. To insert a symbol, click the displayed symbol.

Symbol Names

Each symbol has a name, and some have aliases. By entering its name (or an alias) in Math mode, you can insert the symbol.

Note: If you hover the mouse pointer over a palette item, a tooltip displays the symbol's name.
Using Symbol Names

To insert a symbol by entering its name:

1. In Math mode, enter the symbol name.

2. Press the symbol completion shortcut key. See Table 1.3.

Maple inserts the corresponding symbol.

Table 1.3: Symbol Completion Shortcut Keys

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Shortcut Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows</td>
<td>Ctrl + Space</td>
</tr>
<tr>
<td>Macintosh</td>
<td>Escape</td>
</tr>
<tr>
<td>UNIX</td>
<td>Ctrl + Shift + Space</td>
</tr>
</tbody>
</table>

For example, to find the square root of $603729$:

1. Enter $\sqrt{}$.

2. Press the completion shortcut key. Maple displays a pop-up list of exact matches $\sqrt{x}$.

3. In the completion list, select $\sqrt{x}$. Maple inserts the symbol with the placeholder selected.

4. Enter $603729$.

5. Press $\text{Ctrl} + =$ (Command $+ =$, for Macintosh).

$$\sqrt{603729} = 777$$
Using Partial Symbol Names

To enter a symbol quickly, you can enter the first few characters of its name and then press the completion shortcut key (see Table 1.3).

- If a unique symbol name matches the characters entered, Maple inserts the corresponding symbol.
- If multiple symbol names match the characters entered, Maple displays the completion list, which lists all matches. To select an item, click its name or symbol.

For example, if you enter $i$ and then press the completion shortcut key, Maple displays:

For example, to multiply two complex numbers:

- Use the symbol name and completion list to enter the imaginary unit, $i = \sqrt{-1}$.

$(-0.123 + 0.745 \cdot i) \cdot (4.2 - i) = 0.2284 + 3.2520 \cdot i$

Example: Indefinite Integral

You can enter any expression using symbol names and the completion list.

For example, to enter the indefinite integral $\int \sin(x) \, dx$: 
1. In Math mode, enter \textbf{int}. Press the completion shortcut key.

2. From the completion list, select the indefinite integral item $\int$.

3. Enter \textbf{sin(x)}.

4. Enter \textbf{d}. Press the completion shortcut key.

5. From the completion list, select \textbf{d (differential)}.

6. Enter \textbf{x}.

\textbf{Note:} From the \textbf{int} completion list, you can directly insert $\int f \, dx$.

\section*{1.7 Performing Computations}

Using the Document mode, you can access the power of the advanced Maple mathematical engine without learning Maple syntax. In addition to solving problems, you can also easily plot expressions.

The primary tools for syntax-free computation are:

- Palettes
- Context menus
- Assistants and tutors

\textbf{Note:} The Document mode is designed for quick calculations, but it also supports Maple commands. For information on commands, see \textit{Commands (page 39)} in Chapter 2, \textit{Worksheet Mode (page 35)}.

\textbf{Important:} In Document mode, you can execute a statement only if you enter it in Math mode. To use a Maple command, you must enter it in Math mode.
Computing with Palettes

As discussed in Palettes (page 11), some palettes contain mathematical operations.

To perform a computation using a palette mathematical operation:

1. In a palette that contains operators, such as the Expression palette, click an operator item.
2. In the inserted item, specify values in the placeholders.
3. To execute the operation and display the result, press Ctrl+= (Command+=, for Macintosh) or Enter.

For example, to evaluate $\int_{0}^{1} e^{-x^2} \, dx$ inline:

1. Using the Expression palette, enter the definite integral. See Table 1.2 (page 12).
2. Press Ctrl+= (Command+=, for Macintosh).

$$\int_{0}^{1} e^{-x^2} \, dx = \frac{1}{2} \text{erf}(1) \sqrt{\pi}$$

Context Menus

A context menu is a pop-up menu that lists the operations and actions you can perform on a particular expression. See Figure 1.7.
To display the context menu for an expression:

- Right-click (Control-click, for Macintosh) the expression.

The context menu is displayed beside the mouse pointer.

You can evaluate expressions using context menus.

- The **Evaluate and Display Inline** operation (see Figure 1.7) is equivalent to pressing Ctrl+= (Command+=, for Macintosh). That is, it inserts an equal sign (=) and then the value of the expression.

- The **Evaluate** operation (see Figure 1.7) is equivalent to pressing **Enter**. That is, it evaluates the expression and displays the result centered on the following line.

For more information on evaluation, see *Evaluating Expressions (page 8)*.

From the context menu, you can also select operations different from evaluation. To the right of the expression, Maple inserts a right arrow symbol (→) and then the result.
For example, use the **Approximate** operation to approximate a fraction:
\[
\frac{2}{3} \to 0.6666666667
\]

You can perform a sequence of operations by repeatedly using context menus.

For example, to compute the second derivative of \( \cos(x^2) \), use the **Differentiate** operation on the expression, and then again on the output:
\[
\cos(x^2) \to -2 \sin(x^2) x \to -4 \cos(x^2) x^2 - 2 \sin(x^2)
\]

The following subsections provide detailed instructions on performing a few of the numerous operations available using context menus. Figures in the subsections show related context menus or palettes.

**Approximating the Value of an Expression**

**To approximate a fraction numerically:**

1. Enter a fraction.

2. Display the context menu. See Figure 1.8.

3. From the context menu, select **Approximate**, and then the number of significant digits to use: 5, 10, 20, 50, or 100.
Figure 1.8: Approximating the Value of a Fraction

\[
\frac{2}{3} \rightarrow 0.666666667
\]

You can replace the inserted right arrow with text or mathematical content.

To replace the right arrow (→):

1. Select the arrow. Press Delete.
2. Enter the replacement text or mathematical content.

Note: To replace the the right arrow with text, you must first press F5 to switch to Text mode.

For example, you can replace the arrow with the text "is approximately equal to" or the symbol ≈.

\[
\frac{2}{3} \text{ is approximately equal to } 0.666666667
\]
\[ \frac{2}{3} \approx 0.666666667 \]

**Solving an Equation**

You can find an exact (symbolic) solution or an approximate (numeric) solution of an equation. For more information on symbolic and numeric computations, see *Symbolic and Numeric Computation* (page 66).

**To solve an equation:**

1. Enter an equation.
2. Display the context menu.
3. From the context menu, select *Solve* or *Solve Numerically*.

\[
\frac{7}{3} \frac{x^2}{3} - x = 12 \rightarrow \left\{ x = \frac{3}{14} + \frac{3}{14} \sqrt{113} \right\}, \left\{ x = \frac{3}{14} - \frac{3}{14} \sqrt{113} \right\}
\]

\[
\frac{7}{3} \frac{x^2}{3} - x = 12 \rightarrow \{ x = -2.063602674 \}, \{ x = 2.492174103 \}
\]

For more information on solving equations, including solving inequations, differential equations, and other types of equations, see *Solving Equations* (page 77).

**Using Units**

You can create expressions with units. To specify a unit for an expression, use the *Units* palettes. The *Units (FPS)* palette (Figure 1.9) contains important units from the foot-pound-second (FPS) system of units used in the United States. The *Units (SI)* palette (Figure 1.10) contains important units from the international system (SI) of units.
To insert an expression with a unit:

1. Enter the expression.
2. In a unit palette, click a unit symbol.

Note: To include a reciprocal unit, divide by the unit.

To evaluate an expression that contains units:

1. Enter the expression using the units palettes to insert units.
2. Right-click (Control-click, for Macintosh) the expression.
3. From the context menu, select Units and then Simplify.

For example, compute the electric current passing through a wire that conducts 590 coulombs in 2.9 seconds.

\[
\frac{590 \text{[C]}}{2.9 \text{[s]}} \rightarrow 203.4482759 \text{[A]}
\]

For more information on using units, see Units (page 96).
Assistants and Tutors

Assistants and tutors provide point-and-click interfaces with buttons, text input regions, and sliders.

Assistants

Assistants help you accomplish many tasks, such as solving ordinary differential equations (ODEs) and ODE systems, creating plots, curve fitting, importing data, and building an installer (Figure 1.11).

- From the **Tools** menu, select **Assistants**, and then one of the topic sub-menus.

![Installer Builder Assistant](image)

Figure 1.11: Installer Builder Assistant

Tutors

Over 40 interactive tutors help student users gain insight and understanding of topics in courses such as precalculus, calculus, multivariate calculus,
vector calculus, and linear algebra. Some tutors help you work through a problem step-by-step.

• From the Tools menu, select Tutors, and then one of the topic submenus.

For example, you can create a plot of the compositions of two functions using the Function Composition Tutor.

**To use the Function Composition Tutor:**

1. From the Tools menu, select Tutors, Precalculus, and then Compositions. The Function Composition Tutor is displayed. See Figure 1.12.

2. In the $f(x) =$ and $g(x) =$ text fields, enter the two functions.

3. Click the Display button. The tutor displays the compositions $g(f(x))$ and $f(g(x))$.

4. To insert the plot into your document, click the Close button.
Using a Context Menu to Launch the Plot Builder

You can plot a mathematical expression using the **Interactive Plot Builder**.

The **Plot Builder** can be launched from the **Tools** menu or the context menu for an expression.

**To create a plot using a context menu:**

1. Enter or compute a mathematical expression with one or two independent variables.
2. Right-click (Control-click, for Macintosh) the expression to plot.

3. From the context menu, select Plots, and then Plot Builder. The Interactive Plot Builder is displayed. See Figure 1.13.

4. In the Select Plot Type dialog, select the plot type, for example, 3-D plot or 2-D contour plot.

5. To immediately create a plot, click the Plot button. To customize the plot before generating it, click the Options button.

![Interactive Plot Builder: Select Plot Type Dialog](image)

Figure 1.13: Interactive Plot Builder: Select Plot Type Dialog

For example, Figure 1.14 shows a plot of $x^2 + y^2$. 
$x^2 + y^2 \rightarrow$

Figure 1.14: 3-D Plot of an Expression

For more information on plots, see *Plots and Animations* (page 187).

1.8 Document Mode Summary

The key features of Document mode are summarized in Table 1.4.
## Table 1.4: Summary of Document Mode Tools

<table>
<thead>
<tr>
<th>Action</th>
<th>Methods</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Entering Mathematical Expressions</strong>&lt;br&gt;For example: &lt;br&gt;$\sin\left(\frac{\pi}{3}\right) + i\cos\left(\frac{\pi}{4}\right)$&lt;br&gt;$\int_{0}^{1.9} x^2 \sin(x^2 + 1) , dx$</td>
<td>• Math editing shortcut keys, including symbol name completion&lt;br&gt;• Palettes</td>
</tr>
</tbody>
</table>
| **Evaluating Mathematical Expressions**<br>(Result Inline)*<br>For example:<br>$\sin\left(\frac{\pi}{3}\right) + i\cos\left(\frac{\pi}{4}\right) = \frac{1}{2} \sqrt{3} + \frac{1}{2} i \sqrt{2}$ | • $\text{Ctrl} + = \text{(Command} + =, \text{for Macintosh)}$
• From the context menu, select **Evaluate and Display Inline**. |
| **Evaluating Mathematical Expressions**<br>(Result Centered on Following Line)<br>For example:<br>$\int_{0}^{1.9} x^2 \sin(x^2 + 1) \, dx$ | • **Enter** key<br>• From the context menu, select **Evaluate**. |
| **Performing Computations and Other Operations on Expressions**<br>For example, differentiate an expression:<br>$\sin(x^2 + 1) \rightarrow 2 \cos(x^2 + 1) \, x$ | • Context menus<br>• Assistants<br>• Tutors |
| **Executing a Group of Evaluations, Computations, or Other Operations** | • Execute toolbar icon ![](image)
• Execute All toolbar icon !!! |

* Inline evaluation is available in Document mode and document blocks. For information on document blocks, see *Document Blocks (page 247)*.
1.9 Getting Help

The Maple Help System contains resources to help you use Maple. See Table 1.5.

Table 1.5: Maple Help Resources

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
</tr>
</thead>
</table>
| Maple Tour        | An interactive overview of Maple.  
|                   | • From the Help menu, select Take a Tour of Maple. |
| Online Manuals    | Online manuals, including the Maple Getting Started Guide and this manual. You can execute examples, copy content into other documents, and search the contents using the Maple Help System.  
|                   | The Maple Getting Started Guide provides extensive information for new users on using Maple and the resources available on the Maplesoft Web site (http://www.maplesoft.com). Each procedure and concept is accompanied by visual depictions of actions to help you identify Maple resources and tools.  
|                   | • From the Help menu, select Manuals, Dictionary, and more>Manu als. |
| Quick Help        | A list of key commands and concepts.  
|                   | • From the Help menu, select Quick Help. Alternatively, press F1. For additional information, click an item in the Quick Help. |
| Quick Reference   | A table of commands and information for new users that opens in a new window. It contains hyperlinks to help pages for more information.  
<p>|                   | • From the Help menu, select Quick Reference. Alternatively, press Ctrl + F2 (Command + F2, for Macintosh). |</p>
<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
</tr>
</thead>
</table>
| Help Pages                     | Help for Maple features, commands, packages, and more. Help pages include examples and screenshots to help you quickly learn.  
• From the Help menu, select Maple Help. You can search for a help topic, perform a text search, or browse the Table of Contents. You can also open a help page by entering ?<topic_name> at the input prompt (in Worksheet mode) or in Math mode (in Document mode). |
| Task Templates                 | Set of commands with placeholders that you can use to quickly perform a task.  
• From the Tools menu, select Tasks, and then Browse.                                                                                     |
| Applications and Example       | Executable documents that demonstrate the power and flexibility of the Maple interactive document or provide an overview of computations in a particular field.  
• From the Help menu, select Manuals, Dictionary, and more, and then Applications and Examples.                                             |
| Worksheets                     | Over 5000 definitions, including 300 figures and plots.  
• From the Help menu, select Manuals, Dictionary, and more, and then Dictionary.                                                             |
| Mathematics and Engineering    |                                                                                                                                                                                                            |
| Dictionary                     |                                                                                                                                                                                                            |

For a complete list of resources, refer to the ?MapleResources help page.

For more information on the Maple Help System, refer to the Maple Getting Started Guide.
2 Worksheet Mode

The Worksheet mode of the Standard Worksheet interface is designed for:

- Interactive use through Maple commands, which may offer advanced functionality or customized control not available using context menus or other syntax-free methods
- Programming using the powerful Maple language

Using Worksheet mode, you have access to most of the Maple features described in Chapter 1 including:

- Math and Text modes
- Palettes
- Context menus
- Assistants and tutors

For information on these features, see Chapter 1, Document Mode (page 1). (For a summary, see Table 1.4 (page 30).)

Note: Using a document block, you can use all Document mode features in Worksheet mode. For information on document blocks, see Document Blocks (page 247).

Note: This chapter and the following chapters were created using Worksheet mode.
### 2.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input Prompt - Where you enter input</td>
<td>• The Input Prompt (&gt;)</td>
</tr>
<tr>
<td></td>
<td>• Suppressing Output</td>
</tr>
<tr>
<td></td>
<td>• 2-D and 1-D Math Input</td>
</tr>
<tr>
<td></td>
<td>• Input Separators</td>
</tr>
<tr>
<td>Commands - Thousands of routines for</td>
<td>• The Maple Library</td>
</tr>
<tr>
<td>performing computations and other operations</td>
<td>• Top-Level Commands</td>
</tr>
<tr>
<td></td>
<td>• Package Commands</td>
</tr>
<tr>
<td>Palettes - Items that you can insert by</td>
<td>• Using Palettes</td>
</tr>
<tr>
<td>clicking or dragging</td>
<td></td>
</tr>
<tr>
<td>Context Menus - Pop-up menus of common</td>
<td>• Using Context Menus</td>
</tr>
<tr>
<td>operations</td>
<td></td>
</tr>
<tr>
<td>Assistants and Tutors - Graphical interfaces</td>
<td>• Launching Assistants and Tutors</td>
</tr>
<tr>
<td>with buttons and sliders</td>
<td>• Example: Using the Interactive Plot Builder</td>
</tr>
<tr>
<td>Task Templates - Sets of commands with</td>
<td>• Viewing Task Templates</td>
</tr>
<tr>
<td>placeholders that you can insert and use to</td>
<td>• Inserting a Task Template</td>
</tr>
<tr>
<td>perform a task</td>
<td>• Performing the Task</td>
</tr>
<tr>
<td>Text Regions - Areas in the document in</td>
<td>• Inserting a Text Region</td>
</tr>
<tr>
<td>which you can enter text</td>
<td>• Formatting Text</td>
</tr>
<tr>
<td>Names - References to the expressions you</td>
<td>• Assigning to Names</td>
</tr>
<tr>
<td>assign to them</td>
<td>• Unassigning Names</td>
</tr>
<tr>
<td></td>
<td>• Valid Names</td>
</tr>
</tbody>
</table>
### 2.2 Input Prompt

In Worksheet mode, you enter input at the Maple *input prompt* (>). The default mode for input is Math mode (*2-D Math*).

To evaluate input:

- Press **Enter**.

Maple displays the result (output) below the input.

For example, to find the value of $\sin^3\left(\frac{\pi}{3}\right)$, enter the expression, and then press **Enter**.

\[
> \sin^3\left(\frac{\pi}{3}\right)
\]

\[
= \frac{3}{8} \sqrt{3}
\]

For example, compute the sum of two fractions.

\[
> \frac{2}{9} + \frac{7}{11}
\]
Suppressing Output

To suppress the output, enter a colon (:) at the end of the input.

\[
> \frac{2}{9} + \frac{7}{11} : 
\]

A set of Maple input and its output are referred to as an *execution group*.

1-D Math Input

You can also insert input using Text mode (*1-D Math*). The input is entered as a one-dimensional sequence of characters. 1-D Math input is red.

**To enter input using 1-D Math:**

- At the input prompt, press **F5** to switch from 2-D Math to 1-D Math.

\[
> 123^2 - \frac{29857}{120}; 
\]

\[
\frac{1785623}{120} 
\]

**Important:** 1-D Math input must end with a semicolon or colon. If you use a semicolon, Maple displays the output. If you use a colon, Maple suppresses the output.

\[
> 123^2 - \frac{29857}{120}: 
\]

**To set the default input mode to 1-D Math:**

1. From the **Tools** menu, select **Options**. The **Options** dialog is displayed.
2. On the **Display** tab, in the **Input display** drop-down list, select **Maple Notation**.

3. Click **Apply to Session** (to set for only the current session) or **Apply Globally** (to set for all Maple sessions).

**To convert 2-D Math input to 1-D Math input:**

1. Select the 2-D Math input.

2. From the **Format** menu, select **Convert To**, and then **1-D Math Input**.

**Important:** In Document mode, you can execute a statement *only if* you enter it in Math mode.

### Input Separators

In 1-D and 2-D Math input, you can use a semicolon or colon to separate multiple inputs in the same input line.

\[
> \sqrt{4.4} ; \tan(3.2)
\]

\[
2.097617696
\]

\[
0.05847385446
\]

If you do not specify a semicolon or colon, Maple interprets it as a single input.

\[
> \sqrt{4.4} \tan(3.2)
\]

\[
0.1226557919
\]

### 2.3 Commands

Maple contains a large set of commands and a powerful programming language. Most Maple commands are written using the Maple programming language.
You can enter commands using 1-D or 2-D Math. You must use 1-D Math input when programming in Maple. *Basic Programming (page 321)* provides an introduction to Maple programming.

To learn how to use Maple commands, use task templates. See *Task Templates (page 51)*.

**The Maple Library**

Commands are contained in the Maple library, which is divided into two groups: the *top-level commands* and *packages*.

- The top-level commands are the most frequently used Maple commands.
- Packages contain related specialized commands in areas such as student calculus, linear algebra, vector calculus, and code generation.

For a complete list of packages and commands, refer to the *index* help pages. To access the index overview help page, enter `?index`, and then press Enter. For information on the Maple Help System, see *Getting Help (page 32)*.

**Top-Level Commands**

To use a top-level command, enter its name followed by parentheses (( )) containing any parameters. This is referred to as a *calling sequence* for the command.

```
command(arguments)
```

**Note:** In 1-D Math input, include a semicolon or colon at the end of the calling sequence.

For example, to differentiate an expression, use the *diff* command. The required parameters are the expression to differentiate, which must be specified first, and the independent variable.
For a complete list of functions (commands that implement mathematical functions), for example, BesselI and AiryAi, available in the library, refer to the ?initialfunctions help page. (To display this help page, enter ?initialfunctions at the input prompt.)

```
> diff( tan(x) sin(x) , x)

(1 + tan(x)^2) sin(x) + tan(x) cos(x)
```

For detailed information on the properties of a function, use the FunctionAdvisor command.

```
> FunctionAdvisor( 'definition', BesselI)

\[
\mathrm{I}_a(z) = \frac{\, _0F_1 \left( ; 1 + a ; \frac{z^2}{4} \right) }{\Gamma (1 + a) \, 2^a}, \text{ with no restrictions on } (a, z)
\]
```

For detailed information on how to use a function in Maple, refer to its help page.

For example:

```
> ?Bessel
```

**Note:** In 1-D and 2-D Math input, when accessing a help page using ?, you do not need to include a trailing semicolon or colon.

## Package Commands

To use a package command, the calling sequence must include the package name, and the command name enclosed in brackets ([ ]).

If you are frequently using the commands in a package, load the package.

**To load a package:**

- Use the `with` command, specifying the package as an argument.

The `with` command displays a list of the package commands loaded (unless you suppress the output by entering a colon at the end of the calling sequence).

After loading a package, you can use its commands as top-level commands, that is, without specifying the package name.

For example, use the `NLPSolve` command from the `Optimization` package to find a *local* minimum of an expression and the value of the independent variable at which the minimum occurs.

```plaintext
> Optimization[NLPSolve](\frac{\sin(x)}{x}, x = 1 .. 15)

[-0.0913252028230576718, [x = 10.9041216700744900]]
```

```plaintext
> with(Optimization):

> NLPSolve(\frac{\sin(x)}{x}, x = 1 .. 15)

[-0.0913252028230576718, [x = 10.9041216700744900]]
```

For more information on optimization, see *Optimization* (page 166).
To unload a package:

• Use the `unwith` command, specifying the package as an argument.

```
> unwith(Optimization);
```

To use the examples in this manual, you may be required to use the `unwith` command between examples.

Some packages contain commands that have the same name as a top-level command. When you load one of these packages, Maple returns a warning.

For example, the `plots` package contains a `changecoords` command. Maple also contains a top-level `changecoords` command.

```
> with(plots):
Warning, the name changecoords has been redefined
```

In general, this manual does not include the warning messages Maple returns.

To use the top-level command, unload the package. (For alternative methods of accessing the top-level command, see the `?with` help page.)


2.4 Palettes

Palettes are collections of related items that you can insert by clicking or dragging. See Figure 2.1.

![Expression Palette](image)

You can use palettes to enter input.

For example, evaluate a definite integral using the definite integration item in the Expression palette.

\[
\int_a^b f(x) \, dx
\]

In 2-D Math, clicking the definite integration item inserts:

\[
> \int_a^b f(x) \, dx
\]

1. Enter values in the placeholders. To move to the next placeholder, press Tab. **Note:** If pressing the Tab key inserts a tab, click the Tab icon in the toolbar.
2. To evaluate the integral, press **Enter**.

\[
\int_{0}^{1} \tanh(x) \, dx
\]

\[- \ln(2) + \ln\left(e^{-1} + e\right)\]

In 1-D Math, clicking the definite integration item inserts the corresponding command calling sequence.

\[> \text{int}(f, x = a..b);\]

Specify the problem values (using the **Tab** to move to the next placeholder), and then press **Enter**.

\[> \text{int}(\tanh(x), x = 0..1):\]

**Note:** Some palette items cannot be inserted into 1-D Math because they are not defined in the Maple language. When the cursor is in 1-D Math input, unavailable palette items are dimmed.

For more information on palettes, see *Palettes (page 11)* and *Performing Computations (page 19)* in Chapter 1.
2.5 Context Menus

A context menu is a pop-up menu that lists the operations and actions you can perform on a particular expression. See Figure 2.2.

![Context Menu Example]

**Figure 2.2: Integer Context Menu**

In Worksheet mode, you can use context menus to perform operations on 2-D Math and output.

**To use a context menu:**

1. Right-click (Control-click, for Macintosh) the expression. The context menu is displayed.

2. From the context menu, select an operation.

Maple inserts a new execution group containing:

- The calling sequence that performs the operation
- The result of the operation
For example:

To determine a rational expression (fraction) that approximates a floating-point number:

1. Right-click (Control-click, for Macintosh) the floating-point number.

2. From the context menu, select Conversions, and then Rational.

The inserted calling sequence includes an equation label reference to the number you are converting.

\[
> 0.3463678 + 1.7643
\]

\[
= 2.1106678 \quad \text{(2.1)}
\]

\[
> \text{convert( (2.1),'rational' )}
\]

\[
\frac{32270}{15289}
\]

For information on equation labels and equation label references, see Equation Labels (page 59).

For more information on context menus, see Context Menus (page 20) in Chapter 1.
2.6 Assistants and Tutors

Assistants and tutors provide point-and-click interfaces, with buttons, text input regions, and sliders. See Figure 2.3.

![Interactive Plot Builder: Select Plot Type Dialog](image)

**Figure 2.3: Interactive Plot Builder: Select Plot Type Dialog**

**Launching an Assistant or Tutor**

To launch an assistant or tutor:

1. Open the **Tools** menu.
2. Select **Assistants** or **Tutors**.
3. Navigate to and select one of the assistants or tutors.
Example: Using the Interactive Plot Builder

To plot an expression using the Interactive Plot Builder:

1. From the Tools menu, select Assistants, and then Plot Builder. Maple inserts the following command in the document and launches the Interactive Plot Builder.

   > plots[interactive]();

2. In the Interactive Plot Builder: Specify Expressions window (Figure 2.4), click Add. The Add/Edit Expression dialog is displayed.

![Interactive Plot Builder: Specify Expressions Window](image)

Figure 2.4: Interactive Plot Builder: Specify Expressions Window
3. In the **Add/Edit Expression** dialog, enter the expression to plot using 1-D Math. See Figure 2.5.

![Add/Edit Expression Dialog](image)

**Figure 2.5: Interactive Plot Builder: Add/Edit Expression Dialog**

4. Repeat steps 2 and 3 for each expression to add to the plot.

5. After adding the expressions, in the **Interactive Plot Builder: Specify Expressions** window (Figure 2.4), click **Done**.

6. In the **Interactive Plot Builder: Select Plot Type** dialog (Figure 2.3), select the type of plot, for example, **3-D Plot** or **3-D Contour Plot**, and specify the variable ranges, for example, \( x = [-2, 2], y = [-2, 2] \).

7. To immediately create a plot, click **Plot**. To customize the plot before generating it, click **Options**. Set the plot options, and then click **Plot**.

Maple inserts the plot in the document.
For more information on assistants and tutors, see Assistants and Tutors (page 26) in Chapter 1.

2.7 Task Templates

Maple can solve a diverse set of problems. The task template facility helps you quickly find and use the commands required to perform common tasks.

After inserting a task template, specify the parameters of your problem in the placeholders, and then execute the commands, or click a button.

Viewing Task Templates

The Task Browser (Figure 2.6) organizes task templates by subject.

To launch the Task Browser:

- From the Tools menu, select Tasks, and then Browse.
You can also browse the task templates in the Table of Contents of the Maple Help System.

![Task Browser](image)

**Figure 2.6: Task Browser**

**Inserting a Task Template**

To insert a task template from the Task Browser or Help Navigator:

1. Navigate to the task.

2. Click one of the insertion or copy buttons.

```latex
\textbf{Volume of Revolution}

\textbf{Description}

Calculate the \textit{volume of revolution} for a specified univariate function rotated about the horizontal axis.

Enter the function as an expression.

\begin{verbatim}
> \sin(x) \cos(x) + 1
\sin(x) \cos(x) + 1
\end{verbatim}

Specify the range of revolution, and then calculate the volume of revolution.

\begin{verbatim}
> \nu = \text{Student[Calculus1][VolumeOfRevolution]}((1), 0 \frac{\pi}{2})
\nu := \pi + \frac{9 \pi^2}{16}
\end{verbatim}

Alternatively, you can use the \textit{Volumes of Revolution} tutor, a point-and-click interface. There are two ways to launch this tutor:

- From the \textbf{Tools} menu, select \textbf{Tutors, Calculus - Single Variable}, and then \textbf{Volumes of Revolution}.

- Click the following \textbf{Volumes of Revolution} button.

\begin{verbatim}
> Volumes of Revolution \cos(x)
\end{verbatim}
```
• Click the **Insert Default Content** button. Maple inserts the *default content*. The default content level is set using the **Options** dialog. For details, see the following steps.

• Click the **Insert Minimal Content** button. Maple inserts only the commands and embedded components, for example, a button to launch the related assistant or tutor.

• Click the **Copy Task to Clipboard** button. Place the cursor where you want to insert the task, and then paste the task. Maple inserts the default content. Use this method to quickly insert a task multiple times.

To change the default content level, use the **Options** dialog.

1. From the **Tools** menu, select **Options**. The **Options** dialog opens.

2. In the **Options** dialog, select the **Display** tab.

3. In the **Task content to insert** drop-down list, select **All Content**, **Standard Content**, or **Minimal Content**.
   - Minimal Content - Only the commands and embedded components
   - Standard Content - Commands, embedded components, and instructions for using the template
   - All Content - All content in the task template, including hyperlinks to related help pages

Maple stores a list of the most recently inserted task templates.

To insert a recently inserted task:

• From the **Tools** menu, select **Tasks**, and then the task name.

Maple inserts the default content.

**Performing the Task**

After you insert a task template, enter the parameters for your task, and then compute the result.
To use an inserted task template:

1. Specify values for the parameters in placeholders or using graphical interface components. You can move to the next placeholder by pressing Tab.

2. Execute all commands in the task by:
   • Placing the cursor in the first task command, and then pressing Enter repeatedly to execute each command.
   • Selecting all the template commands, and then clicking the execute toolbar icon !.

3. If the template contains a button that computes the result, click it.

For more information on task templates, refer to the Maple Getting Started Guide or the ?tasks help page.

## 2.8 Text Regions

To add descriptive text in Worksheet mode, use a text region.

To insert a text region:

• In the toolbar, click the Text region icon T.

The default mode in a text region is Text mode.

In a text region, you can:

• Enter text with inline mathematical content by switching between Text and Math modes. To toggle between Text mode and Math mode, press F5. **Note:** The mathematical content in a text region is not evaluated. To enter mathematical content that is evaluated, enter it at an Input Prompt (page 37).

• Insert any palette item. Palette items are inserted in Math mode (2-D Math).
You can format text in a text region. Features include:

- Character styles
- Paragraph styles
- Sections and subsections
- Tables

For more information on formatting documents, see *Creating Mathematical Documents* (page 231).

## 2.9 Names

Instead of re-entering an expression every time you need it, you can assign it to a *name* or add an *equation label* to it. Then you can quickly refer to the expression using the name or an equation label reference. For information on labels, see the following section *Equation Labels* (page 59).

### Assigning to Names

You can assign any Maple expression to a name: numeric values, data structures, procedures (a type of Maple program), and other Maple objects.

Initially, the value of a name is itself.

```maple
> a

a
```

The assignment operator (`:=`) associates an expression with a name.

```maple
> a := π

a := π
```
Recall that you can enter $\pi$ using the following two methods.

- Use the **Common Symbols** palette
- In 2-D Math enter $pi$, and then press the symbol completion short cut key. See *Shortcuts for Entering Mathematical Expressions (page 6)*.

When Maple evaluates an expression that contains a name, it replaces the name with its value. For example:

```maple
> cos(a)
```

-1

For information on Maple evaluation rules, see *Evaluating Expressions (page 310)*.

**Mathematical Functions**

To define a function, assign it to a name.

For example, define a function that computes the cube of its argument.

```maple
> cube := x \rightarrow x^3;
```

For information on creating functions, see *Defining a Mathematical Function (page 14)*.

```maple
> cube(3); cube(1.666)
```

27

4.624076296

**Note:** To insert the right arrow, enter the characters ->. In 2-D Math, Maple replaces -> with the right arrow symbol $\rightarrow$. In 1-D Math, the characters are not replaced.
For example, define a function that squares its argument.

> square := x -> x^2:

> square(32);

1024

For more information on functions, see *Functional Operators* (page 292).

**Protected Names**

Protected names are valid names that are predefined or reserved.

If you attempt to assign to a protected name, Maple returns an error.

> sin := 2

Error, attempting to assign to `sin` which is protected

For more information, refer to the ?type/protected and ?protect help pages.

**Unassigning Names**

The unassign command resets the value of a name to itself. **Note:** You must enclose the name in right single quotes (')

> unassign( 'a' )

> a

a

Right single quotes (*unevaluation quotes*) prevent Maple from evaluating the name. For more information on unevaluation quotes, see *Delaying Evaluation* (page 317) or refer to the ?uneval help page.

See also *Unassigning a Name Using Unevaluation Quotes* (page 319).
Unassigning All Names

The restart command clears the Maple internal memory. The effects include unassigning all names and unloading all packages. For more information, refer to the ?restart help page.

Note: To use the examples in this manual, you may be required to use the unassign or restart command between examples.

Valid Names

A Maple name must be one of the following.

- A sequence of alphanumeric and underscore (_) characters that begins with an alphabetical character. Note: To enter an underscore character in 2-D Math, enter a backslash character followed by an underscore character, that is, \_.

- A sequence of characters enclosed in left single quotes (``).

Important: Do not begin a name with an underscore character. Maple reserves names that begin with an underscore for use by the Maple library.

Examples of valid names:

- a
- a1
- polynomial
- polynomial1_divided_by_polynomial2
- `2a`
- `x#y`
- `x y`
2.10 Equation Labels

Maple marks the output of each execution group with a unique equation label.

Note: The equation label is displayed to the right of the output.

\[
\int \sin(x) \, dx
\]

\[= \cos(x) \quad (2.2)\]

Using equation labels, you can refer to the result in other computations.

\[
\int (2.2) \, dx
\]

\[= \sin(x) \quad (2.3)\]

Displaying Equation Labels

Important: By default, equation labels are displayed. If equation label display is turned off, complete both the following operations.

- From the Format menu, select Labels, and then ensure that Worksheet is selected.
- In the Options dialog (Tools>Options), on the Display tab, ensure that Show equation labels is selected.

Referring to a Previous Result

Instead of re-entering previous results in computations, you can use equation label references. Each time you need to refer to a previous result, insert an equation label reference.
To insert an equation label reference:

- From the **Insert** menu, select **Label**. (Alternatively, press **Ctrl+L**. For Macintosh, **Command+L**.)
- In the **Insert Label** dialog, enter the label value, and then click **OK**.

Maple inserts the reference.

For example:

**To integrate the product of (2.2) and (2.3):**

1. In the **Expression** palette, click the indefinite integration item \( \int \). The item is inserted and the cursor moves to the integrand placeholder.
3. In the **Insert Label** dialog, enter \( 2.2 \). Click **OK**.
4. Press \( * \).
5. Press **Ctrl+L** (**Command+L**, for Macintosh).
6. In the **Insert Label** dialog, enter \( 2.3 \). Click **OK**.
7. To move to the variable of integration placeholder, press **Tab**.
8. Enter \( x \). Press **Enter**.

\[
\int (2.2) \cdot (2.3) \, dx
\]

\[
\frac{1}{2} \sin(x)^2
\]
Execution Groups with Multiple Outputs

An equation label is associated with the last output within an execution group.

\[
> \left( \frac{2}{3.5} \right)^2 \cos \left( \frac{\pi}{6} \right)
\]

\[
0.3265306122
\]

\[
\frac{1}{2} \sqrt{3}
\]  

(2.4)

\[
> (2.4)^2
\]

\[
\frac{3}{4}
\]

Label Numbering Schemes

You can number equation labels in two ways:

- **Flat** - Each label is a single number, for example, 1, 2, or 3.
- **Sections** - Each label is numbered according to the section in which it occurs. For example, 2.1 is the first equation in the second section, and 1.3.2 is the second equation in the third subsection of the first section.

To change the equation label numbering scheme:

- From the Format menu, select Labels, and then Label Display. In the Format Labels dialog (Figure 2.7), select one of the formats.
- Optionally, enter a prefix.
Features of Equation Labels

Although equation labels are not descriptive names, labels offer other important features.

- Each label is unique, whereas a name may be inadvertently assigned more than once for different purposes.
- Maple labels the output values sequentially. If you remove or insert an output, Maple automatically renumbers all equation labels and updates the label references.
- If you change the equation label format (see Label Numbering Schemes (page 61)), Maple automatically updates all equation labels and label references.

For information on assigning to, using, and unassigning names, see Names (page 55).

For more information on equation labels, refer to the ?equationlabels help page.

The following chapters describe how to use Maple to perform tasks such as solving differential (and other types of) equations, producing plots and anim-
ations, and creating mathematical documents. The chapters were created using Worksheet mode. Except where noted, all features are available in both Worksheet mode and Document mode.
3 Performing Computations

This chapter discusses key concepts related to performing computations with Maple. It discusses important features that are relevant to all Maple users. After learning about these concepts, you will learn how to use Maple to solve problems in specific areas in the following chapter.

3.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Symbolic and Numeric Computation - An overview of exact and floating-point computation | • Exact Computations  
• Floating-Point Computations  
• Converting Exact Quantities to Floating-Point Values  
• Sources of Error |
| Integer Operations - How to perform integer computations | • Important Integer Commands  
• Non-Base 10 Numbers  
• Finite Rings and Fields  
• Gaussian Integers |
| Solving - How to solve standard mathematical equations | • Equations and Inequalities  
• Ordinary Differential Equations  
• Partial Differential Equations  
• Integer Equations  
• Integer Equations in a Finite Field  
• Linear Systems  
• Recurrence Relations |
<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Units, Scientific Constants, and Uncertainty</td>
<td>Units</td>
</tr>
<tr>
<td>- How to construct and compute with expressions that have units, scientific constants, or uncertainty</td>
<td>• Conversions</td>
</tr>
<tr>
<td></td>
<td>• Applying Units to an Expression</td>
</tr>
<tr>
<td></td>
<td>• Performing Computations with Units</td>
</tr>
<tr>
<td></td>
<td>• Changing the Current System of Units</td>
</tr>
<tr>
<td></td>
<td>• Extensibility</td>
</tr>
<tr>
<td></td>
<td>Scientific Constants</td>
</tr>
<tr>
<td></td>
<td>• Scientific Constants</td>
</tr>
<tr>
<td></td>
<td>• Element and Isotope Properties</td>
</tr>
<tr>
<td></td>
<td>• Value, Units, and Uncertainty</td>
</tr>
<tr>
<td></td>
<td>• Performing Computations</td>
</tr>
<tr>
<td></td>
<td>• Modification and Extensibility</td>
</tr>
<tr>
<td></td>
<td>Uncertainty Propagation</td>
</tr>
<tr>
<td></td>
<td>• Quantities with Uncertainty</td>
</tr>
<tr>
<td></td>
<td>• Performing Computations with Quantities with Uncertainty</td>
</tr>
<tr>
<td>Restricting the Domain - How to restrict the domain for computations</td>
<td>• Real Number Domain</td>
</tr>
<tr>
<td></td>
<td>• Assumptions on Variables</td>
</tr>
</tbody>
</table>

### 3.2 Symbolic and Numeric Computation

*Symbolic computation* is the mathematical manipulation of expressions involving symbolic or abstract quantities, such as variables, functions, and operators; and exact numbers, such as integers, rationals, $\pi$, and $e^2$. The goal of such manipulations may be to transform an expression to a simpler form or to relate the expression to other, better understood formulas.
**Numeric computation** is the manipulation of expressions in the context of finite-precision arithmetic. Expressions involving exact numbers, for example, \( \sqrt{2} \), are replaced by close approximations using floating-point numbers, for example 1.41421. These computations generally involve some error. Understanding and controlling this error is often of as much importance as the computed result.

In Maple, numeric computation is normally performed if you use floating-point numbers (numbers containing a decimal point) or the `evalf` command. The `plot` command (see *Plots and Animations (page 187)*) uses numeric computation, while commands such as `int`, `limit`, and `gcd` (see *Integer Operations (page 71)* and *Mathematical Computations (page 121)*) generally use only symbolic computation to achieve their results.

### Exact Computations

In Maple, integers, rational numbers, mathematical constants such as \( \pi \) and \( \infty \), and mathematical structures such as matrices with these as entries are treated as exact quantities. Names, such as \( x \), \( y \), \( my\_variable \), and mathematical functions, such as \( \sin(x) \) and \( \text{LambertW}(k, z) \), are **symbolic** objects. Names can be assigned exact quantities as their values, and functions can be evaluated at symbolic or exact arguments.

\[
> \frac{3}{2} + \frac{1}{3}, 1 + \frac{\pi}{2}
\]

\[
\frac{11}{6}, 1 + \frac{1}{2} \pi
\]

**Important:** Unless requested to do otherwise (see the following section), Maple evaluates expressions containing exact quantities to exact results, as you would do if you were performing the calculation by hand, and not to numeric approximations, as you normally obtain from a standard hand-held calculator.
Floating-Point Computations

In some situations, a numeric approximation of an exact quantity is required. For example, the `plot` command requires the expression it is plotting to evaluate to numeric values that can be rendered on the screen: \( \pi \) cannot be so rendered, but \( 3.14159 \) can be. Maple distinguishes *approximate* from *exact* quantities by the presence or absence of a decimal point: \( 1.9 \) is approximate, while \( \frac{19}{10} \) is exact.

**Note:** An alternative representation of floating-point numbers, called *e-notation*, may not include an explicit decimal point: \( 1e5 = 100000. \), \( 3e-2 = .03 \).

In the presence of a floating-point (approximate) quantity in an expression, Maple generally computes using numeric approximations. Arithmetic involving mixed exact and floating-point quantities results in a floating-point result.

\[
> \sin(1), \sin(\pi), \sin(x)
\]
\[
\begin{align*}
\sin(1), & \ 0, & \ \sin(x) \\
\end{align*}
\]

\[
> \int \tan(t) \ dt
\]
\[
\begin{align*}
& - \ln( \cos(t) ) \\
\end{align*}
\]

\[
> \sqrt{32}
\]
\[
4 \sqrt{2}
\]
If a mathematical function is passed a floating-point argument, it normally attempts to produce a floating-point approximation to the result.

\[ \sin(1.5), \int_{0.0}^{1.0} e^x \, dx \]

0.9974949866, 1.718281828

Converting Exact Quantities to Floating-Point Values

To convert an exact quantity to a numeric approximation of that quantity, use the `evalf` command or the `Approximate` context menu operation (see Approximating the Value of an Expression (page 22)).

\[ \text{evalf}(\pi), \text{evalf}(\sin(3)), \text{evalf}\left(\frac{3}{2} + \frac{1}{3}\right) \]

3.141592654, 0.1411200081, 1.833333333

By default, Maple computes such approximations using 10 digit arithmetic. You can modify this in one of two ways:

- **Locally**, you can pass the precision as an index to the `evalf` call.

\[ \text{evalf}[20](\exp(2)), \text{evalf}\left(\Gamma\left(\frac{2}{3}\right)\right) \]

7.3890560989306502272, 1.354117939

- **Globally**, you can set the value of the `Digits` environment variable.

\[ \text{Digits} := 5; \]
For more information, see the \texttt{evalf} and \texttt{Digits} help pages.

\textbf{Note:} When appropriate, Maple performs floating-point computations directly using your computer's underlying hardware.

\section*{Sources of Error}

By its nature, floating-point computation normally involves some error. Controlling the effect of this error is the subject of active research in Numerical Analysis. Some sources of error are:

\begin{itemize}
  \item An exact quantity may not be exactly representable in decimal form: \( \frac{1}{3} \) and \( \pi \) are examples.
  
  \item Small errors can accumulate after many arithmetic operations.
  
  \item Subtraction of nearly equal quantities can result in essentially no useful information. For example, consider the computation \( x - \sin(x) \) for \( x \approx 0 \).
\end{itemize}

\begin{verbatim}
> evalf(tan(Pi/3))
1.7321
\end{verbatim}

No correct digits remain. If, however, you use Maple to analyze this expression, and replace this form with a representation that is more accurate for small values of \( x \), a fully accurate 10-digit result can be obtained.

\begin{verbatim}
> t := taylor(x - sin(x), x)
\end{verbatim}
For information on evaluating an expression at a point, see *Substituting a Value for a Subexpression* (page 310). For information on creating a series approximation, see *Series* (page 159).

For more information on floating-point numbers, refer to the `?float` and `?type/float` help pages.

### 3.3 Integer Operations

In addition to the basic arithmetic operators, Maple has many specialized commands for performing more complicated integer computations, such as factoring an integer, testing whether an integer is a prime number, and determining the greatest common divisor (GCD) of a pair of integers.

**Note:** Many integer operations are available as task templates (`Tools>Tasks>Browse`).

You can quickly perform many integer operations using context menus. Selecting an integer, and then right-clicking (for Macintosh, *Control*-clicking) displays a context menu with integer commands, for example, *Integer Factors*, which applies the *ifactor* command. See Figure 3.1.
Figure 3.1: Context Menu for an Integer

In Worksheet mode, Maple uses an equation label reference in the `ifactor` calling sequence.

> 9469629

> `ifactor((3.1) )`

\[(3)^4 (13) (17) (23)^2\]

For more information on equation labels, see *Equation Labels (page 59)*.

For more information on using context menus in Worksheet mode, see *Context Menus (page 46)*. For information on using context menus in Document mode, see *Context Menus (page 20)*.

You can also enter the `ifactor` command and specify the integer to factor as an argument.
Maple has many other integer commands, including those listed in Table 3.1.

Table 3.1: Select Integer Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>abs</td>
<td>absolute value (displays in 2-D math as $</td>
</tr>
<tr>
<td>factorial</td>
<td>factorial (displays in 2-D math as $a!$)</td>
</tr>
<tr>
<td>ifactor</td>
<td>factorization</td>
</tr>
<tr>
<td>igcd</td>
<td>greatest common divisor</td>
</tr>
<tr>
<td>iquo</td>
<td>quotient of integer division</td>
</tr>
<tr>
<td>irem</td>
<td>remainder of integer division</td>
</tr>
<tr>
<td>iroot</td>
<td>integer approximation of nth root</td>
</tr>
<tr>
<td>isprime</td>
<td>test primality</td>
</tr>
<tr>
<td>isqrt</td>
<td>integer approximation of square root</td>
</tr>
<tr>
<td>max, min</td>
<td>maximum and minimum of a set</td>
</tr>
<tr>
<td>mod</td>
<td>modular arithmetic (See Finite Rings and Fields (page 75))</td>
</tr>
<tr>
<td>numtheory[divisors]</td>
<td>set of positive divisors</td>
</tr>
</tbody>
</table>

> ifactor(9469629)

$3^4 \cdot 13 \cdot 17 \cdot 23^2$

> iquo(209, 17)

12

> irem(209, 17)
For information on finding integer solutions to equations, see *Integer Equations* (page 93).

**Non-Base 10 Numbers and Other Number Systems**

Maple supports:

- Non-base 10 numbers
- Finite ring and field arithmetic
- Gaussian integers

**Non-Base 10 Numbers**

To represent an expression in another base, use the `convert` command.

```maple
> convert(6000, 'binary')
1011101110000
```

```maple
> convert(34271, 'hex')
85DF
```

For information on enclosing keywords in right single quotes ('), see *Delaying Evaluation* (page 317).

You can also use the `convert/base` command.
> convert(34271, 'base', 16)

    [15, 13, 5, 8]

Note: The \texttt{convert/base} command returns a list of digit values in order of increasing significance.

\textbf{Finite Rings and Fields}

Maple supports computations over the integers modulo \( m \).

The \texttt{mod} operator evaluates an expression over the integers modulo \( m \).

> 27 \texttt{mod} 4

\hspace{1cm} 3

By default, the \texttt{mod} operator uses positive representation (\texttt{modp} command). Symmetric representation is available using the \texttt{mods} command.

> \texttt{modp}(27, 4)

\hspace{1cm} 3

> \texttt{mods}(27, 4)

\hspace{1cm} -1

For information on setting symmetric representation as the default, refer to the \?\texttt{mod} help page.

The modular arithmetic operators are listed in Table 3.2.
Table 3.2: Modular Arithmetic Operators

<table>
<thead>
<tr>
<th>Operation</th>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Addition</td>
<td>+</td>
<td>&gt; 7 + 6 mod 5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3</td>
</tr>
<tr>
<td>Subtraction</td>
<td>-</td>
<td>&gt; mods(3 − 16, 11)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-2</td>
</tr>
<tr>
<td>Multiplication (displays in 2-D Math as ( \cdot ))</td>
<td>( \ast )</td>
<td>&gt; 13 ( \cdot ) mod 3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2</td>
</tr>
<tr>
<td>Multiplicative inverse (displays in 2-D Math as a superscript)</td>
<td>(^{-1})</td>
<td>&gt; 3(^{-1}) mod 5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2</td>
</tr>
<tr>
<td>Division (displays in 2-D Math as ( \frac{a}{b} ))</td>
<td>( / )</td>
<td>&gt; ( \frac{2}{3} ) mod 5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4</td>
</tr>
<tr>
<td>Exponentiation(^1)</td>
<td>&amp;(^\wedge)</td>
<td>&gt; (100&amp;(^\wedge)100) mod 7</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2</td>
</tr>
</tbody>
</table>

\(^1\)To enter a caret (\(^\wedge\)) in 2-D Math, enter a backslash character followed by a caret, that is, \\(^\wedge\).

For information on solving an equation modulo an integer, see *Integer Equations in a Finite Field (page 94).*

The *mod* operator also supports polynomial and matrix arithmetic over finite rings and fields. For more information, refer to the *?mod* help page.
Gaussian Integers

Gaussian integers are complex numbers in which the real and imaginary parts are integers.

The GaussInt package contains commands that perform Gaussian integer operations.

The GIfactor command returns the Gaussian integer factorization.

> GaussInt[GIfactor](173 + 16 i)

\[(1 + 2 i) (41 - 66 i)\]

You can enter the imaginary unit using the following two methods.

- In the Common Symbols palette, click the i or j item. See Palettes (page 11).
- Enter i or j, and then press the symbol completion key. See Symbol Names (page 16).

Note: In 1-D Math input, enter the imaginary unit as an uppercase i (I).

The GIsqrt command approximates the square root in the Gaussian integers.

> GaussInt[GIsqrt](9 - 5 j)

\[3 - i\]

For more information on Gaussian integers including a list of GaussInt package commands, refer to the ?GaussInt help page.

### 3.4 Solving Equations

You can solve a variety of equation types, including those described in Table 3.3.
Table 3.3: Overview of Solution Methods for Important Equation Types

<table>
<thead>
<tr>
<th>Equation Type</th>
<th>Solution Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equations and inequations</td>
<td><code>solve</code> and <code>fsolve</code> commands</td>
</tr>
<tr>
<td>Ordinary differential equations</td>
<td><code>ODE Analyzer Assistant</code> (and <code>dsolve</code> command)</td>
</tr>
<tr>
<td>Partial differential equations</td>
<td><code>pdsolve</code> command</td>
</tr>
<tr>
<td>Integer equations</td>
<td><code>isolve</code> command</td>
</tr>
<tr>
<td>Integer equations in a finite field</td>
<td><code>msolve</code> command</td>
</tr>
<tr>
<td>Linear systems</td>
<td><code>LinearAlgebra[LinearSolve]</code> command</td>
</tr>
<tr>
<td>Recurrence relations</td>
<td><code>rsolve</code> command</td>
</tr>
</tbody>
</table>

Note: Many solve operations are available as task templates (Tools>Tasks>Browse) and in context menus. This section focuses on other methods.

Solving Equations and Inequations

Using Maple, you can symbolically solve equations and inequations. You can also solve equations numerically.

To solve an equation or set of equations using context menus:

1. Right-click (for Macintosh, Control-click) the equations.
2. From the context menu, select Solve (or Solve Numerically). See Figure 3.2.
> \( \frac{7}{3} x^2 - x = 12 \)

\[ \frac{7}{3} x^2 - x = 12 \]

Figure 3.2: Context Menu for an Equation

In Worksheet mode, Maple inserts a calling sequence that solves the equation followed by the solutions.

If you select **Solve**, Maple computes exact solutions.

\[ \frac{7}{3} x^2 - x = 12 \]

> \texttt{solve( \{ (3.2) \} )}

\[ \begin{align*}
\left\{ x = \frac{3}{14} + \frac{3 \sqrt{113}}{14} \right\}, \left\{ x = \frac{3}{14} - \frac{3 \sqrt{113}}{14} \right\}
\end{align*} \]

If you select **Solve Numerically**, Maple computes floating-point solutions.
Symbolically Solving Equations and Inequations

The `solve` command is a general solver that determines exact symbolic solutions to equations or inequations. The solutions to a single equation or inequation are returned as an expression sequence. If Maple does not find any solutions, the `solve` command returns the empty expression sequence.

\[ \frac{7}{3} x^2 - x = 12 \]  

\[ \frac{7}{3} x^2 - x = 12 \]  \hspace{1cm} (3.3)

\[ > \text{fsolve}\left( \{3.3\} \right) \]

\[ \{x = -2.063602674\}, \{x = 2.492174103\} \]

For information on solving equations and inequations symbolically using the `solve` command, see the following section. For information on solving equations numerically using the `fsolve` command, see Numerically Solving Equations (page 83).

To return the solutions as a list, enclose the calling sequence in brackets (\[ \])

\[ > [\text{solve}(x^2 + x = 256,x)] \]
Expressions You can specify expressions instead of equations. The `solve` command automatically equates them to zero.

\[ \text{solve}\left(e^z + z\right) \]

\[ -W(1) \]

\(W\) represents the Lambert W function.

Multiple Equations To solve multiple equations or inequations, specify them as a set or list.

\[ \text{solve}\left(\{xy^2 - y=5, x > 0\}\right) \]

\[ \left\{ x = \frac{y + 5}{y^2}, -5 < y, y < 0 \right\}, \left\{ x = \frac{y + 5}{y^2}, 0 < y \right\} \]

\[ \text{solve}\left(\{xy^2 - y=5, x < 0\}\right) \]

\[ \left\{ x = \frac{y + 5}{y^2}, y < -5 \right\} \]

Solving for Specific Unknowns By default, the `solve` command returns solutions for all unknowns. You can specify the unknowns for which to solve.

\[ \text{solve}\left(q^2 - rs + \frac{q}{r} = 5, q\right) \]

\[ \frac{1}{2} -1 + \sqrt{1 + 4r^3s + 20r^2}, -\frac{1}{2} \]

To solve for multiple unknowns, specify them as a list.
Transcendental Equations  In general, the `solve` command returns one solution to transcendental equations.

\[
\text{solve}\left(\frac{q}{s} - \frac{r}{s + 1} + \frac{q}{r} = 5, r s = 1\right), [q, r]
\]

\[
\left[q = \frac{1 + 5 s^2 + 5 s}{s + 1 + s^3 + s^2}, r = \frac{1}{s}\right]
\]

To produce all solutions, set the `_EnvAllSolutions` environment variable to `true`.

Note: To enter an underscore character (\_\_) in 2-D Math, enter \_.

```maple
> equation1 := \sin(x) = \cos(x):
> solve(equation1)

\frac{1}{4} \pi
```

Maple uses variables of the form \_ZN~, where \(N\) is a positive integer, to represent arbitrary integers. The tilde (~) indicates that it is a quantity with an assumption. For information about names with assumptions, see `Assumptions on Variables` (page 116).

RootOf Structure The `solve` command may return solutions, for example, to higher order polynomial equations, in an implicit form using `RootOf` structures.
These RootOf structures are placeholders for the roots of the equation $x^5 - 2x^4 + 3x^3 - 2$. The index parameter numbers and orders the four solutions.

Like any symbolic expression, you can convert RootOf structures to a floating-point value using the evalf command.

\[ \text{evalf}(3.4) \]

Some equations are difficult to solve symbolically. For example, polynomial equations of order five and greater do not in general have a solution in terms of radicals. If the solve command does not find any solutions, it is recommended that you use the Maple numerical solver, fsolve. For information, see the following section, Numerically Solving Equations.

For more information on the solve command, including how to solve equations defined as procedures and how to find parametric solutions, refer to the ?solve/details help page.

For information on verifying and using solutions returned by the solve command, see Working with Solutions (page 86).

**Numerically Solving Equations**

The fsolve command solves equations numerically. The behavior of the fsolve command is similar to that of the solve command.
\[ \text{equation2} := z \cos(z) = 2: \]
\[ \text{fsolve(equation2, } z) \]
\[ 23.64662473 \]  
(3.5)

**Note:** You can also numerically solve equations using the context menus. See *Solving Equations and Inequations* (page 78).

It is recommended that you verify the solutions returned by the `fsolve` command. For details, see *Working with Solutions* (page 86).

**Multiple Equations** To solve multiple equations, specify them as a set. The `fsolve` command solves for all unknowns.

\[ \text{fsolve}\{\ln(x) = y^2 + 1, xy = e^y\} \]
\[ \{x = 3.396618823, y = 0.4719962637\} \]

**Univariate Polynomial Equations** In general, the `fsolve` command finds one solution. However, for a univariate polynomial equation, the `fsolve` command returns all real roots.

\[ \text{equation3} := y^4 - 3y^2 - 2 y + 1: \]
\[ \text{fsolve(equation3, } y) \]
\[ 0.3365322739, 1.940392664 \]

**Controlling the Number of Solutions** To limit the number of roots returned, specify the `maxsols` option.

\[ \text{fsolve(equation3, } y, \text{maxsols'} = 1) \]
\[ 0.3365322739 \]
To find additional solutions to a general equation, use the `avoid` option to ignore known solutions.

```
> fsolve(equation2, z, 'avoid' = \{z = 3.5\})

-2.498755763
```

**Complex Solutions** To search for a complex solution, or find all complex and real roots for a univariate polynomial, specify the `complex` option.

```
> fsolve(equation3, y, 'complex')

-1.138462469 - 0.4850624941 i, -1.138462469 + 0.4850624941 i,
     0.3365322739, 1.940392664
```

If the `fsolve` command does not find any solutions, it is recommended that you specify a range in which to search for solutions, or specify an initial value.

**Range** To search for a solution in a range, specify the range in the calling sequence. The range can be real or complex.

```
> fsolve(equation2, z, \{z = 100 .. 200\})

149.2390528
```

The syntax for specifying a region in the complex plane is `lower-left point .. upper-right point`.

```
> fsolve(equation3, y, \{y = -2 .. 0\}, 'complex');

-1.138462469 - 0.4850624941 i
```

**Initial Values** You can specify a value for each unknown. The `fsolve` command uses these as initial values for the unknowns in the numerical method.

```
> fsolve(equation2, \{z = 100\})
```
For more information and examples, refer to the `?fsolve/details` help page.

For information on verifying and using solutions returned by the `fsolve` command, see the following section, *Working with Solutions*.

**Working with Solutions**

**Verifying** It is recommended that you always verify solutions (that the `solve` and `fsolve` commands return) using the `eval` command.

\[
\begin{align*}
\text{\textbackslash{indent}} & \text{\textbackslash{indent}} > equation4 := \sin(x) = -\cos(x): \\
\text{\textbackslash{indent}} & \text{\textbackslash{indent}} > \text{solve}(\text{equation4}) \\
\text{\textbackslash{indent}} & \text{\textbackslash{indent}} \quad -\frac{1}{4} \pi \\
\text{\textbackslash{indent}} & \text{\textbackslash{indent}} > \text{eval}(\text{equation4}, x = 3.7) \\
\text{\textbackslash{indent}} & \text{\textbackslash{indent}} \quad -\frac{1}{2} \sqrt{2} = -\frac{1}{2} \sqrt{2} \\
\text{\textbackslash{indent}} & \text{\textbackslash{indent}} > equation5 := \cos(z) = \frac{2}{z}: \\
\text{\textbackslash{indent}} & \text{\textbackslash{indent}} > \text{fsolve}(\text{equation5}) \\
\text{\textbackslash{indent}} & \text{\textbackslash{indent}} \quad -2.498755763 \\
\text{\textbackslash{indent}} & \text{\textbackslash{indent}} > \text{eval}(\text{equation5}, \{z = 3.8\}) \\
\text{\textbackslash{indent}} & \text{\textbackslash{indent}} \quad -0.8003983544 = -0.8003983540
\end{align*}
\]

For more information, see *Substituting a Value for a Subexpression* (page 310).
Assigning the Value of a Solution to a Variable To assign the value of a solution to the corresponding variable as an expression, use the assign command.

For example, consider the numeric solution to equation2, \( \{ z = 98.98037599 \} \) (3.6), found using the starting value \( z = 100 \).

\[ \text{assign}(3.6) \]

\[ z \]

\[ 98.98037599 \]

Creating a Function from a Solution The assign command assigns a value as an expression to a name. It does not define a function. To convert a solution to a function, use the unapply command.

Consider one of the solutions for \( q \) to the equation \( q^2 - rs + \frac{q}{r} = 5 \).

\[ \text{solutions} := \left[ \text{solve} \left( q^2 - rs + \frac{q}{r} = 5, q \right) \right] ; \]

\[ f := \text{unapply} ( \text{solutions}[1], r, s ) \]

\[ f := (r, s) \mapsto \frac{1}{2} \frac{-1 + \sqrt{1 + 4 r^3 s + 20 r^2}}{r} \]

You can evaluate this function at symbolic or numeric values.

\[ f(x, y) \]

\[ \frac{1}{2} \frac{-1 + \sqrt{1 + 4 x^3 y + 20 x^2}}{x} \]
\( > f \left( \frac{1}{\sqrt{2}}, 1 \right) \)

\[ \frac{1}{2} \sqrt{2} \left( -1 + \sqrt{11 + \sqrt{2}} \right) \]

\( > f(5.7, 2.1) \)

4.032680522

For more information on defining and using functions, see *Functional Operators* (page 292).

**Other Specialized Solvers**

In addition to equations and inequations, Maple can solve other equations including:

- Ordinary differential equations (ODEs)
- Partial differential equations (PDEs)
- Integer equations
- Integer equations in a finite field
- Linear systems
- Recurrence relations

**Ordinary Differential Equations (ODEs)**

Maple can solve ODEs and ODE systems, including initial value and boundary value problems, symbolically and numerically.

**ODE Analyzer Assistant** The **ODE Analyzer Assistant** is a point-and-click interface to the Maple ODE solving routines.

**To launch the ODE Analyzer:**

- From the **Tools** menu, select **Assistants**, and then **ODE Analyzer**.
Maple inserts the \texttt{dsolve[interactive]()} calling sequence in the document. The \textbf{ODE Analyzer Assistant} (Figure 3.3) is displayed.

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{ode_analyzer_assistant.png}
\caption{ODE Analyzer Assistant}
\end{figure}

In the main \textbf{ODE Analyzer Assistant} window, you can define ODEs, initial or boundary value conditions, and parameters. To define derivatives, use the \texttt{diff} command. For example, \texttt{diff(x(t), t)} corresponds to \( \frac{dx(t)}{dt} \), and \texttt{diff(x(t), t, t)} corresponds to \( \frac{d^2x(t)}{dt^2} \). For more information on the \texttt{diff} command, see \textit{The diff Command} on page 155.

After defining an ODE, you can solve it numerically or symbolically.

\textbf{To solve a system numerically using the ODE Analyzer Assistant:}

1. Ensure that the conditions guarantee uniqueness of the solution.
2. Ensure that all parameters have fixed values.
3. Click the \textbf{Solve Numerically} button.
4. In the **Solve Numerically** window (Figure 3.4), you can specify the numeric method and relevant parameters and error tolerances to use for solving the problem.

5. To compute solution values at a point, click the **Solve** button.

![Figure 3.4: ODE Analyzer Assistant: Solve Numerically Dialog](image)

**To solve a system symbolically using the ODE Analyzer Assistant:**

1. Click the **Solve Symbolically** button.

2. In the **Solve Symbolically** window (Figure 3.5), you can specify the method and relevant method-specific options to use for solving the problem.

3. To compute the solution, click the **Solve** button.
When solving numerically or symbolically, you can view a plot of the solution by clicking the **Plot** button.

- To plot the solution to a symbolic problem, all conditions and parameters must be set.
- To customize the plot, click the **Plot Options** button to open the **Plot Options** window.

To view the corresponding Maple commands as you solve the problem or plot the solution, select the **Show Maple** commands check box.
You can control the return value of the ODE Analyzer using the On Quit, Return drop-down list. You can select to return nothing, the displayed plot, the computed numeric procedure (for numeric solutions), the solution (for symbolic solutions), or the Maple commands needed to produce the solution values and the displayed plot.

For more information, refer to the ?ODEAnalyzer help page.

**The dsolve Command**

The ODE Analyzer provides a point-and-click interface to the Maple `dsolve` command.

For ODEs or systems of ODEs, the `dsolve` command can find:

- Closed form solutions
- Numerical solutions
- Series solutions

In addition, the `dsolve` command can find:

- Formal power series solutions to linear ODEs with polynomial coefficients
- Formal solutions to linear ODEs with polynomial coefficients

To access all available functionality, use the `dsolve` command directly. For more information, refer to the ?dsolve help page.

**Partial Differential Equations (PDEs)**

To solve a PDE or PDE system symbolically or numerically, use the `pdsolve` command. PDE systems can contain ODEs, algebraic equations, and inequalities.

For example, solve the following PDE symbolically.

\[ x \left( \frac{\partial}{\partial y} f(x, y) \right) - y \left( \frac{\partial}{\partial x} f(x, y) \right) = 0 \]
3.4 Solving Equations

\[ x \frac{\partial}{\partial y} f(x, y) - y \frac{\partial}{\partial x} f(x, y) = 0 \]  
\[ (3.9) \]

\[ > \textit{pdsolve}((3.9)) \]

\[ f(x, y) = _{F1}(x^2 + y^2) \]

The solution is an arbitrary univariate function applied to \(x^2 + y^2\).

Maple generally prints only the return value, errors, and warnings during a computation. To print information about the techniques Maple uses, increase the \texttt{infolevel} setting for the command.

To return all information, set \texttt{infolevel} to 5.

\[ > \texttt{infolevel[pdsolve]} := 5 : \]

\[ > \textit{pdsolve}((3.9)) \]

\textit{Checking arguments ...}

\textit{Getting info and details about the PDE ... First set of solution methods (general or quase general solution) Second set of solution methods (complete solutions) Trying methods for first order PDEs HINT = strip Trying characteristic strip method ... characteristic strip method successful. Second set of solution methods successful}

\[ f(x, y) = _{F1}(x^2 + y^2) \]

For more information on solving PDEs, including numeric solutions and solving PDE systems, refer to the \texttt{?pdsolve} help page.

\textbf{Integer Equations}

To find only integer solutions to an equation, use the \texttt{isolve} command. The \texttt{isolve} command finds solutions for all variables. For more information, refer to the \texttt{?isolve} help page.
Integer Equations in a Finite Field

To solve an equation modulo an integer, use the `msolve` command. For more information, refer to the `?msolve` help page. The `msolve` command finds solutions for all variables.

\[
\text{msolve}\left\{x^2 = 1, \ 13\right\}
\]

\[
\{x = 1\}, \ {x = 12}\]

Solving Linear Systems

To solve a linear system, use the `LinearAlgebra[LinearSolve]` command. For more information, refer to the `?LinearAlgebra[LinearSolve]` help page. The `LinearSolve` command returns the vector \(x\) that satisfies \(A \cdot x = B\).

For example, construct an augmented matrix using the `Matrix` palette (see `Creating Matrices and Vectors (page 133)`) in which the first four columns contain the entries of \(A\) and the final column contains the entries of \(B\).

\[
\begin{bmatrix}
59 & 44 & 17 & 1 & 1 & 1 & 10 & 25 & 2 & 100 & 2 \\
1 & 0 & 7 & 533 & 61 & 50 \\
98 & 21 & 3 & 7 & 2178 & 25 \\
23 & 9 & 12 & 51 & 786 & 25
\end{bmatrix}
\]

\[
\text{linearSystem} :=
\]

\[
\text{LinearAlgebra[LinearSolve]}(\text{linearSystem})
\]
For more information on using Maple to solve linear algebra problems, see *Linear Algebra (page 133)*.

**Solving Recurrence Relations**

To solve a recurrence relation, use the `rsolve` command. For more information, refer to the `?rsolve` help page. The `rsolve` command finds the general term of the function.

```maple
> rsolve({f(n)= f(n - 1) + f(n - 2), f(0)= 1, f(1)= 1}, {f(n)})
```

\[
f(n) = \left( \frac{1}{2} - \frac{1}{10} \sqrt{5} \right) \left( -\frac{1}{2} \sqrt{5} + \frac{1}{2} \right)^n + \left( \frac{1}{10} \sqrt{5} + \frac{1}{2} \right) \left( \frac{1}{2} + \frac{1}{2} \sqrt{5} \right)^n\]

**3.5 Units, Scientific Constants, and Uncertainty**

In addition to manipulating exact symbolic and numeric quantities, Maple can perform computations with units and uncertainties.

Maple supports hundreds of units, for example, miles, coulombs, and bars, and provides facilities for adding custom units.
Maple has a library of hundreds of scientific constants with units, including element and isotope properties.

To support computations with uncertainties, Maple propagates errors through computations.

**Units**

The **Units** package in Maple provides a library of units, and facilities for using units in computations. It is fully extensible so that you can add units as required.

**Note:** Some unit operations are available as task templates (see **Tools>Tasks>Browse**) and through context menus.

**Overview of Units**

A *dimension* is a measurable quantity, for example, length or force. The set of dimensions that are fundamental and independent are known as *base dimensions*.

In Maple, the base dimensions include length, mass, time, electric current, thermodynamic temperature, amount of substance, luminous intensity, information, and currency. For a complete list, run `Units[GetDimensions]()`.

Complex dimensions (or *composite dimensions*) measure other quantities in terms of a combination of base dimensions. For example, the complex dimension force is a measurement of \( \frac{mass \cdot length}{time^2} \).

Each dimension, base or complex, has associated units. (Base units measure a base dimension. Complex units measure a complex dimension.) Maple supports over forty units of length, including feet, miles, meters, angstroms, microns, and astronomical units. A length must be measured in terms of a unit, for example, a length of 2 parsecs.

Table 3.4 lists some dimensions, their corresponding base dimensions, and example units.
Table 3.4: Sample Dimensions

<table>
<thead>
<tr>
<th>Dimension</th>
<th>Base Dimensions</th>
<th>Example Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>time</td>
<td>second, minute, hour, day, week, month, year, millennium, blink, lune</td>
</tr>
<tr>
<td>Energy</td>
<td>( \frac{\text{length}^2 \text{mass}}{\text{time}^2} )</td>
<td>joule, electron volt, erg, watt hour, calorie, Calorie, British thermal unit</td>
</tr>
<tr>
<td>Electric potential</td>
<td>( \frac{(\text{length}^2 \text{mass})}{(\text{time}^3 \text{electric current})} )</td>
<td>volt, abvolt, statvolt</td>
</tr>
</tbody>
</table>

For the complete list of units (and their contexts and symbols) available for a dimension, refer to the corresponding help page, for example, the ?Units/length help page for the units of length.

Each unit has a context. The context differentiates between different definitions of the unit. For example, the standard and US survey miles are different units of length, and the second is a unit of time and of angle. You can specify the context for a unit by appending the context as an index to the unit, for example, mile[US_survey]. If you do not specify a context, Maple uses the default context.

Units are collected into systems, for example, the foot-pound-second (FPS) system and international system, or système international, (SI). Each system has a default set of units used for measurements. In the FPS system, the foot, pound, and second are used to measure the dimensions of length, mass, and time. The unit of speed is the foot/second. In SI, the meter, kilogram, and second are used to measure the dimensions of length, mass, and time. The units of speed, magnetic flux, and power are the meter/second, weber, and watt.

**Conversions**

To convert a value measured in a unit to the corresponding value in a different unit, use the Units Calculator.
In the worksheet, enter `UnitsCalculator`.

The **Units Calculator** application (Figure 3.6) opens.

**Units Calculator**

Convert between over 500 units of measurement. See [Units help index](#) for details.

First, select a dimension from the drop-down box. Then select the units to convert from and to. Click the 'Perform Unit Conversion' button. The 'Convert Back' button converts in the opposite direction.

![Unit Converter Assistant](Image)

**Figure 3.6: Unit Converter Assistant**

**To perform a conversion:**

1. In the **Convert** text field, enter the numeric value to convert.

2. In the **Dimension** drop-down list, select the dimensions of the unit.

3. In the **From** and **To** drop-down lists, select the original unit and the unit to which to convert.

4. Click **Perform Unit Conversion**.

Maple inserts the corresponding `convert/units` command into the document.

```maple
> convert(1.0, 'units', 'lbft(radius)', 'Nm(radius)')
1.355817948
```

**Important:** Using the **Units Calculator**, you can convert temperatures and temperature changes.
• To perform a temperature conversion, in the **Dimension** drop-down list, select **temperature(absolute)**.

• To perform a temperature change conversion, in the **Dimension** drop-down list, select **temperature(relative)**.

To convert temperature changes, the **Units Calculator** uses the `convert/units` command. For example, an increase of 32 degrees Fahrenheit corresponds to an increase of almost 18 degrees Celsius.

```plaintext
> convert(32.0, 'units', 'degF', 'degC')
17.77777778
```

To convert absolute temperatures, the **Unit Converter** uses the `convert/temperature` command. For example, 32 degrees Fahrenheit corresponds to 0 degrees Celsius.

```plaintext
> convert(32, 'temperature', 'degF', 'degC')
0
```

**Applying Units to an Expression**

To insert a unit, use the **Units** palettes. The **Units (FPS)** palette (Figure 3.7) contains important units from the foot-pound-second system of units. The **Units (SI)** palette (Figure 3.8) contains important units from the international system of units.
To insert a unit:

- In a Units palette, click a unit symbol.

\[ 3 [ft] \]

3 \([ft]\)

To insert a unit that is unavailable in the palettes:

1. In a Units palette, click the unit symbol \([unit]\). Maple inserts a Unit object with the placeholder selected.

2. In the placeholder, enter the unit name (or symbol).

For example, to enter 0.01 standard (the default context) miles, you can specify the unit name, mile, or symbol, mi.

\[ 0.01 [mile] \]

0.01 \([mi]\)
The context of a unit is displayed only if it is not the default context.

**Important:** In 1-D Math input, the quantity and unit (entered using the top-level \texttt{Unit} command) are a product, not a single entity. The following calling sequences define different expressions.

\[
\begin{align*}
> 1\text{*Unit(m)/(2*Unit(s))}; & \quad > 1\text{*Unit(m)/2*Unit(s)}; \\
\frac{1}{2} \text{ [m]} & \quad \frac{1}{2} \text{ [m] [s]}
\end{align*}
\]

Some units support prefixes. For example, SI units support prefixes to names and symbols. You can specify 1000 meters using \texttt{kilometer} or \texttt{km}. For more information, refer to the \texttt{?Units/prefixes} help page.

\[
> 1.5 \text{[km}_\text{SI}] \\
1.5 \text{ [km]}
\]

**Performing Computations with Units**

In the default Maple environment, you cannot perform computations with quantities that have units. You can perform only unit conversions. For more information about the default environment, refer to the \texttt{?Units/default} help page.

To compute with expressions that have units, you must load a \texttt{Units} environment, Natural or Standard. It is recommended that you use the Standard environment.

\[
> \text{with(Units[Standard])};
\]

In the \texttt{Standard Units} environment, commands that support expressions with units return results with the correct units.
Performing Computations

\[ area := 3 \text{[ft]} \cdot \frac{1}{8} \text{[mile]} \]
\[
area := \frac{14370939}{78125} \text{[m}^2\text{]} 
\]

\[ ( -12 \sin(x) + x^2 ) \text{[m]} \]
\[
\left( -12 \sin(x) + x^2 \right) \text{[m]} \quad (3.10)
\]

\[ int (3.10), x[s] \)
\[
\left( 12 \cos(x) + \frac{1}{3} x^3 \right) \text{[m]} \quad (3.11)
\]

\[ diff (3.11), x[s] \]
\[
\left( -12 \sin(x) + x^2 \right) \text{[m]} \quad (3.12)
\]

For information on differentiation and integration, see *Calculus* (page 151).

**Changing the Current System of Units**

If a computation includes multiple units, all units are expressed using units from the current system of units.

\[ 132.25 \text{[mile]} \]
\[
132.25 \text{[mi]} 
\]

(3.12)

By default, Maple uses the SI system of units, in which length is measured in meters and time is measured in seconds.
To view the name of the default system of units, use the `Units[UsingSystem]` command.

\[
\frac{(3.12)}{3[\text{hour}]} = 19.70701333 \left[ \frac{m}{s} \right]
\]

To change the system of units, use the `Units[UseSystem]` command.

\[
\text{> with(Units)} : \text{UseSystem(FPS)} : \text{(3.12)} \cdot 3[m] \cdot 1.1[kg] = 0.1666720741 \left[ \text{ft}^2 \text{lb} \right]
\]

**Extensibility**

You can extend the set of:

- Base dimensions and units
- Complex dimensions
- Complex units
- Systems of units


For more information about units, refer to the `?Units` help page.
Scientific Constants and Element Properties

Computations often require not only units (see Units (page 96)), but also the values of scientific constants, including properties of elements and their isotopes. Maple supports computations with scientific constants. You can use the built-in constants and add custom constants.

Overview of Scientific Constants and Element Properties

The ScientificConstants package provides the values of constant physical quantities, for example, the velocity of light and the atomic weight of sodium. The ScientificConstants package also provides the units for the constant values, allowing for greater understanding of the equation as well as unit-matching for error checking of the solution.

The quantities available in the ScientificConstants package are divided into two distinct categories.

- Physical constants
- Chemical element (and isotope) properties

Scientific Constants

Maple contains many built-in scientific constants, which you can easily include in your computations.

List of Scientific Constants

You have access to scientific constants important in engineering, physics, chemistry, and other fields. Table 3.5 lists some of the supported constants. For a complete list of scientific constants, refer to the ?ScientificConstants/PhysicalConstants help page.
### Table 3.5: Scientific Constants

<table>
<thead>
<tr>
<th>Name</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Newtonian_constant_of_gravitation</td>
<td>G</td>
</tr>
<tr>
<td>Planck_constant</td>
<td>h</td>
</tr>
<tr>
<td>elementary_charge</td>
<td>e</td>
</tr>
<tr>
<td>Bohr_radius</td>
<td>a[0]</td>
</tr>
<tr>
<td>deuteron_magnetic_moment</td>
<td>mu[d]</td>
</tr>
<tr>
<td>Avogadro_constant</td>
<td>N[A]</td>
</tr>
<tr>
<td>Faraday_constant</td>
<td>F</td>
</tr>
</tbody>
</table>

You can specify a constant using either its name or symbol.

#### Accessing Constant Definition

The `GetConstant` command in the `ScientificConstants` package returns the complete definition of a constant.

To view the definition of the Newtonian gravitational constant, specify the symbol `G` (or its name) in a call to the `GetConstant` command.

```maple
> with(ScientificConstants):

> GetConstant('G')
```

```maple
Newtonian_constant_of_gravitation, symbol = G, value = 0.6673 \times 10^{-10},

uncertainty = 0.1 \times 10^{-12}, units = \frac{m^3}{kg \cdot s^2}
```

For information on accessing a constant's value, units, or uncertainty, see `Value, Units, and Uncertainty (page 107).

#### Element Properties

Maple also contains element properties and isotope properties.
Elements

Maple supports the first 112 elements of the periodic table, plus elements number 114 and 116. Each element has a unique name, atomic number, and chemical symbol. You can specify an element using any of these labels. For a complete list of supported elements, refer to the ?ScientificConstants/elements help page.

Maple supports key element properties, including atomic weight (atomic-weight), electron affinity (electronaffinity), and density. For a complete list of element properties, refer to the ?ScientificConstants/properties help page.

Isotopes

Isotopes, variant forms of an element that contain the same number of protons but a different number of neutrons, exist for many elements.

To see the list of supported isotopes for an element, use the GetIsotopes command.

\[
> \text{GetIsotopes}(\ '\text{element}' = \ '\text{Li}')
\]

\[
\text{Li}_4, \text{Li}_5, \text{Li}_6, \text{Li}_7, \text{Li}_8, \text{Li}_9, \text{Li}_{10}, \text{Li}_{11}, \text{Li}_{12}
\]

Maple supports isotopes and has a distinct set of properties for isotopes, including abundance, binding energy (bindingenergy), and mass excess (massexcess). For a complete list of isotope properties, refer to the ?ScientificConstants/properties help page.

Accessing an Element or Isotope Property Definition

The GetElement command in the ScientificConstants package returns the complete definition of an element or isotope.
3.5 Units, Scientific Constants, and Uncertainty

> GetElement('Li')

\[
3, \text{symbol} = \text{Li}, \text{name} = \text{lithium}, \text{names} = \{\text{lithium}\}, \text{atomicweight} = [\text{value} = 6.941, \text{uncertainty} = 0.002, \text{units} = \text{u}], \text{ionizationenergy} = [\text{value} = 5.3917, \text{uncertainty} = \text{undefined}, \text{units} = \text{eV}], \text{density} = [\text{value} = 0.534, \text{uncertainty} = \text{undefined}, \text{units} = \frac{\text{g}}{\text{cm}^3}], \text{electronegativity} = [\text{value} = 0.98, \text{uncertainty} = \text{undefined}, \text{units} = 1], \text{electronaffinity} = [\text{value} = 0.6180, \text{uncertainty} = 0.0005, \text{units} = \text{eV}], \text{boilingpoint} = [\text{value} = 1615.\text{K}, \text{uncertainty} = \text{undefined}, \text{units} = \text{K}], \text{meltingpoint} = [\text{value} = 453.65, \text{uncertainty} = \text{undefined}, \text{units} = \text{K}]
\]

> GetElement('Li[4]')

\[
\text{Li}_4, \text{atomicmass} = [\text{value} = 0.4027182329 \times 10^7, \text{uncertainty} = 227.733, \text{units} = \text{uu}], \text{massexcess} = [\text{value} = 25320.173, \text{uncertainty} = 212.132, \text{units} = \text{keV}], \text{bindingenergy} = [\text{value} = 4618.058, \text{uncertainty} = 212.132, \text{units} = \text{keV}]
\]

**Value, Units, and Uncertainty**

To use constants or element properties, you must first construct a **Scientific-Constants** object.

To construct a scientific constant, use the **Constant** command.

> \( G := \text{Constant('G')} \)

\[
G := \text{Constant(G)}
\]

To construct an element (or isotope) property, use the **Element** command.

> \( \text{LiAtomicWeight} := \text{Element('Li', atomicweight)} \)

\[
\text{LiAtomicWeight} := \text{Element(Li, atomicweight)}
\]
Value

To obtain the value of a ScientificConstants object, use the evalf command.

\[ \text{evalf}(G) \]
\[ 0.6673 \times 10^{-10} \]

\[ \text{evalf}(\text{LiAtomicWeight}) \]
\[ 0.1152580953 \times 10^{-25} \]

Note: The value returned depends on the current system of units. For information on controlling the system of units, see Changing the Current System of Units (page 102).

Units

To obtain the units for a ScientificConstants object, use the GetUnit command.

\[ \text{GetUnit}(G) \]
\[ \left[ \frac{m^3}{kg \cdot s^2} \right] \]

\[ \text{GetUnit}(\text{LiAtomicWeight}) \]
\[ [\text{kg}] \]

For information on changing the default system of units, for example, from SI to foot-pound-second, see Changing the Current System of Units (page 102).
Value and Units

If performing computations with units, you can access the value and units for a \texttt{ScientificConstants} object by specifying the \texttt{units} option when constructing the object, and then evaluating the object.

\begin{verbatim}
> evalf(Constant('G', units))

0.6673 \times 10^{-10} \left[ \frac{m^3}{kg \ s^2} \right]
\end{verbatim}

\begin{verbatim}
> evalf(Element('Li[5]', atomicmass, units))

0.8323520514 \times 10^{-26} \text{ kg}
\end{verbatim}

Uncertainty

The value of a constant is often determined by direct measurement or derived from measured values. Hence, it has an associated uncertainty. To obtain the uncertainty in the value of a \texttt{ScientificConstants} object, use the \texttt{GetError} command.

\begin{verbatim}
> GetError(G)

0.10 \times 10^{-12}
\end{verbatim}

\begin{verbatim}
> GetError(LiAtomicWeight)

0.3321080400 \times 10^{-29}
\end{verbatim}

Performing Computations

You can use constant values in any computation. To use constant values with units, use a \texttt{Units} environment as described in \textit{Performing Computations with Units (page 101)}. For information on computing with quantities that have an uncertainty, see the following section.
Modification and Extensibility

You can change the definition of a scientific constant or element (or isotope) property.

For more information, refer to the `ScientificConstants[ModifyConstant]` and `ScientificConstants[ModifyElement]` help pages.

You can extend the set of:

- Constants
- Elements (and isotopes)
- Element (or isotope) properties


For more information about constants, refer to the `ScientificConstants` help page.

Uncertainty Propagation

Some computations involve uncertainties (or errors). Using the `ScientificErrorAnalysis` package, you can propagate the uncertainty in these values through the computation to indicate the possible error in the final result.

The `ScientificErrorAnalysis` package does not perform interval arithmetic. That is, the error of an object does not represent an interval in which possible values must be contained. (To perform interval arithmetic, use the `Tolerances` package. For more information, refer to the `Tolerances` help page.) The quantities represent unknown values with a central tendency. For more information on central tendency, refer to any text on error analysis for the physical sciences or engineering.
Quantities with Uncertainty

Creating To construct quantities with uncertainty, use the `Quantity` command. You must specify the value and uncertainty. The uncertainty can be defined absolutely, relatively, or in units of the last digit. For more information on uncertainty specification, refer to the `ScientificErrorAnalysis[Quantity]` help page.

The output displays the value and uncertainty of the quantity.

\[
> \text{with(ScientificConstants): with(ScientificErrorAnalysis):}
\]

\[
> \text{Quantity}(105, 1.2)
\]

\[
\text{Quantity}(105, 1.2)
\]

\[
> \text{Quantity}(105, 0.03, '\text{relative}')
\]

\[
\text{Quantity}(105, 3.15) \quad (3.13)
\]

To specify the error in units of the last digit, the value must be of floating-point type.

\[
> \text{Quantity}(105.0, 12, '\text{uld}')
\]

\[
\text{Quantity}(105.0, 12)
\]

To access the value and uncertainty of a quantity with uncertainty, use the `evalf` and `ScientificErrorAnalysis[GetError]` commands.

\[
> \text{evalf}(3.13)
\]

\[
105.
\]

\[
> \text{GetError}(3.13)
\]
### 3.15

**Rounding** To round the error of a quantity with uncertainty, use the `ApplyRule` command. For a description of the predefined rounding rules, refer to the `?ScientificErrorAnalysis/rule` help page.

```maple
> GetError(ApplyRule(3.13, 'round[2]'))
```

### 3.2

**Units** Quantities with errors can have units. For example, the scientific constants and element (and isotope) properties in the `ScientificConstants` packages are quantities with errors and units.

To construct a new quantity with units and an uncertainty, include units in the `Quantity` calling sequence.

For an absolute error, you must specify the units in both the value and error.

```maple
> with(Units[Standard]) :

> Quantity(3.5[m], 0.1[m])

```

For a relative error, you can specify the units in only the value.

```maple
> Quantity(3.5[m], 0.1, 'relative')

```

For information on the correlation between, variance of, and covariance between quantities with uncertainty, refer to the `?ScientificErrorAnalysis` help page.

**Performing Computations with Quantities with Uncertainty**

Many Maple commands support quantities with uncertainty.
\[ q1 := \text{Quantity}(31., 2.): \]
\[ q2 := \text{Quantity}(20., 1.): \]

Compute the value of the derivative of \( q1 \cdot x^2 + \sin(q2 \cdot x) \) at \( x = \sin\left(\frac{\pi}{4}\right) \).

\[ d1 := \text{diff}\left(q1 \cdot x^2 + \sin(q2 \cdot x), x\right) \]
\[ d1 := 2 \text{Quantity}(31., 2.) x + \cos(\text{Quantity}(20., 1.) x) \text{Quantity}(20., 1.) \]

\[ d2 := \text{eval}\left(d1, x = \sin\left(\frac{\pi}{4}\right)\right): \]

To convert the solution to a single quantity with uncertainty, use the `combine/errors` command.

\[ \text{result} := \text{combine}(d2, 'errors'): \]

The value of the result is:

\[ \text{evalf}(\text{result}) \]

\[ 43.74124725 \]

The uncertainty of the result is:

\[ \text{getError}(\text{result}) \]

\[ 14.42690612 \]

**Additional Information**

For information on topics including:

- Creating new rounding rules
- Setting the default rounding rule
Creating a new interface to quantities with uncertainty refer to the ?ScientificErrorAnalysis help page.

3.6 Restricting the Domain

By default, Maple computes in the complex number system. Most computations are performed without any restrictions or assumptions on the variables. Maple often returns results that are extraneous or unsimplified when computing in the field of complex numbers. Using restrictions, you can more easily and efficiently perform computations in a smaller domain.

Maple has facilities for performing computations in the real number system and for applying assumptions to variables.

Real Number Domain

To force Maple to perform computations in the field of real numbers, use the RealDomain package.

The RealDomain package contains a small subset of Maple commands related to basic precalculus and calculus mathematics, for example, arccos, limit, and log, and the symbolic manipulation of expressions and formulae, for example, expand, eval, and solve. For a complete list of commands, refer to the ?RealDomain help page.

After you load the RealDomain package, Maple assumes that all variables are real. Commands return simplified results appropriate to the field of real numbers.

> with(RealDomain);
Some commands that generally return **NULL** instead return a numeric result when you use the **RealDomain** package.

\[
\begin{align*}
\text{\texttt{\> simplify(\sqrt{x^2})}} & \quad |x| \\
\text{\texttt{\> ln(e^x)}} & \quad x \\
\text{\texttt{\> (-32)\left(\frac{1}{5}\right)}} & \quad -2
\end{align*}
\]

Complex return values are excluded or replaced by **undefined**.

\[
\begin{align*}
\text{\texttt{\> solve(x^2 = -1)}} \\
\text{\texttt{\> arcsin(e^2)}} & \quad \textbf{undefined}
\end{align*}
\]
Assumptions on Variables

To simplify problem solving, it is recommended that you always apply any known assumptions to variables. You can impose assumptions using the `assume` command. To apply assumptions for a single computation, use the `assuming` command.

**Note:** The `assume` and `assuming` commands are not supported by the `RealDomain` package.

The assume Command

You can use the `assume` command to set variable properties, for example, `x::real`, and relationships between variables, for example, `x < 0` or `x < y`. For information on valid properties, refer to the `?assume` help page. For information on the double colon (`::`) operator, refer to the `?type` help page.

The `assume` command allows improved simplification of symbolic expressions, especially multiple-valued functions, for example, computing the square root.

To assume that `x` is a positive real number, use the following calling sequence. Then compute the square root of `x^2`.

```plaintext
> assume(0 < x): \sqrt{x^2}

x~
```

The trailing tilde (`~`) on the name `x` indicates that it carries assumptions.

When you use the `assume` command to place another assumption on `x`, all previous assumptions are removed.

```plaintext
> assume(x < 0): \sqrt{x^2}

-x~
```
Displaying Assumptions To view the assumptions on an expression, use the `about` command.

```plaintext
> about(x)
Originally x, renamed x~: is assumed to be: RealRange(-infinity,Open(0))
```

Imposing Multiple Assumptions To simultaneously impose multiple conditions on an expression, specify multiple arguments in the `assume` calling sequence.

```plaintext
> assume(0 < x, x < 2)
```

To specify additional assumptions without replacing previous assumptions, use the `additionally` command. The syntax of the `additionally` calling sequence is the same as that of the `assume` command.

```plaintext
> additionally(x :: integer): about(x)
Originally x, renamed x~: is assumed to be: 1
```

The only integer in the open interval \((0, 2)\) is 1.

Testing Properties To test whether an expression always satisfies a condition, use the `is` command.

```plaintext
> assume(15 < x, 7 < y): is(100 < xy)
true
```

The following test returns `false` because there are values of \(x\) and \(y\) \((x = 0, y = 10)\) that satisfy the assumptions, but do not satisfy the relation in the `is` calling sequence.

```plaintext
> assume(x :: nonnegint, 10 ≤ y): is(10 < x + y)
false
```
To test whether an expression can satisfy a condition, use the `coulditbe` command.

\[ \text{coulditbe}(10 < x + y) \]

\[ \text{true} \]

**Removing Assumptions** To remove all assumptions on a variable, unassign its name.

\[ \text{unassign} \ ('x', 'y') \]

For more information, see *Unassigning Names* (page 57).

For more information on the `assume` command, refer to the `?assume` help page.

**The assuming Command**

To perform a single evaluation under assumptions on the names in an expression, use the `assuming` command.

The syntax of the assuming command is `expression assuming <property or relation>`. Properties and relations are introduced in *The assume Command* (page 116).

The `frac` command returns the fractional part of an expression.

\[ \text{frac}(x) \text{ assuming } x :: \text{integer} \]

\[ 0 \]

Using the `assuming` command is equivalent to imposing assumptions with the `assume` command, evaluating the expression, and then removing the assumptions.
If you do not specify the names to which to apply a property, it is applied to all names.

\[ \sqrt{\left( \frac{a}{b} \right)^2} \quad \text{assuming positive} \]

\[ \frac{a}{b} \]

Assumptions placed on names using the `assume` command are ignored by the `assuming` command, unless you include the `additionally` option.

\[ \text{assume}(x < 1) \]

\[ \text{is}(1 - x^2 > 0) \quad \text{assuming } x > -1 \]

\[ \text{false} \]

\[ \text{is}(1 - x^2 > 0) \quad \text{assuming additionally, } x > -1 \]

\[ \text{true} \]

The `assuming` command does not affect variables inside procedures. (For information on procedures, see Procedures (page 338).) You must use the `assume` command.

\[ f := \text{proc}(x) \sqrt{a^2} + x \text{ end proc}; \]

\[ f := \text{proc} (x) \sqrt{a^2} + x \text{ end proc} \]

\[ f(1) \quad \text{assuming } a > 0 \]
\[ \sqrt{a^2} + 1 \]

\[ > \text{assume}(a > 0): \ f(1) \]

\[ a + 1 \]

For more information on the \texttt{assuming} command, refer to the \texttt{?assuming} help page.
4 Mathematical Computations

As discussed in previous chapters, Maple contains numerous built-in resources for computations.

These resources—and others on the Maplesoft Web site—are available for the areas discussed in this chapter, and many more. Your first step in solving a problem should be to review the related Maple resources available. This will help you to quickly and easily solve problems. See Table 4.1.

Table 4.1: Maple Resources for Mathematical Computation

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point-and-click assistants</td>
<td>Graphical interfaces with buttons and sliders to easily perform a computation, create a plot, or perform other operations.</td>
</tr>
<tr>
<td></td>
<td>• From the <strong>Tools</strong> menu, select <strong>Assistants</strong>.</td>
</tr>
<tr>
<td>Context menus</td>
<td>Pop-up menu of common operations for the selected object, based on its type.</td>
</tr>
<tr>
<td></td>
<td>• Select the expression in 2-D Math input or output, and then right-click (for Macintosh, <strong>Control</strong>-click).</td>
</tr>
<tr>
<td>Palettes</td>
<td>Collections of related items that you can insert by clicking or dragging. Some palettes contain mathematical operations with placeholders for parameters.</td>
</tr>
<tr>
<td></td>
<td>• From the <strong>View</strong> menu, select <strong>Palettes</strong>, and then <strong>Expand Docks</strong>.</td>
</tr>
<tr>
<td>Task templates</td>
<td>Set of commands with placeholders that you can use to quickly perform a task. Some tasks contain graphical components such as buttons.</td>
</tr>
<tr>
<td></td>
<td>• From the <strong>Tools</strong> menu, select <strong>Tasks</strong>, and then <strong>Browse</strong>.</td>
</tr>
<tr>
<td><strong>FunctionAdvisor</strong> command</td>
<td>Provides detailed information about mathematical functions, for example, definitions, identities, and mathematical properties.</td>
</tr>
<tr>
<td></td>
<td>• Refer to the <strong>?FunctionAdvisor</strong> help page.</td>
</tr>
<tr>
<td>Resource</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Maple Help System                | Over 5000 help pages and example worksheets with an integrated search engine.  
• From the Help menu, select Maple Help.                                                                                                           |
| Package index help page          | A complete list of the over 100 Maple packages, which contain thousands of commands.  
• From the Help menu, select Manuals, Dictionary, and more, and then List of Packages.                                                               |
| Command index help page          | A complete list of the over 600 top-level Maple commands.  
• From the Help menu, select Manuals, Dictionary, and more, and then List of Commands.                                                                |
| Maplesoft Web site (http://www.maplesoft.com) | Maple Application Center - Free documents and point-and-click Maplet applications for mathematics, engineering, finance, and science.  
• Visit http://www.maplesoft.com/applications  
Toolboxes - Add-on products from Maplesoft, for example, the Global Optimization Toolbox.  
• Visit http://www.maplesoft.com/products/toolboxes  
Third-Party Products - Add-on products developed by the Maple user community for specialized computation.  
• Visit http://www.maplesoft.com/products/thirdparty |
# 4.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Algebra - Performing algebra computations</td>
<td>• Polynomial Algebra</td>
</tr>
<tr>
<td>Linear Algebra - Performing linear algebra computations</td>
<td>• Creating Matrices and Vectors&lt;br&gt;• Accessing Entries in Matrices and Vectors&lt;br&gt;• Linear Algebra Computations&lt;br&gt;• Student LinearAlgebra Package</td>
</tr>
<tr>
<td>Calculus - Performing calculus computations</td>
<td>• Limits&lt;br&gt;• Differentiation&lt;br&gt;• Series&lt;br&gt;• Integration&lt;br&gt;• Differential Equations&lt;br&gt;• Calculus Packages</td>
</tr>
<tr>
<td>Optimization - Performing optimization computations using the Optimization package</td>
<td>• Point-and-Click Interface&lt;br&gt;• Efficient Computation&lt;br&gt;• MPS(X) File Support</td>
</tr>
<tr>
<td>Statistics - Performing statistics computations using the Statistics package</td>
<td>• Probability Distributions and Random Variables&lt;br&gt;• Statistical Computations&lt;br&gt;• Plotting</td>
</tr>
<tr>
<td>Teaching and Learning with Maple - Student and Instructor resources for using Maple in an academic setting</td>
<td>• Table of Student and Instructor Resources&lt;br&gt;• Student Packages and Tutors</td>
</tr>
</tbody>
</table>
4.2 Algebra

Maple contains a variety of commands that perform integer operations, such as factoring and modular arithmetic, as described in *Integer Operations (page 71)*. In addition, it supports polynomial algebra.

For information on matrix and vector algebra, see *Linear Algebra (page 133)*.

**Polynomial Algebra**

A Maple polynomial is an expression in powers of an unknown. *Univariate* polynomials are polynomials in one unknown, for example, \( x^3 - 2x + 13 \). *Multivariate* polynomials are polynomials in multiple unknowns, such as \( x^3 y - \frac{3}{2} xy^2 + 7x \).

The coefficients can be integers, rational numbers, irrational numbers, floating-point numbers, complex numbers, variables, or a combination of these types.

\[
> a x^2 + 7x - \frac{b}{2}
\]

\[
a x^2 + 7x - \frac{1}{2} b
\]

**Arithmetic**

The polynomial arithmetic operators are the standard Maple arithmetic operators excluding the division operator (/). (The division operator accepts polynomial arguments, but does not perform *polynomial division*.)

Polynomial division is an important operation. The *quo* and *rem* commands find the quotient and remainder of a polynomial division. See Table 4.2. (The *iquo* and *irem* commands find the quotient and remainder of an integer division. For more information, see *Integer Operations (page 71)*.)
Table 4.2: Polynomial Arithmetic Operators

<table>
<thead>
<tr>
<th>Operation</th>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
</table>
| Addition                       | +        | > \((x^2 + 1) + (3x^3 - 5x + 2)\)  
|                                |          | \(x^2 + 3 + 3x^3 - 5x\)   |
| Subtraction                    | -        | > \((x^2 + 1) - (3x^3 - 5x + 2)\)  
|                                |          | \(x^2 - 1 - 3x^3 + 5x\)   |
| Multiplication\(^1\)           | *        | > \((x^2 + 1) \cdot (3x^3 - 5x + 2)\)  
|                                |          | \((x^2 + 1) (3x^3 - 5x + 2)\) |
| Division: Quotient and Remainder | quo     | > \text{quo}(2x^2 + x - 3, 3x + 5, x)  
|                                | rem      | > \text{rem}(2x^2 + x - 3, 3x + 5, x)  
|                                |          | \(\frac{2}{3} x - \frac{7}{9}\)  
|                                |          | \(\frac{8}{9}\)   |
| Exponentiation\(^2\)           | ^        | > \((x^2 + 1)^3\)  
|                                |          | \((x^2 + 1)^3\)   |

\(^1\)You can specify multiplication explicitly by entering *, which displays in 2-D Math as \(\cdot\). In 2-D Math, you can also implicitly multiply by placing a space character between two expressions. In some cases, the space character is optional. For example, Maple interprets a number followed by a name as an implicit multiplication.

\(^2\)In 2-D Math, exponents display as superscripts.

To expand a polynomial, use the \textbf{expand} command.
If you need to determine whether one polynomial divides another, but do not need the quotient, use the `divide` command. The `divide` command tests for exact polynomial division.

\>
\> divide(x^4 y^2 + x^3 y^2 - x^2 y^2 + 13 x^2 + 13 x - 13 + y \cdot x^2 + x \cdot y - y, x^2 + x - 1)

\> true

**Important:** You must insert a space character or a multiplication operator ( \cdot \) between adjacent variables names. Otherwise, they are interpreted as a single variable.

For example, \( x \) does not divide the single variable \( xy \).

\>
\> divide(xy, x)

\> false

But, \( x \) divides the product of \( x \) and \( y \).

\>
\> divide(xy, x); divide(x \cdot y, x)

\> true

\> true

For information on polynomial arithmetic over finite rings and fields, refer to the `?mod` help page.

**Sorting Terms**

To sort the terms of a polynomial, use the `sort` command.
> \( p1 := x^2 + x^3 - x + x^4 \)

\[
p1 := x^2 + x^3 - x + x^4
\]

> \( \text{sort}(p1) \)

\[
x^4 + x^3 + x^2 - x
\]

**Note:** The `sort` command returns the sorted polynomial, and updates the order of the terms in the polynomial.

The terms of \( p1 \) are sorted.

> \( p1 \)

\[
x^4 + x^3 + x^2 - x
\]

To specify the unknowns of the polynomial and their ordering, include a list of names.

> \( \text{sort}(a^2 x^3 + x^2 + x \cdot a + a + b, [a]) \)

\[
x^3 \ a^2 + x \ a + a + x^2 + b
\]

> \( \text{sort}(a^2 x^3 + x^2 + x \cdot a + a + b, [x, b]) \)

\[
a^2 \ x^3 + x^2 + a \ x + b + a
\]

By default, the `sort` command sorts a polynomial by decreasing *total degree* of the terms.

> \( p2 := x^3 + y^3 + x^2 y^2 \)

> \( \text{sort}(p2, [x, y]) \)
The first term has total degree 4. The other two terms have total degree 3. The order of the final two terms is determined by the order of their names in the list.

To sort the terms by *pure lexicographic order*, that is, first by decreasing order of the first unknown in the list option, and then by decreasing order of the next unknown in the list option, specify the 'plex' option.

\[
x^2 y^2 + x^3 + y^3
\]

For information on enclosing keywords in right single quotes ('), see *Delaying Evaluation* (page 317).

The first term has a power of \( x \) to the 3. The second, a power of \( x \) to the 2. The third, a power of \( x \) to the 0.

Using context menus, you can perform operations, such as sorting, for polynomials and many other Maple objects.

**To sort a polynomial:**

1. Right-click (Control-click, for Macintosh) the polynomial.

2. The context menu displays. From the *Sorts* menu, select:
   - **Single-variable**, and then the unknown
   - **Two-variable** (or **Three-variable**), **Pure Lexical** or **Total Degree**, and then the sort priority of the unknowns

See Figure 4.1.
Maple sorts the polynomial.

In Worksheet mode, Maple inserts the calling sequence that performs the sort followed by the sorted polynomial.

```maple
> x^3 + y^3 + x^2 y^2

> sort( x^3 + y^3 + x^2 y^2, [y, x], 'plex' )

y^3 + y^2 x^2 + x^3
```
Collecting Terms

To collect the terms of polynomial, use the **collect** command.

\[ \text{collect}\left(2ax y + cx^2 y - zy^2 + az - 13 by + \frac{3y^2}{x}, y\right)\]

\[-z + 3 \frac{1}{x} y^2 + (2ax + x^2c - 13b)y + az\]

Coefficients and Degrees

Maple has several commands that return coefficient and degree values for a polynomial. See Table 4.3.

**Table 4.3: Polynomial Coefficient and Degree Commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>coeff</strong></td>
<td>Coefficient of specified degree term</td>
<td>(&gt; \text{coeff}\left(\frac{1}{2}x^3 - 2x + 5, x^3\right)) [\frac{1}{2}]</td>
</tr>
<tr>
<td><strong>lcoeff</strong></td>
<td>Leading coefficient</td>
<td>(&gt; \text{lcoeff}\left(\frac{1}{2}x^3 - 2x + 5\right)) [\frac{1}{2}]</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>---------</td>
<td>-------------</td>
<td>---------</td>
</tr>
</tbody>
</table>
| tcoeff | Trailing coefficient | \( tcoeff \left( \frac{1}{2} x^3 - 2x + 5 \right) \)
|         |             | 5       |
| coeffs  | Sequence of all coefficients in increasing degree order. **Note:** It does not return zero coefficients. | \( coeffs \left( \frac{1}{2} x^3 - 2x + 5 \right) \)
|         |             | 5, -2, \( \frac{1}{2} \) |
| degree  | (Highest) degree | \( degree \left( \frac{1}{2} x^3 - 2x + 5 \right) \)
|         |             | 3       |
| ldegree | Lowest degree term with a non-zero coefficient | \( ldegree \left( \frac{1}{2} x^3 - 2x \right) \)
|         |             | 1       |

**Factorization**

To express a polynomial in fully factored form, use the `factor` command.

\[ factor \left( x^4 - 1 \right) \]

\[ (x - 1) (x + 1) (x^2 + 1) \]

The `factor` command factors the polynomial over the ring implied by the coefficients, for example, integers. You can specify an algebraic number field over which to factor the polynomial. For more information, refer to the `?factor` help page. (The `ifactor` command factors an integer. For more information, see *Integer Operations* (page 71).)
To solve for the roots of a polynomial, use the `solve` command. For information on the `solve` command, see *Solving Equations and Inequalities (page 78).* (The `isolve` command solves an equation for integer solutions. For more information, see *Integer Equations (page 93).*

**Other Commands**

Table 4.4 lists other commands available for polynomial operations.

**Table 4.4: Select Other Polynomial Commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>content</code></td>
<td>Content (multivariate polynomial)</td>
</tr>
<tr>
<td><code>compoly</code></td>
<td>Decomposition</td>
</tr>
<tr>
<td><code>discrim</code></td>
<td>Discriminant</td>
</tr>
<tr>
<td><code>gcd</code></td>
<td>Greatest common divisor (of two polynomials)</td>
</tr>
<tr>
<td><code>gcdex</code></td>
<td>Extended Euclidean algorithm (for two polynomials)</td>
</tr>
<tr>
<td><code>CurveFitting[PolynomialInterpolation]</code></td>
<td>Interpolating polynomial (for list of points)</td>
</tr>
<tr>
<td>See also the <code>CurveFitting Assistant</code> (<code>Tools&gt;Assistants&gt;Curve Fitting</code>)</td>
<td></td>
</tr>
<tr>
<td><code>lcm</code></td>
<td>Least common multiple (of two polynomials)</td>
</tr>
<tr>
<td><code>norm</code></td>
<td>Norm</td>
</tr>
<tr>
<td><code>prem</code></td>
<td>Pseudo-remainder (of two multivariate polynomials)</td>
</tr>
<tr>
<td><code>primpart</code></td>
<td>Primitive part (multivariate polynomial)</td>
</tr>
<tr>
<td><code>randpoly</code></td>
<td>Random polynomial</td>
</tr>
<tr>
<td><code>PolynomialTools[IsSelfReciprocal]</code></td>
<td>Determine whether self-reciprocal</td>
</tr>
<tr>
<td><code>resultant</code></td>
<td>Resultant (of two polynomials)</td>
</tr>
<tr>
<td><code>roots</code></td>
<td>Exact roots (over algebraic number field)</td>
</tr>
</tbody>
</table>
### 4.3 Linear Algebra

Linear algebra operations act on Matrix and Vector data structures.

You can perform many linear algebra operations using task templates. In the **Task Browser** ([Tools]>[Tasks]>[Browse]), expand the **Linear Algebra** folder.

#### Creating Matrices and Vectors

You can easily define matrices using the **Matrix** palette. To define vectors, use the angle-bracket (<> ) notation.

#### Creating Matrices

To create a matrix, use the **Matrix** palette. See Figure 4.2.

---

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>sqrfree</td>
<td>Square free factorization (multivariate polynomial)</td>
</tr>
</tbody>
</table>

---

### Additional Information

**Table 4.5: Additional Polynomial Help**

<table>
<thead>
<tr>
<th>Topic</th>
<th>Resource</th>
</tr>
</thead>
<tbody>
<tr>
<td>General polynomial information</td>
<td><code>?polynom</code> help page</td>
</tr>
<tr>
<td>PolynomialTools package</td>
<td><code>?PolynomialTools</code> package overview help page</td>
</tr>
<tr>
<td>Algebraic manipulation of numeric polynomials</td>
<td><code>?SNAP</code> (Symbolic-Numeric Algorithms for Polynomials) package overview help page</td>
</tr>
<tr>
<td>Efficient arithmetic for sparse polynomials</td>
<td><code>?SDMPolynom</code> (Sparse Distributed Multivariate Polynomial data structure) help page</td>
</tr>
<tr>
<td>Polynomial information and commands</td>
<td>Maple Help System Table of Contents: Mathematics&gt;Algebra&gt;Polynomials section</td>
</tr>
</tbody>
</table>
In the Matrix palette, you can specify the matrix size (see Figure 4.3) and properties. To insert a matrix, click the Insert Matrix button.
After inserting the matrix:

1. Enter the values of the entries. To move to the next entry placeholder, press **Tab**.

2. After specifying all entries, press **Enter**.
Creating Vectors

To create a vector, use angle brackets (<>).

To create a column vector, specify a comma-delimited sequence, \(<a, b, c>\). The number of elements is inferred from the number of expressions.

\[
> <1, 2, 3>
\]

\[
\begin{bmatrix}
1 \\
2 \\
3
\end{bmatrix}
\]

To create a row vector, specify a vertical-bar-delimited (|) sequence, \(<a | b | c>\). The number of elements is inferred from the number of expressions.

\[
> <1|2|3>
\]

\[
\begin{bmatrix}
1 & 2 & 3
\end{bmatrix}
\]

Editing and Viewing Large Matrices and Vectors

Matrices 10 × 10 and smaller, and vectors with 10 or fewer elements display in the document. Larger objects are displayed as a placeholder.

For example, insert a 15 × 15 matrix.
In the Matrix palette:

1. Specify the dimensions: 15 rows and 15 columns.

2. In the **Type** drop-down list, select a matrix type, for example, **Custom values**.

3. Click **Insert Matrix**. Maple inserts a placeholder.

```
> 15 x 15 Matrix
Data Type: anything
Storage: rectangular
Order: Fortran_order
```

To edit or view a large matrix or vector, double-click the placeholder. This launches the Matrix Browser. See Figure 4.4.
To specify the value of entries using the Matrix Browser:

1. Select the **Table** tab.

2. Double-click an entry, and then edit its value. Press **Enter**.

3. Repeat for each entry to edit.

4. When you have finished updating entries, click **Done**.
You can view the matrix or vector as a table or as an image, which can be inserted into the document. For more information, refer to the MatrixBrowser help page.

To set the maximum dimension of matrices and vectors displayed inline:

- Use the `interface` command with the `rtablesize` option.

For example, `interface(rtablesize = 15)`.

For more information, refer to the `interface` help page.

**Creating Matrices and Vectors for Large Problems**

By default, matrices and vectors can store any values. To increase the efficiency of linear algebra computations, create matrices and vectors with properties. You must specify the properties, for example, the matrix or vector type or the data type, when defining the object.

The **Matrix** palette (Figure 4.2) supports several properties.

To specify the matrix type:

- Use the **Shape** and **Type** drop-down lists.

To specify the data type:

- Use the **Data type** drop-down list.

For example, define a diagonal matrix with small integer coefficients.

In the **Matrix** palette:

1. Specify the size of the matrix, for example, $3 \times 3$.
2. In the **Shapes** drop-down list, select **Diagonal**.
3. In the **Data type** drop-down list, select `integer[1]`.
4. Click the **Insert Matrix** button.
5. Enter the values in the diagonal entries.

\[
\begin{bmatrix}
-23 & 0 & 0 \\
0 & 17 & 0 \\
0 & 0 & 32
\end{bmatrix}
\]

**Note:** To create a matrix with randomly-generated entries, select the **Random Type**.

You cannot specify properties when defining vectors using the angle-bracket notation. You must use the **Vector constructor**.

**To define a column vector using the Vector constructor, specify:**

- The number of elements. If you explicitly specify all element values, this argument is not required.
- A list of expressions that define the element values.
- Parameters such as `shape`, `datatype`, and `fill` that set properties of the vector.

The following two calling sequences are equivalent.

\[
\text{Vector}([0,0,0])
\]

\[
\begin{bmatrix}
0 \\
0 \\
0
\end{bmatrix}
\]

\[
\text{Vector}(3,'shape='zero')
\]

\[
\begin{bmatrix}
0 \\
0 \\
0
\end{bmatrix}
\]
To create a row vector using the `Vector` constructor, include `row` as an index.

```plaintext
> Vector[row](3,'fill' = 1)

    [ 1 1 1 ]
```

```plaintext
> Vector[row]([[127, 0, 34],'datatype'=integer[1]])

    [ 127 0 34 ]
```

The `Matrix` palette does not support some properties. To set all properties, use the `Matrix` constructor.

**To define a matrix using the Matrix constructor, specify:**

- The number of rows and columns. If you explicitly specify all element values, these arguments are not required.
- A list of lists that define the element values row-wise.
- Parameters such as `shape`, `datatype`, and `fill` that set properties of the matrix.

For example:

```plaintext
> Matrix([[1, 2, 3],[4, 5, 6]])

    [ 1 2 3 ]
    [ 4 5 6 ]
```

The `Matrix` palette cannot fill the matrix with an arbitrary value. Use the `fill` parameter.

```plaintext
> Matrix(3,4,[[1, 2, 3],[4, 5, 6]],'fill'=2 + i)
```
For more information on the constructors, including other calling sequence syntaxes and parameters, refer to the \cref{?storage}, \cref{?Matrix}, and \cref{?Vector} help pages.

See also \textit{Numeric Computations (page 150)}.

\section*{Accessing Entries in Matrices and Vectors}

To select an entry in a vector, enter the vector name with a non-zero integer index.

\begin{verbatim}
> a := <85.3, 47.1, 59.9, 38.1>
\end{verbatim}

\begin{verbatim}
> a[1]
85.3
\end{verbatim}

Negative integers select entries from the end of the vector.

\begin{verbatim}
> a[−1]
38.1
\end{verbatim}

To create a Vector consisting of multiple entries, specify a list or range of integers in the index. For more information, refer to the \cref{?list} and \cref{?range} help pages.
Similarly, you can access submatrices using an index. In the following two-dimensional matrix, the first entry selects rows and the second, columns.

\[
\begin{bmatrix}
1 & 0 & 0 \\
0 & \cos(t) & -\sin(t) \\
0 & \sin(t) & \cos(t)
\end{bmatrix}
\]

\[
> a[[1,2]]
\]

\[
\begin{bmatrix}
85.3 \\
47.1
\end{bmatrix}
\]

\[
> a[2..4]
\]

\[
\begin{bmatrix}
47.1 \\
59.9 \\
38.1
\end{bmatrix}
\]

Linear Algebra Computations

You can perform matrix and vector computations using context menus and the LinearAlgebra package.

Matrix Arithmetic

The matrix and vector arithmetic operators are the standard Maple arithmetic operators up to the following two differences.
The scalar multiplication operator is the asterisk (*), which displays in math as $\cdot$. The noncommutative matrix and vector multiplication operator is the period (.)

There is no division operator (/) for matrix algebra. (You can construct the inverse of a matrix using the exponent $-1$.)

See Table 4.6.

$\begin{bmatrix} 93 & 43 \\ 19 & 37 \end{bmatrix}; b := \begin{bmatrix} 48 & 20 \\ 19 & 37 \end{bmatrix}; c := <23, 6>$

\begin{table}[h]
\centering
\caption{Matrix and Vector Arithmetic Operators}
\begin{tabular}{|l|c|c|}
\hline
\textbf{Operation} & \textbf{Operator} & \textbf{Example} \\
\hline
Addition & $+$ & $a+b$ \\
& & $\begin{bmatrix} 141 & 63 \\ 38 & 74 \end{bmatrix}$ \\
Subtraction & $-$ & $a-b$ \\
& & $\begin{bmatrix} 45 & 23 \\ 0 & 0 \end{bmatrix}$ \\
Multiplication & $\cdot$ & $a.c$ \\
& & $\begin{bmatrix} 2397 \\ 659 \end{bmatrix}$ \\
\hline
\end{tabular}
\end{table}
Definition of two column vectors.

\[
\begin{pmatrix} 116 & 516 \\ 228 & 444 \end{pmatrix}
\]

\[
\begin{pmatrix} 92 \\ 24 \end{pmatrix}
\]

\[
\begin{pmatrix} 986548 & 613868 \\ 271244 & 187092 \end{pmatrix}
\]

\[
\begin{pmatrix} 37 & -5 \\ 1396 & 349 \\ -19 & 12 \\ 1396 & 349 \end{pmatrix}
\]

1 You can specify scalar multiplication explicitly by entering \(*\), which displays in 2-D Math as \(\times\). In 2-D Math, you can also implicitly multiply a scalar and a matrix or vector by placing a space character between them. In some cases, the space character is optional. For example, Maple interprets a number followed by a name as an implicit multiplication.

2 In 2-D Math, exponents display as superscripts.

A few additional matrix and vector operators are listed in Table 4.7.

Define two column vectors.

\[
\begin{pmatrix} 1, 2, 3 \end{pmatrix} : \begin{pmatrix} 4, 5, 6 \end{pmatrix}
\]
Table 4.7: Select Matrix and Vector Operators

<table>
<thead>
<tr>
<th>Operation</th>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transpose</td>
<td>(^%T^1)</td>
<td>(d^{%T})</td>
</tr>
<tr>
<td>Hermitian Transpose</td>
<td>(^%H^1)</td>
<td>(i\ -2i^{%H})</td>
</tr>
<tr>
<td>Cross Product (3-D vectors only)</td>
<td>(&amp;x^2)</td>
<td>(with(LinearAlgebra):)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(d &amp; x)</td>
</tr>
</tbody>
</table>

1 Exponential operators display in 2-D Math as superscripts.

2 After loading the LinearAlgebra package, the cross product operator is available as the infix operator \(\&x\). Otherwise, it is available as the LinearAlgebra[CrossProduct] command.

For information on matrix arithmetic over finite rings and fields, refer to the \?mod help page.

**Point-and-Click Interaction**

Using context menus, you can perform many matrix and vector operations.

Matrix operations available in the context menu include the following.
• Standard operations: determinant, inverse, norm (1, Euclidean, infinity, or Frobenius), transpose, and trace
• Compute eigenvalues, eigenvectors, and singular values
• Compute the dimension or rank
• Convert to the Jordan form, or other forms
• Perform Cholesky decomposition and other decompositions

For example, compute the infinity norm of a matrix. See Figure 4.5.

Figure 4.5: Computing the Infinity Norm of a Matrix

In Document mode, Maple inserts a right arrow followed by the norm. See Figure 4.6.
Vector operations available in the context menu include the following.

- Compute the dimension
- Compute the norm (1, Euclidean, and infinity)
- Compute the transpose
- Select an element

For more information on context menus, see Context Menus (page 20) (for Document mode) or Context Menus (page 46) (for Worksheet mode).

**LinearAlgebra Package Commands**

The **LinearAlgebra** package contains commands that construct and manipulate matrices and vectors, compute standard operations, perform queries, and solve linear algebra problems.

Table 4.8 lists some **LinearAlgebra** package commands. For a complete list, refer to the ??LinearAlgebra/Details help page.

**Table 4.8: Select LinearAlgebra Package Commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basis</td>
<td>Return a basis for a vector space</td>
</tr>
<tr>
<td>CrossProduct</td>
<td>Compute the cross product of two vectors</td>
</tr>
<tr>
<td>DeleteRow</td>
<td>Delete the rows of a matrix</td>
</tr>
<tr>
<td>Dimension</td>
<td>Determine the dimension of a matrix or a vector</td>
</tr>
<tr>
<td>Eigenvectors</td>
<td>Compute the eigenvalues and eigenvectors of a matrix</td>
</tr>
<tr>
<td>FrobeniusForm</td>
<td>Reduce a matrix to Frobenius form</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>GaussianElimination</td>
<td>Perform Gaussian elimination on a matrix</td>
</tr>
<tr>
<td>HessenbergForm</td>
<td>Reduce a square matrix to Hessenberg form</td>
</tr>
<tr>
<td>HilbertMatrix</td>
<td>Construct a generalized Hilbert matrix</td>
</tr>
<tr>
<td>IsOrthogonal</td>
<td>Test if a matrix is orthogonal</td>
</tr>
<tr>
<td>LeastSquares</td>
<td>Compute the least-squares approximation to $A \cdot x = b$</td>
</tr>
<tr>
<td>LinearSolve</td>
<td>Solve the linear system $A \cdot x = b$</td>
</tr>
<tr>
<td>MatrixInverse</td>
<td>Compute the inverse of a square matrix or pseudo-inverse of a non-square matrix</td>
</tr>
<tr>
<td>QRDecomposition</td>
<td>Compute a QR factorization of a matrix</td>
</tr>
<tr>
<td>RandomMatrix</td>
<td>Construct a random matrix</td>
</tr>
<tr>
<td>SylvesterMatrix</td>
<td>Construct the Sylvester matrix of two polynomials</td>
</tr>
</tbody>
</table>

For information on arithmetic operations, see *Matrix Arithmetic* (page 143).

For information on selecting entries, subvectors, and submatrices, see *Accessing Entries in Matrices and Vectors* (page 142).

**Example** Determine a basis for the space spanned by the set of vectors \{
\langle 2, 13, -15 \rangle, \langle 7, -2, 13 \rangle, \langle 5, -4, 9 \rangle \}\. Express the vector \langle 25, -4, 9 \rangle\ with respect to this basis.

\[ \text{with(LinearAlgebra):} \]

\[ v1 := \langle 2, 13, -15 \rangle; v2 := \langle 7, -2, 13 \rangle; v3 := \langle 5, -4, 9 \rangle; \]

Find a basis for the vector space spanned by these vectors, and then construct a matrix from the basis vectors.

\[ \text{basis := Matrix(Basis([v1, v2, v3]));} \]
To express $\begin{pmatrix} 25, -4, 9 \end{pmatrix}$ in this basis, use the **LinearSolve** command.

```maple
LinearSolve(basis, <25, -4, 9>)
```

\[
\begin{bmatrix}
170 \\
91 \\
-285 \\
91 \\
786 \\
91
\end{bmatrix}
\]

**Numeric Computations**

You can very efficiently perform computations on large matrices and vectors that contain floating-point data using the built-in library of numeric linear algebra routines. Some of these routines are provided by the Numerical Algorithms Group (NAG®). Maple also contains portions of the CLAPACK and optimized ATLAS libraries.

For information on performing efficient numeric computations using the **LinearAlgebra** package, refer to the **?EfficientLinearAlgebra** help page.

See also *Creating Matrices and Vectors for Large Problems (page 139)*.

**Student LinearAlgebra Package**

The **Student** package contains subpackages that help instructors teach concepts and allow students to visualize and explore ideas. These subpackages also contain computational commands.
In the **Student[LinearAlgebra]** subpackage, the environment differs from that of the **LinearAlgebra** package in that floating-point computations are generally performed using software precision, instead of hardware precision, and symbols are generally assumed to represent real, rather than complex, quantities. These defaults, and others, can be controlled using the **SetDefault** command. For more information, refer to the `?Student[LinearAlgebra][SetDefault]` help page.

For information on using Maple as a teaching and learning tool, see *Teaching and Learning with Maple* (page 178).

## 4.4 Calculus

The **Task Browser** (Tools>Tasks>Browse) contains numerous calculus task templates. For a list of tasks, navigate to one of the related folders, such as **Calculus**, **Differential Equations**, **Multivariate Calculus**, or **Vector Calculus**.

This section describes the key Maple calculus commands, many of which are used in task templates or available in the context menus.

For a complete list of calculus commands, refer to the **Mathematics** (including **Calculus**, **Differential Equations**, **Power Series**, and **Vector Calculus** subfolders) and **Student Package** sections of the Maple Help System Table of Contents.

### Limits

To compute the limit of an expression as the independent variable approaches a value:

1. In the **Expression** palette, click the limit item \( \lim_{x \to a} f \).

2. Specify the independent variable, limit point, and expression, and then evaluate it.
For example:

\[ \lim_{x \to 0} \left( \frac{x}{\sin(x)} \right) \]

1

**The limit Command**

By default, Maple searches for the real bidirectional limit (unless the limit point is \( \infty \) or \(-\infty\)). To specify a direction, include one of the options **left**, **right**, **real**, or **complex** in a call to the **limit** command. See Table 4.9.

**Table 4.9: Limits**

<table>
<thead>
<tr>
<th>Limit</th>
<th>Command Syntax</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \lim_{x \to 0} \left( \frac{1}{x} \right) )</td>
<td>( \text{limit} \left( \frac{1}{x}, x = 0 \right) )</td>
<td>undefined</td>
</tr>
<tr>
<td>( \lim_{x \to 0^+} \left( \frac{1}{x} \right) )</td>
<td>( \text{limit} \left( \frac{1}{x}, x = 0, 'right' \right) )</td>
<td>( \infty )</td>
</tr>
<tr>
<td>( \lim_{x \to 0^-} \left( \frac{1}{x} \right) )</td>
<td>( \text{limit} \left( \frac{1}{x}, x = 0, 'left' \right) )</td>
<td>(- \infty )</td>
</tr>
</tbody>
</table>

Using the **limit** command, you can also compute multidimensional limits.

\[ \text{limit} \left( \frac{x^2}{y}, \{x = 1, y = \infty \} \right) \]

0

For more information on multidimensional limits, refer to the ?limit/multi help page.
Numerically Computing a Limit

To numerically compute a limit:

• Use the `evalf(Limit(arguments))` calling sequence.

Important: Use the inert `Limit` command, not the `limit` command. For more information, refer to the `?limit` help page.

The `Limit` command accepts the same arguments as the `limit` command.

For example:

```plaintext
> evalf(Limit(sin(x)/(cos(x)+tan(x)), x=1.225))
0.3020605357
```

For information on the `evalf` command, see Numerical Approximation (page 313).

The `Limit` command does not compute the limit. It returns an unevaluated limit.

```plaintext
> Limit(sin(x), x=1.225)
lim_{x \to 1.225} \frac{\sin(x)}{\cos(x) + \tan(x)}
```

For more information on the `Limit` command, refer to the `?Limit` help page.

Differentiation

Maple can perform symbolic and numeric differentiation.
To differentiate an expression:

1. In the Expression palette, click the differentiation item \( \frac{d}{dx} \) or the partial differentiation item \( \frac{\partial}{\partial x} \).

2. Specify the expression and independent variable, and then evaluate it.

For example, to differentiate \( x \sin(ax) \) with respect to \( x \):

\[
\frac{d}{dx} (x \sin(ax)) = \sin(ax) + x \cos(ax) a
\]

You can also differentiate using context menus. For more information, see Context Menus (page 20).

To calculate a higher order or partial derivative, edit the derivative symbol inserted. For example, to calculate the second derivative of \( x \sin(ax) + x^2 \) with respect to \( x \):

\[
\frac{d^2}{dx^2} (x \sin(ax) + x^2) = 2 \cos(ax) a - x \sin(ax) a^2 + 2
\]

To calculate the mixed partial derivative of \( x \sin(3y) + yx^5 \):

\[
\frac{\partial^2}{\partial y \partial x} (x \sin(3y) + yx^5)
\]
\[ 3 \cos(3y) + 5x^4 \]

**The diff Command**

Maple computes derivatives using the `diff` command. To directly use the `diff` command, specify the expression to differentiate and the variable.

\[ x \sin(ax) + x^2 \]

(4.1)

\[ \text{diff}(4.1, x) \]

\[ \sin(ax) + x \cos(ax) a + 2x \]

For information on equation labels such as (4.1), see *Equation Labels (page 59)*.

To calculate a higher order derivative, specify a sequence of differentiation variables. Maple recursively calls the `diff` command.

\[ \text{diff}(4.1, x, x) \]

\[ 2 \cos(ax) a - x \sin(ax) a^2 + 2 \]

To calculate a partial derivative, use the same syntax. Maple assumes that the derivatives commute.

\[ \text{diff}(x \sin(3y) + y\sqrt{x}, x, y) \]

\[ 3 \cos(3y) + \frac{1}{2} \frac{1}{\sqrt{x}} \]

To enter higher order derivatives, it is convenient to use the sequence operator ($\_\_\$). For more information, refer to the $\_\_\$ help page.
To compute the \( n \)th derivative of an expression \( f \) in the independent variable \( t \), you can use the syntax \( \text{diff}(f,t^n) \).

For example:

\[ \text{diff}(\cos(t),t^5) \]

\[-\sin(t)\]

**Differentiating an Operator**

You can also specify a mathematical function as a *functional operator* (a mapping). For a comparison of operators and other expressions, see *Distinction between Functional Operators and Other Expressions* (page 293).

**To find the derivative of a functional operator:**

- Use the \( D \) operator.

The \( D \) operator returns a functional operator.

For example, find the derivative of an operator that represents the mathematical function \( x \cos(x) \).

First, define the mathematical function \( x \cos(x) \) as the operator \( F \).

1. In the **Expression** palette, click the single-variable function definition item \( f := x \rightarrow y \).
2. Enter placeholder values.
   - To move to the next placeholder, press the **Tab** key. **Note:** If pressing the **Tab** key inserts a tab, click the Tab icon \( \text{Tab} \) in the toolbar.

\[ F := x \rightarrow x \cos(x) : \]

Now, define the operator, \( G \), that maps \( x \) to the derivative of \( x \cos(x) \).
> G := D(F)

\[ G := x \mapsto \cos(x) - x \sin(x) \]

\( F \) and \( G \) evaluated at \( \pi/2 \) return the expected values.

\[ > F\left(\frac{\pi}{2}\right); G\left(\frac{\pi}{2}\right) \]

\[ 0 \]

\[ -\frac{1}{2} \pi \]

For more information on the \( \textbf{D} \) operator, refer to the \texttt{?D} help page. For a comparison of the \texttt{diff} command and \( \textbf{D} \) operator, refer to the \texttt{?diffVersusD} help page.

\textbf{Directional Derivative}

To compute and plot a directional derivative, use the \textbf{Directional Derivative Tutor}. The tutor computes a floating-point value for the directional derivative.

\textbf{To launch the tutor:}

From the \texttt{Tools} menu, select \texttt{Tutors, Calculus - Multi-Variable}, and then \texttt{Directional Derivatives}. Maple launches the \textbf{Directional Derivative Tutor}. See Figure 4.7.
To compute a symbolic value for the directional derivative, use the `Student[MultivariateCalculus][DirectionalDerivative]` command. The first list of numbers specifies the point at which to compute the derivative. The second list of numbers specifies the direction in which to compute the derivative.

For example, at the point \([1, 2]\), the gradient of \(x^2 + y^2\) points in the direction \([2, 4]\), which is the direction of greatest increase. The directional derivative in the orthogonal direction \([-2, 1]\) is zero.

\[
> \text{with(Student[MultivariateCalculus])}:
\]

\[
\text{DirectionalDerivative}(x^2+y^2, [x, y] = [1, 1], [1, 2], \text{output = plot});
\]
To generate the Taylor series expansion of a function about a point, use the `taylor` command.

```latex
\text{DirectionalDerivative}(x^2 + y^2, [x, y] = [1, 2], [1, 2]);
2 \sqrt{5}
```

```latex
\text{DirectionalDerivative}(x^2 + y^2, [x, y] = [1, 2], [-2, 1]);
0
```

**Series**

To generate the Taylor series expansion of a function about a point, use the `taylor` command.

```latex
\text{taylor} (\sin (4x) \cos (x), x=0)
4x - \frac{38}{3} x^3 + \frac{421}{30} x^5 + O(x^6)
```

**Note:** If a Taylor series does not exist, use the `series` command to find a general series expansion.

For example, the cosine integral function does not have a taylor series expansion about 0. For more information, refer to the `?Ci` help page.

```latex
\text{taylor} (\text{Ci}(x), x=0)
\text{Error, does not have a taylor expansion, try series()}
```

To generate a truncated series expansion of a function about a point, use the `series` command.

```latex
\text{series} (\text{Ci}(x), x=0)
\gamma + \ln(x) - \frac{1}{4} x^2 + \frac{1}{96} x^4 + O(x^6)
```
By default, Maple performs series calculations up to order 6. To use a different order, specify a non-negative integer third argument.

```maple
> expansion := series(Ci(t), t = 0, 4)
```

```
expansion := γ + ln(t) − \frac{1}{4} t^2 + O(t^4)
```

To set the order for all computations, use the `Order` environment variable. For information about the `Order` variable and the $O(t^4)$ term, refer to the `?Order` help page.

The expansion is of type `series`. Some commands, for example, `plot`, do not accept arguments of type `series`. To use the expansion, you must convert it to a polynomial using the `convert/polynom` command.

```maple
> plot({Ci(t), convert(expansion, polynom)}, t = \frac{1}{100} \ldots 2)
```
For information on Maple types and type conversions, see *Maple Expressions* (page 285).

For information on plotting, see *Plots and Animations* (page 187).

**Integration**

Maple can perform symbolic and numeric integration.

**To compute the indefinite integral of an expression:**

1. In the Expression palette, click the indefinite integration item $\int f \, dx$.
2. Specify the integrand and variable of integration, and then evaluate it.

For example, to integrate $x \sin(a \, x)$ with respect to $x$:

$$> \int x \sin(a \, x) \, dx$$

$$\frac{\sin(a \, x) - x \cos(a \, x) \, a}{a^2}$$

Recall that you can also enter symbols, including $\int$ and $\, dx$, using symbol completion.

- Enter the symbol name (or part of the name), for example, `int` and `d`, and then press the completion shortcut key.

For more information, see *Symbol Names* (page 16).

You can also compute an indefinite integral using context menus. For more information, see *Context Menus* (page 20).
To compute the definite integral of an expression:

1. In the **Expression** palette, click the definite integration item \( \int_a^b \).

2. Specify the endpoints of the interval of integration, integrand expression, and variable of integration, and then evaluate it.

For example, to integrate \( e^{(-a \cdot t)} \ln(t) \) over the interval \((0, \infty)\):

\[
> \int_0^\infty e^{(-a \cdot t)} \ln(t) \, dt
\]

\[
\lim_{{t \to \infty}} \left( - \frac{e^{-a \cdot t} \ln(t) + \text{Ei}(1, a \cdot t) + \gamma + \ln(a)}{a} \right)
\]

(4.2)

Maple treats the parameter \( a \) as a complex number. As described in *Assumptions on Variables (page 116)*, you can compute under the assumption that \( a \) is a positive, real number using the **assuming** command.

\[
> \int_0^\infty e^{-a \cdot t} \ln(t) \, dt \text{ assuming } a > 0
\]

\[
- \frac{\ln(a)}{a} - \frac{\gamma}{a}
\]

**The int Command**

\( \int_a^b f \, dx \) and \( \int_a^b f \, dx \) use the **int** command. To use the **int** command directly, specify the following arguments.

- Expression to integrate
- Variable of integration
For a definite integration, set the variable of integration equal to the interval of integration.

\[ \int \left( \frac{\sin(ax) - x \cos(ax)}{a^2} \right) \]

For a definite integration, set the variable of integration equal to the interval of integration.

\[ \int \left( \frac{\pi}{a^2} \right) \]

**Numeric Integration**

**To perform numeric integration:**

- Use the `evalf(Int(arguments))` calling sequence.

**Important:** Use the inert `Int` command, not the `int` command. For more information, refer to the `?int` help page.

In addition to the arguments accepted by the `int` command, you can include optional arguments such as `method`, which specifies the numeric integration method.

For example:

\[ \text{evalf} \left( \text{Int} \left( \frac{1}{\Gamma(x)}, x = 0 .. 2, \text{\textquoteleft} method = _Dexp \text{\textquoteright} \right) \right) \]
Note: To enter an underscore character (_) in 2-D Math, enter \_.

For information on the `evalf` command, see *Numerical Approximation* (page 313).

For information on numeric integration, including iterated integration and controlling the algorithm, refer to the `?evalf/Int` help page.

To compute iterated integrals, line integrals, and surface integrals, use the task templates (Tools>Tasks>Browse) in the Multivariate and Vector Calculus folders.

**Differential Equations**

Maple has a powerful set of solvers for ordinary differential equations (ODEs) and partial differential equations (PDEs), and systems of ODEs and PDEs.

For information on solving ODEs and PDEs, see *Other Specialized Solvers* (page 88).

**Calculus Packages**

In addition to top-level calculus commands, Maple contains calculus packages.

**VectorCalculus Package**

The `VectorCalculus` package contains commands that perform multivariate and vector calculus operations on `VectorCalculus` vectors (vectors with an additional coordinate system attribute) and vector fields (vectors with additional coordinate system and `vectorfield` attributes), for example, `Curl`, `Flux`, and `Torsion`.

```maple
> with(VectorCalculus):
> SetCoordinates( 'cartesian'[x,y,z]):
```
Find the curl of \textit{VectorField1}.

\[ \text{Curl(VectorField1)}; \]
\[
\begin{bmatrix}
\text{0} \\
\text{0} \\
\text{2}
\end{bmatrix}
\]

Find the flux of \textit{VectorField1} through a sphere of radius \( r \) at the origin.

\[ \text{Flux(VectorField1, Sphere( <0, 0, 0>, r))} \]
\[
\frac{4}{3} r^3 \pi
\]

Compute the torsion of a space curve. The curve must be a vector with parametric function components.

\[ \text{simplify(Torsion( <t, t^2, t^3>, t)) assuming t::real} \]
\[
3 \frac{1}{9 t^4 + 9 t^2 + 1}
\]

For information on the \texttt{assuming} command, see \textit{The assuming Command (page 118)}.

For more information on the \texttt{VectorCalculus} package, including a complete list of commands, refer to the \texttt{?VectorCalculus} help page.
To find other calculus packages, such as \texttt{VariationalCalculus}, refer to the \texttt{?index/package} help page.

\section*{Student Calculus Packages}

The \texttt{Student} package contains subpackages that help instructors teach concepts and allow students to visualize and explore ideas. These subpackages also contain computational commands. The \texttt{Student} calculus subpackages include \texttt{Calculus1}, \texttt{MultivariateCalculus}, and \texttt{VectorCalculus}. The \texttt{Student[VectorCalculus]} package provides a simple interface to a limited subset of the functionality available in the \texttt{VectorCalculus} package.

For information on using Maple as a teaching and learning tool, and some computational examples, see \textit{Teaching and Learning with Maple} (page 178).

\section*{4.5 Optimization}

Using the \texttt{Optimization} package, you can numerically solve optimization problems. The package uses fast Numerical Algorithms Group (NAG) algorithms to \textit{minimize} or \textit{maximize} an objective function.

The \texttt{Optimization} package solves constrained and unconstrained problems.

- Linear programs
- Quadratic programs
- Nonlinear programs
- Linear and nonlinear least-squares problems

The \texttt{Optimization} package contains local solvers. In addition, for univariate finitely-bounded nonlinear programs with no other constraints, you can compute global solutions using the \texttt{NLPSolve} command. To find global solutions generally, purchase the \texttt{Global Optimization Toolbox}. For more information, visit \url{http://www.maplesoft.com/products/toolboxes}. 
Point-and-Click Interface

The primary method for solving optimization problems is the Optimization Assistant.

To launch the Optimization Assistant:

- From the Tools menu, select Assistants, and then Optimization.

Maple inserts the Optimization[Interactive]() calling sequence (in Worksheet mode), and launches the Optimization Assistant. See Figure 4.8.

![Figure 4.8: Optimization Assistant](image)

To solve a problem:

1. Enter the objective function, constraints, and bounds.
2. Select the **Minimize** or **Maximize** radio button.

3. Click the **Solve** button. The solution is displayed in the **Solution** text box.

You can also enter the problem (objective function, constraints, and bounds) in the calling sequence.

For example, find the maximum of \( x^3y - y^2 \) subject to the constraints 
\[ x + y \leq 6, x \in [0,5], y \in [0,5] \, . \]

\[
> \text{Optimization[Interactive]}(x^3y - y^2, \{x + y \leq 6, x = 0..5, y = 0..5\})
\]

\[
[134.491161539748276, [y = 1.46440707460870768, x = 4.53559292539129277]]
\]

After finding a solution, you can plot it. To plot a solution:

In the **Optimization Assistant** window, click the **Plot** button. The **Optimization Plotter** window is displayed. See Figure 4.9.
Figure 4.9: Optimization Assistant Plotter Window

For information on the algorithms used to solve optimization problems, refer to the `?Optimization/Methods` help page.

**Large Optimization Problems**

The **Optimization Assistant** accepts input in an algebraic form. You can specify input in other forms, described in the `?Optimization/InputForms` help page, in command calling sequences.
The Matrix form, described in the \texttt{Optimization/MatrixForm} help page, is more complex but offers greater flexibility and efficiency.

For example, solve the quadratic program:

\[
\text{maximize } \mathbf{c}^T \mathbf{x} + \frac{1}{2} \mathbf{x}^T \mathbf{H} \mathbf{x} \text{ subject to } \mathbf{A} \mathbf{x} \leq \mathbf{b}, \text{ where } \mathbf{x} \text{ is the vector of problem variables.}
\]

Define the column vector, \( \mathbf{c} \), of the quadratic objective function.

\[ > \mathbf{c} := \text{Vector}([2, 5], \text{\'datatype\' = \'float\'}); \]

Define the symmetric Hessian matrix, \( \mathbf{H} \), of the quadratic objective function.

\[ > \mathbf{H} := \text{Matrix}([[6, 3], [3, 4]], \text{\'datatype\' = \'float\'}); \]

Define the matrix \( \mathbf{A} \), the coefficient matrix for the linear inequality constraints.

\[ > \mathbf{A} := \text{Matrix}([[\mathbf{-1}, 1]], \text{\'datatype\' = \'float\'}); \]

Define the column vector \( \mathbf{b} \), the linear inequality constraints.

\[ > \mathbf{b} := \text{Vector([-2], \text{\'datatype\' = \'float\'});} \]

The \texttt{QPSolve} command solves quadratic programs.

\[ > \text{Optimization[QPSolve]}([\mathbf{c}, \mathbf{H}], [\mathbf{A}, \mathbf{b}]) \]

\[
\begin{bmatrix}
-3.533333333333333 \\
0.466666666666666564 \\
-1.60000000000000030
\end{bmatrix}
\]

\textbf{Note:} For information on creating matrices and vectors (including how to use the \texttt{Matrix} palette to easily create matrices), see Linear Algebra (page 133).
For additional information on performing efficient computations, refer to the `Optimization/Computation` help page.

**MPS(X) File Support**

To import linear programs from a standard MPS(X) data file, use the `Import-MPS` command.

**Additional Information**

For a complete list of commands and other `Optimization` package information, refer to the `Optimization` help page.

### 4.6 Statistics

The `Statistics` package is a collection of commands and the point-and-click `Data Analysis Assistant`—refer to the `Statistics[InteractiveDataAnalysis]` help page—for performing computations in mathematical statistics and data analysis. The package supports a wide range of common statistical tasks including quantitative and graphical data analysis, simulation, and curve fitting.

In addition to standard data analysis tools, the `Statistics` package provides a wide range of symbolic and numeric tools for computing with random variables. The package supports over 35 major probability distributions and can be extended to include new distributions.

**Probability Distributions and Random Variables**

The `Statistics` package supports:

- Continuous distributions, which are defined along the real line by probability density functions. Maple supports many continuous distributions, including the normal, Student-t, Laplace, and logistic distributions.
- Discrete distributions, which have nonzero probability only at discrete points. A discrete distribution is defined by a probability function. Maple
supports many discrete distributions, including the Bernoulli, geometric, and Poisson distributions.

For a complete list of distributions, refer to the ?Statistics/Distributions help page.

You can define random variables by specifying a distribution in a call to the RandomVariable command.

> with(Statistics):

> X := RandomVariable(Poisson(λ)):

Find the probability distribution function for X. (For information on statistics computations, see Statistical Computations (page 173)).

> PDF(X, t)

\[
\sum_{k=0}^{\infty} \frac{\lambda^k e^{-\lambda}}{k!} \delta(t - k)
\]

δ represents the Dirac delta function. For more information, refer to the ?Dirac help page.

Adding Custom Distributions

To add a new distribution, specify a probability distribution in a call to the Distribution command.

> U := Distribution(PDF = t -> \begin{cases} 0 & t < 0 \\ \frac{1}{3} & t < 3 \\ 0 & \text{otherwise} \end{cases}):

To construct a piecewise-continuous function in 1-D Math, use the piecewise command, for example, t -> piecewise(t < 0, 0, t < 3, 1/3, 0).
Define a new random variable with this distribution.

\[ Z := \text{RandomVariable}(U): \text{PDF}(Z, t) \]

\[
\begin{align*}
0 & \quad t < 0 \\
\frac{1}{3} & \quad t < 3 \\
0 & \quad \text{otherwise}
\end{align*}
\]

Calculate the mean value of the random variable.

\[ \text{Mean}(Z) \]

\[
\frac{3}{2}
\]

For more information, refer to the \texttt{?Statistics/Distributions} help page.

**Statistical Computations**

In addition to basic functions, like mean, median, standard deviation, and percentile, the \texttt{Statistics} package contains commands that compute, for example, the interquartile range and hazard rate.

**Examples**

**Example 1**

Compute the average absolute range from the interquartile of the Rayleigh distribution with scale parameter 3.

\[ \text{InterquartileRange}(\text{Rayleigh}(3)) \]

\[
\sqrt{36} \sqrt{\ln(2)} - \sqrt{-18 \ln\left(\frac{3}{4}\right)}
\]

To compute the result numerically:
Specify the 'numeric' option.

> InterquartileRange(Rayleigh(3), 'numeric')

2.719744818

Example 2

Compute the hazard rate of the Cauchy distribution with location and scale parameters \(a\) and \(b\) at an arbitrary point \(t\).

> HazardRate(Cauchy(a, b), t)

\[
\frac{1}{\pi b \left(1 + \frac{(t - a)^2}{b^2}\right) \left(\frac{1}{2} - \frac{\arctan\left(\frac{t - a}{b}\right)}{\pi}\right)}
\]

You can specify a value for the point \(t\).

> HazardRate(Cauchy(a, b), 1/2)

\[
\frac{1}{\pi b \left(1 + \left(\frac{1}{2} - a\right)^2 \right) \left(\frac{1}{2} - \frac{\arctan\left(\frac{1}{2} - a\right)}{\pi}\right)}
\]

You can also specify that Maple compute the result numerically.

> HazardRate(Cauchy(10, 1), 1/2, 'numeric')

0.003608801460
For more information, refer to the \texttt{?Statistics/DescriptiveStatistics} help page.

## Plotting

You can generate statistical plots using the visualization commands in the \texttt{Statistics} package. Available plots include:

- Bar chart
- Frequency plot
- Histogram
- Pie Chart
- Scatter Plot

For example, create a scatter plot for a distribution of points that vary from $\sin\left(\frac{2\pi x}{200}\right)$ by a small value determined by a normally distributed sample.

\[ N := 200; \]
\[ U := \text{Sample}(\text{Normal}(0, 1), N); \]
\[ X := \langle \text{seq}(x, x = 1 .. N) \rangle; \]
\[ Y := \langle \text{seq}\left(\sin\left(\frac{2\pi x}{N}\right) + \frac{U[x]}{5}, x = 1 .. N\right) \rangle; \]
\[ \text{ScatterPlot}(X, Y, \text{title} = "\text{Scatter Plot}"); \]
For information on plotting options, such as title, see Plots and Animations (page 187).

To fit a curve to the data points, include the optional fit equation parameter.

Using the plots[display] command, create a plot that contains the:

- Scatter plot of the data points
- Quartic polynomial fitted to the data points: 
  \[ f(x) = ax^4 + bx^3 + cx^2 + dx + e \]
- Function \( \sin(2\pi x/N) \)

\[ P := \text{ScatterPlot}(X, Y, \text{fit} = [ax^4 + bx^3 + cx^2 + dx + e, x], \text{thickness} = 2) ; \]
For more information on statistical plots, refer to the ?Statistics/Visualization help page.

For an overview of plotting, see *Plots and Animations* (page 187).

**Additional Information**

For more information on the Statistics package, including regression analysis, estimation, data manipulation, and data smoothing, refer to the ?Statistics help page.
4.7 Teaching and Learning with Maple

Table 4.10 resources for instructors and students. For additional resources see Table 4.1 (page 121).

Table 4.10: Student and Instructor Resources

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Student Packages and Tutors</td>
<td>The <strong>Student</strong> package contains computational and visualization (plotting and animation) functionality, and point-and-click interfaces for explaining and exploring concepts (<strong>Tools&gt;Tutors</strong>). For more information, refer to the ?<strong>Student</strong> help page.</td>
</tr>
<tr>
<td>Mathematics and Engineering Dictionary</td>
<td>The Maple Help System has an integrated dictionary of over 5000 mathematics and engineering terms. You can search the dictionary using the Help System search engine. (<strong>Help&gt;Manuals, Dictionary, and more&gt;Dictionary</strong>)</td>
</tr>
<tr>
<td>Maple Application Center™</td>
<td>The Maple Application Center contains tutorials and applications that help instructors begin using Maple and use Maple in the classroom. Browse the many resources in the <strong>Education</strong> and <strong>Education PowerTools</strong> categories. (<strong><a href="http://www.maplesoft.com/applications">http://www.maplesoft.com/applications</a></strong>)</td>
</tr>
</tbody>
</table>
The Maple Student Center contains tutorials and applications that help students learn how to use Maple, explore mathematical concepts, and solve problems. Available resources include:

- **Study guides** - Complete lessons with examples for academic courses, including precalculus and calculus. For example, the Interactive Precalculus Study Guide contains worked problems, each solved as in a standard textbook, using Maple commands and custom Maplet graphical interfaces.

- **Free course lessons** for many subjects including precalculus to vector calculus; high school, abstract, and linear algebra; engineering; physics; differential equations; cryptography; and classical mechanics. ([http://www.maplesoft.com/academic/students](http://www.maplesoft.com/academic/students))

<table>
<thead>
<tr>
<th><strong>Resource</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Maple Student Center™</td>
<td>The Maple Student Center contains tutorials and applications that help students learn how to use Maple, explore mathematical concepts, and solve problems. Available resources include:</td>
</tr>
<tr>
<td></td>
<td>• Study guides - Complete lessons with examples for academic courses, including precalculus and calculus. For example, the Interactive Precalculus Study Guide contains worked problems, each solved as in a standard textbook, using Maple commands and custom Maplet graphical interfaces.</td>
</tr>
<tr>
<td></td>
<td>• Free course lessons for many subjects including precalculus to vector calculus; high school, abstract, and linear algebra; engineering; physics; differential equations; cryptography; and classical mechanics.</td>
</tr>
</tbody>
</table>

### Student Packages and Tutors

The **Student** package is a collection of subpackages for teaching and learning mathematics and related subjects. The **Student** package contains packages for a variety of subjects, including precalculus, calculus, and linear algebra.

Instructors can:

- Teach concepts without being distracted by the mechanics of the computations.
- Create examples and quickly update them during a lesson to demonstrate different cases or show the effect of the variation of a parameter.
- Create plots and animations to visually explain concepts, for example, the geometric relationship between a mathematical function and its derivatives ([Tools>Tutors>Calculus - Single Variable>Derivatives](#)). See Figure 4.10.
Students can:

- Perform step-by-step computations, for example, compute a derivative by applying differentiation rules using commands or a tutor (Tools>Tutors>Calculus - Single Variable>Differentiation Methods). See Figure 4.11.

- Perform computations.

- Visually explore concepts.
Tutors provide point-and-click interfaces to the Student package functionality.

To launch a tutor:

1. From the Tools menu, select Tutors.
2. Select a subject, for example, Calculus - Multi-Variable.
3. Select a tutor, for example, Gradients.
Maple inserts the `Student[MultivariateCalculus][GradientTutor]()` calling sequence (in Worksheet mode), and launches the **Multivariate Calculus Gradient Tutor**.

By rotating the three-dimensional plot, you can show that the gradient points in the direction of greatest increase of the surface (see Figure 4.12) and show the direction of the gradient vector in the x-y plane (see Figure 4.13).

**Figure 4.12: Multivariate Calculus Gradient Tutor**
Figure 4.13: Multivariate Calculus Gradient Tutor Showing x-y Plane

When you close the tutor, Maple inserts the 3-D plot.

> Student[MultivariateCalculus][GradientTutor]();
Many Student package commands can return a value, mathematical expression, plot, or animation. This allows you to compute the final answer, see the general formula applied to a specific problem, or visualize the underlying concepts.

For example, the `Student[VectorCalculus][LineInt]` (line integral) command can return the following.

- Plot that visually indicates the vector field, path of integration, and tangent vectors to the path
- Unevaluated line integral
- Numeric value of the line integral

```maple
> with(Student[VectorCalculus]):

> LineInt(VectorField( <y, -x> ), Circle( <0, 0>, 1), 'output' = 'plot')
```
To evaluate the integral returned by the `output = integral` calling sequence, use the `value` command.

> value((4.4))

\[-2 \pi\]

By default, the `LineInt` command returns the value of the integral.

> LineInt(VectorField( <y, -x>, Circle( <0, 0>, r) )`
\[ -2 \pi r^2 \]

For more information on the Student package, refer to the `Student` help page.
5 Plots and Animations

Maple can generate many forms of plots, allowing you to visualize a problem and further understand concepts.

- Maple accepts explicit, implicit, and parametric forms to display 2-D and 3-D plots and animations.
- Maple recognizes many coordinate systems.
- All plot regions in Maple are active; therefore, you can drag expressions to and from a plot region.
- Maple offers numerous plot options, such as axes styles, title, colors, shading options, surface styles, and axes ranges, which give you complete control to customize your plots.

5.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Creating Plots - Interactive and command-driven methods to display 2-D and 3-D plots | • **Interactive Plot Builder**  
• Context Menu  
• Dragging to a Plot Region  
• The `plot` and `plot3d` Commands  
• The `plots` Package  
• Multiple Plots in the Same Plot Region |
| Customizing Plots - Methods for applying plot options before and after a plot displays | • **Interactive Plot Builder** Options  
• Context Menu Options  
• The `plot` and `plot3d` Command Options |
<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analyzing Plots - Plot analyzing tools</td>
<td>• Point Probe  &lt;br&gt;• Rotate  &lt;br&gt;• Pan  &lt;br&gt;• Zoom</td>
</tr>
<tr>
<td>Creating Animations - Interactive and command-driven methods to display animations</td>
<td>• <strong>Interactive Plot Builder</strong>&lt;br&gt;• The <code>plots[animate]</code> Command</td>
</tr>
<tr>
<td>Playing Animations - Tools to run animations</td>
<td>• Animation Context Bar</td>
</tr>
<tr>
<td>Customizing Animations - Methods for applying plot options before and after an animation displays</td>
<td>• <strong>Interactive Plot Builder</strong> Animation Options&lt;br&gt;• Context Menu Options&lt;br&gt;• The <code>animate</code> Command Options</td>
</tr>
<tr>
<td>Exporting - Methods for exporting plots</td>
<td>• Saving Plots to File Formats</td>
</tr>
<tr>
<td>Code for Color Plates - Information on color plates</td>
<td>• Accessing Code for the Color Plates</td>
</tr>
</tbody>
</table>

## 5.2 Creating Plots

Maple offers several methods to easily plot an expression. These methods include:

- The **Interactive Plot Builder**
- Context menus
- Dragging to a plot region
- Commands

Each method offers a unique set of advantages. The method you use depends on the type of plot to display, as well as your personal preferences.
Interactive Plot Builder

The Interactive Plot Builder is a point-and-click interface to the Maple plotting functionality. The interface displays plot types based on the expression you specify. The available plot types include plots, interactive plots, animations, or interactive animations. Depending on the plot type you select, you can create a:

- 2-D / 3-D plot
- 2-D / 3-D conformal plot of a complex-valued function
- 2-D / 3-D complex plot
- 2-D density plot
- 2-D gradient vector-field plot
- 2-D implicit plot

Using the Interactive Plot Builder, you can:

1. Specify the plotting domain before you launch the graph
2. Specify the endpoints of the graph as symbolic, for example, Pi, sqrt(2)
3. Select different kinds of graphs such as animations, and interactive with slider control of the parameter, that is, customize and display a plot by selecting from the numerous plot types and applying plot options without any knowledge of plotting command syntax
4. Apply the `discont=true` option for a discontinuous graph

The output from the Interactive Plot Builder is a plot of the expression or the command used to generate the plot in the document.

To launch the Interactive Plot Builder:

- From the Tools menu, select Assistants, and then Plot Builder. **Note:** The Tools menu also offers tutors to easily generate plots in several academic subjects. For more information, see Teaching and Learning with Maple (page 178).
Table 5.1: Windows of the Interactive Plot Builder

1. Specify Expressions window

   - Add, edit, or remove expressions and variables. Once finished, you can advance to the Select Plot Type window.

2. Select Plot Type window

   - Select the plot type and corresponding plot, and edit the ranges. Once finished, you can display the plot or advance to the Plot Options window.
3. **Plot Options window** - Apply plot options. Once finished, you can display the plot or return the command that generates the plot to the document.
### Example 1 - Display a plot of a single variable expression

Maple can display two-dimensional graphs and offers numerous plot options such as color, title, and axes styles to customize the plot.

#### Table 5.2: Displaying a Plot of a Single Variable Expression

<table>
<thead>
<tr>
<th>Step</th>
<th>Details</th>
</tr>
</thead>
</table>
| Launch the **Interactive Plot Builder**. | 1. Ensure the cursor is in a Maple input region.  
2. From the **Tools** menu, select **Assistants**, and then **Plot Builder**.  
Notes: 1. Maple inserts `plots[interactive]();` in the Maple document. Entering this command at the Maple prompt also invokes the Plot Builder.  
2. Interaction with the document is disabled while the **Plot Builder** is running. |
| Enter an expression.        | 1. In the **Specify Expressions** window:  
a. Add the expression, `sin(x)/x`.  
b. Click **Done** to proceed to the **Select Plot Type** window. |
<table>
<thead>
<tr>
<th>Step</th>
<th>Details</th>
</tr>
</thead>
</table>
| Plot the expression. | 1. In the **Select Plot Type** window, notice the default setting of a 2-D plot type and an x axis range, -10 .. 10. Notice also the various plot types available for this expression.  
2. Click **Plot**. |

To see the Maple syntax used to generate this plot, see *Maple commands from Creating Plots: Interactive Plot Builder* (page 207)

**Example 2 - Display a plot of multiple expressions of 1 variable**

Maple can display multiple expressions in the same plot region to compare and contrast. The **Interactive Plot Builder** accepts multiple expressions.
### Table 5.3: Displaying a Plot of Multiple Expressions of 1 Variable

<table>
<thead>
<tr>
<th>Step</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Launch the Interactive Plot Builder</strong></td>
<td>1. Launch the Interactive Plot Builder. The Plot Builder accepts expressions and performs basic calculations on expressions. For example, entering ( \text{diff(sin(x^2), x)} ) in the Specify Expression window performs the calculation and displays the expression as ( 2\cos(x^2)\cdot x ) in the Expression group box.</td>
</tr>
<tr>
<td><strong>In the Specify Expressions window:</strong></td>
<td>2. In the Specify Expressions window: ( \text{a. In three separate steps, add the expressions } \sin(x^2), \text{diff}(\sin(x^2), x), \text{and int}(\sin(x^2), x) ).</td>
</tr>
<tr>
<td><strong>Change the x-axis range.</strong></td>
<td>In the Select Plot Type window: ( \text{a. Change the x Axis range to -3 .. 3.} )</td>
</tr>
<tr>
<td><strong>Launch the Plot Options window</strong></td>
<td>( \text{b. Click Options to proceed to the Plot Options window.} )</td>
</tr>
<tr>
<td><strong>Display the actual plot.</strong></td>
<td>Click Command. ( \text{Click Command.} ) ( \text{Execute the inserted command, that is, display the plot.} )</td>
</tr>
</tbody>
</table>
By default, Maple displays each plot in a plot region using a different color. You can also apply a line style such as solid, dashed, or dotted for each expression in the graph. For more information, refer to the ?plot/options help page. To see the Maple syntax used to generate this plot, see Maple commands from Creating Plots: Interactive Plot Builder (page 207)

**Example 3 - Display a plot of a multi-variable expression**

Maple can display three-dimensional plots and offers numerous plot options such as light models, surface styles, and shadings to allow you to customize the plot.

**Table 5.4: Displaying a Plot of a Multi-variable Expression**

<table>
<thead>
<tr>
<th>Step</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Launch the <strong>Interactive Plot Builder</strong></td>
<td>Add the expression ((1+\sin(x*y))/(x^2+y^2)).</td>
</tr>
<tr>
<td>Step</td>
<td>Details</td>
</tr>
<tr>
<td>------</td>
<td>---------</td>
</tr>
</tbody>
</table>
| Launch the **Plot Options** window. | In the **Select Plot Type** window:  
  a. Notice the available plot types for an expression with 2 variables, as well as the plot objects for each type.  
  b. Click **Options**. |
| Set plot options. | In the **Plot Options** window:  
  a. From the **Variables** column, change the **Range** fields to 0 .. 0.05.  
  b. From the **Labels** column, enter z.  
  c. From the **Color** group box, select **Light Model**, and then **green-red**.  
  d. From the **Color** group box, select **Shading**, and then z (grayscale).  
  e. From the **Style** group box, select **patch w/o grid**.  
  f. From the **Miscellaneous** group box, select **Grid Size**, and then 40, 40. |
| Plot the expression. | Click **Plot**. |
To see the Maple syntax used to generate this plot, see *Maple commands from Creating Plots: Interactive Plot Builder* (page 207)

**Example 4 - Display a conformal plot**

Maple can display a conformal plot of a complex expression mapped onto a two-dimensional grid or plotted on the Riemann sphere in 3-D.

**Table 5.5: Displaying a Conformal Plot**

<table>
<thead>
<tr>
<th>Step</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Launch the <strong>Interactive Plot Builder</strong></td>
<td>Add the expression $z^3$.</td>
</tr>
<tr>
<td>and enter an expression.</td>
<td></td>
</tr>
<tr>
<td>Step</td>
<td>Details</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Select a plot type.</td>
<td>In the Select Plot Type window:</td>
</tr>
<tr>
<td></td>
<td>a. From the Select Plot group box, select 2-D conformal plot of a complex-valued expression.</td>
</tr>
<tr>
<td></td>
<td>b. Change the range of the z parameter to 0 .. 2+2*I.</td>
</tr>
<tr>
<td>Set plot options.</td>
<td>In the Plot Options window:</td>
</tr>
<tr>
<td></td>
<td>a. From the Axes group box, select normal.</td>
</tr>
<tr>
<td></td>
<td>b. From the Miscellaneous group box, select the Grid Size drop-down menu option 30, 30.</td>
</tr>
<tr>
<td>Plot the expression.</td>
<td>Click Plot.</td>
</tr>
</tbody>
</table>

![Diagram of a 2-D conformal plot of a complex-valued expression](image-url)
Example 5 - Display a plot in polar coordinates

Cartesian (ordinary) coordinates is the Maple default. Maple also supports numerous other coordinate systems, including hyperbolic, inverse elliptic, logarithmic, parabolic, polar, and rose in two-dimensions, and bipolar cylindrical, bispherical, cylindrical, inverse elliptical cylindrical, logarithmic cosh cylindrical, Maxwell cylindrical, tangent sphere, and toroidal in three-dimensional plots. For a complete list of supported coordinate systems, refer to the ?coords help page.

Table 5.6: Displaying a Plot in Polar Coordinates

<table>
<thead>
<tr>
<th>Step</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Launch the <strong>Interactive Plot Builder</strong> and enter an expression.</td>
<td>Add the expression $1+4\cos(4\theta)$.</td>
</tr>
<tr>
<td>Change the x-axis range.</td>
<td>In the <strong>Select Plot Type</strong> window:</td>
</tr>
<tr>
<td></td>
<td>a. Change the x axis range to $0 \ldots 8\pi$.</td>
</tr>
<tr>
<td>Set plot options.</td>
<td>In the <strong>Plot Options</strong> window:</td>
</tr>
<tr>
<td></td>
<td>a. From the <strong>Coordinate System</strong> group box, select <strong>polar</strong>.</td>
</tr>
<tr>
<td></td>
<td>b. From the <strong>Color</strong> group box drop down menu, select <strong>magenta</strong>.</td>
</tr>
<tr>
<td>Plot the expression.</td>
<td>Click <strong>Plot</strong>.</td>
</tr>
</tbody>
</table>
To see the Maple syntax used to generate this plot, see *Maple commands from Creating Plots: Interactive Plot Builder* (page 207)

**Example 6 - Interactive Plotting**

Using the **Interactive Plot Builder**, you can plot an expression with several of its variables set to numeric values. The **Interactive Parameter** window allows you to interactively adjust these numeric values within specified ranges to observe their effect.
Figure 5.1: Interactive Parameter Window

Table 5.7: Interactive Plotting

<table>
<thead>
<tr>
<th>Steps</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Launch the Interactive Plot Builder and enter an expression.</td>
<td>Add the expression $x+3\sin(xt)$.</td>
</tr>
<tr>
<td>Steps</td>
<td>Details</td>
</tr>
<tr>
<td>-----------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Select a plot type.</td>
<td>In the <strong>Select Plot Type</strong> window:</td>
</tr>
<tr>
<td></td>
<td>a. From the <strong>Select Plot</strong> group box, select</td>
</tr>
<tr>
<td></td>
<td><strong>Interactive Plot with 1 parameter.</strong></td>
</tr>
<tr>
<td></td>
<td>b. Change the range of the <strong>x-axis</strong> to <strong>0 .. 5.</strong></td>
</tr>
<tr>
<td></td>
<td>c. Change the <strong>t</strong> range to <strong>0 .. 10.</strong></td>
</tr>
<tr>
<td></td>
<td>d. Click <strong>Plot</strong> to launch the <strong>Interactive Parameter</strong> window.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> To apply plot options before interactively adjusting the plot, click <strong>Options</strong> to launch the <strong>Plot Options</strong> window.</td>
</tr>
<tr>
<td></td>
<td>After setting the plot options, click <strong>Plot</strong> to display the <strong>Interactive Parameter window.</strong></td>
</tr>
<tr>
<td>Adjust the plot.</td>
<td>1. To adjust the numeric values, use the slider.</td>
</tr>
<tr>
<td></td>
<td>2. Click <strong>Done</strong> to return the plot to the Maple document.</td>
</tr>
</tbody>
</table>
To see the Maple syntax used to generate this plot, see *Maple commands from Creating Plots: Interactive Plot Builder* (page 207).

For information on customizing plots using the **Interactive Plot Builder**, refer to *Customizing Plots: Interactive Plot Builder Options* (page 215).

**Context Menu**

A context menu in Maple displays a list of commands to manipulate, display, or calculate using a Maple expression. The commands in the menu depend on the type of the expression. To display the context menu for a Maple expression, right-click (for Macintosh, **Control**-click) the expression.

For expressions, the context menu lists:

- 2-D or 3-D plot
- 2-D or 3-D implicit plot
- **Interactive Plot Builder**

based on the expression selected.
By invoking the **Interactive Plot Builder** through the context menu, the expression automatically passes to the builder and Maple does not display the **Specify Expression** window.

One advantage of using the context menu is the simplicity of creating an expression using menus. By using this method, you do not need any knowledge of plot command syntax.

1. Enter and evaluate an expression, for example, \( \frac{xy}{x^2+y^2} \).

2. Right-click (**Control**-click for Macintosh) the expression.

3. From the context menu, select **Plots > 3-D Plot > x,y**.
\[ \frac{xy}{x^2 + y^2} \]
For information on customizing plots using the context menu, see Context Menu Options (page 216).

**Dragging to a Plot Region**

To use the drag-and-drop method, use the plot region created by one of the other methods or insert an empty plot region into the document. Empty plot regions can be two-dimensional or three-dimensional.

Advantages of the drag-and-drop method include the ease of adding and removing plots and the independence from plotting command syntax.

1. From the **Insert** menu, select **Plot**, and then **2D**.

2. Enter the expression $\sin(x)$ in an input region.

3. Select the full expression in the input region and drag it into the plot region.

4. Repeat steps 2 and 3 using the following expressions: $\sin(2x)$, $\sin(x+2)$, and $\sin(x)^2$.

5. To remove an expression from the plot region, drag-and-drop the expression plot from the plot region to a Maple input region.
The final method for creating plots is entering plotting commands. The main advantages of using plotting commands are the availability of all Maple plot structures and the greater control over the plot output. Plot options are discussed in *Customizing Plots* (page 215).

**Table 5.8: The plot and plot3d Commands**

- `plot(plotexpression, x=a..b, ...)`
- `plot3d(plotexpression, x=a..b, y=a..b, ...)`
  - `plotexpression` - expression to be plotted
  - `x=a..b` - name and horizontal range
  - `y=a..b` - name and vertical range

**Maple commands from Creating Plots: Interactive Plot Builder**

The following examples show the plotting commands returned by the examples in *Interactive Plot Builder* (page 189).

**Example 1 - Display a plot of a single variable expression**

\[
\text{> plot}\left(\frac{\sin(x)}{x}, x = -10 .. 10\right)
\]
Example 2 - Display a plot of multiple expressions of 1 variable

To display multiple expressions in a plot, include the expressions in a list. To enter $\frac{d}{dx} \sin(x^2)$ and $\int \sin(x^2) \, dx$, use the Expression palette. For more information, see Entering Expressions (page 10).

```maple
> plot([sin(x^2), diff(sin(x^2), x), int(sin(x^2) \, dx)], x=-3 .. 3)
```

Example 3 - Display a plot of a multi-variable expression

```maple
> plot3d(1 + sin(x*y)/(x^2 + y^2), x = -5 .. 5, y = -5 .. 5, view = 0 .. 0.5, lightmodel = light1, shading = zgrayscale, style = patchnogrid, grid = [40, 40])
```

Example 4 - Display a conformal plot

A collection of specialized plotting routines are available in the plots package. For access to a single command in a package, use the long form of the command.

```maple
> plots[conformal](z^3, z = 0 .. 2 I, axes = normal, grid = [20, 20])
```

Example 5 - Display a plot in polar coordinates

```maple
> plot(1 + 4 cos(4 \theta), \theta = 0 .. 0.8 \pi, coords = polar, color = magenta)
```

Example 6 - Interactive Plotting

```maple
> plots[animate](plot, [x+3 sin(x*t), x=0 .. 5], t=0 .. 10)
```

For more information on the plot options described in this section, refer to the ?plot/options and ?plot3d/options help pages.
Display a Parametric Plot

Some graphs cannot be specified explicitly. In other words, you cannot write the dependent variable as a function of the independent variable, \( y=f(x) \). One solution is to make both the x-coordinate and the y-coordinate depend upon a parameter.

\[
> \text{plot}\left( [\cos(3 \, t), \sin(5 \, t), t = 0 .. 2 \pi]\right)
\]

Display a 3-D Plot

Maple can plot an expression of two variables as a surface in three-dimensional space. To customize the plot, include \texttt{plot3d} options in the calling sequence. For a list of plot options, see *The plot and plot3d Options (page 219).*
The plots Package

The plots package contains numerous plot commands for specialized plotting. This package includes: animate, contourplot, densityplot, fieldplot, odeplot, matrixplot, spacecurve, textplot, and tubeplot. For details about this package, refer to the ?plots help page.

> with(plots) :

The pointplot Command

To plot numeric data, use the pointplot command in the plots package with the data organized in a list of lists structure of the form \([[[x1, y1], [x2, y2], \ldots, [xn, yn]]]\). By default, Maple does not connect the points. To draw a line through the points, use the style = line option. For further analysis of data points, use the Curve Fitting Assistant, (Tools>Assistants>CurveFitting) which fits and plots a curve through the points. For more information, refer to the ?CurveFitting[Interactive] help page.
The matrixplot Command

The `matrixplot` command plots the values of a plot object of type `Matrix`. The `matrixplot` command accepts options such as `heights` and `gap` to control the appearance of the plot. For more information on Matrices, see Linear Algebra (page 133).

```maple
> with(LinearAlgebra) :

> A := HilbertMatrix(6)
```
\[
A := \begin{bmatrix}
1 & \frac{1}{2} & \frac{1}{3} & \frac{1}{4} & \frac{1}{5} & \frac{1}{6} \\
\frac{1}{2} & 1 & \frac{1}{3} & \frac{1}{4} & \frac{1}{5} & \frac{1}{6} \\
\frac{1}{3} & \frac{1}{2} & 1 & \frac{1}{4} & \frac{1}{5} & \frac{1}{6} \\
\frac{1}{4} & \frac{1}{3} & \frac{1}{2} & 1 & \frac{1}{4} & \frac{1}{5} \\
\frac{1}{5} & \frac{1}{4} & \frac{1}{3} & \frac{1}{2} & 1 & \frac{1}{4} \\
\frac{1}{6} & \frac{1}{5} & \frac{1}{4} & \frac{1}{3} & \frac{1}{2} & 1
\end{bmatrix}
\]

\[
B := \text{ToeplitzMatrix}([1, 2, 3, 4, 5, 6], \text{symmetric})
\]

\[
B := \begin{bmatrix}
1 & 2 & 3 & 4 & 5 & 6 \\
2 & 1 & 2 & 3 & 4 & 5 \\
3 & 2 & 1 & 2 & 3 & 4 \\
4 & 3 & 2 & 1 & 2 & 3 \\
5 & 4 & 3 & 2 & 1 & 2 \\
6 & 5 & 4 & 3 & 2 & 1
\end{bmatrix}
\]

\[
\text{matrixplot}(A + B, \text{heights} = \text{histogram}, \text{axes} = \text{normal}, \text{gap} = 0.25, \text{style} = \text{patch})
\]
The **contourplot** Command

The **contourplot** command generates a topographical map for an expression or function. To create a smoother, more precise plot, increase the number of points using the **numpoints** option.

```maple
> contourplot(cos(x y), x = -4 ..4, y = -4 ..4, filled = true, numpoints = 750)
```

**Multiple Plots in the Same Plot Region**

**List of Expressions**

To display multiple expressions in the same plot region, enter the expressions in a **list** data structure. To distinguish the surfaces, apply different shading options, styles, or colors to each surface.
The display Command

To display different types of plots in the same plot region, use the display command in the plots package.

This example plots a curve over a hill with the shadow of the curve projected onto the hill.

\[ \text{plot3d}([\cos(5x) + \cos(5y), x^2 + 3y^2 - 4], x=-2..2, y=-1..1, shading=[\text{zgrayscale}, \text{none}], color=[\text{default}, \text{grey}], style=[\text{patchnogrid}, \text{patch}], \text{lightmodel}=\text{light3}, \text{transparency}=0.1) \]

\[ z := 10 \left( x^2 + y^5 + \frac{x}{5} \right) e^{-x^2-y^2} \]

\[ \text{hill} := \text{plot3d}(z, x=-2..2, y=-2.5..2.5, shading=\text{zhue}, style=\text{patchnogrid}, \text{lightmodel}=\text{light3}, \text{orientation}=[-125, 60]) \]

\[ xt := \cos(t) \]

\[ yt := 2 \sin(t) \]

Maple can draw curves in three-dimensional space.
Now that you have seen how easy it is to incorporate a plot into your work, the next section illustrates how to customize plots.

### 5.3 Customizing Plots

Maple provides many plot options to display the most aesthetically pleasing, illustrative results. Plot options include line styles, colors, shadings, axes styles, and titles where applicable. Plot options are applied using the **Interactive Plot Builder**, the context menus, or as options in the command syntax.

#### Interactive Plot Builder Options

The **Interactive Plot Builder** offers most of the plot options available in Maple in an easy-to-use interface.
Table 5.9: Customizing Plots Using Interactive Plot Builder

<table>
<thead>
<tr>
<th>Steps</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Launch the <strong>Interactive Plot Builder</strong> and enter the expression.</td>
<td>Add the expression $2x^5-10x^3+6x-1$. For information on interacting with the <strong>Interactive Plot Builder</strong>, see Example 1 - Display a plot of a single variable expression (page 192)</td>
</tr>
<tr>
<td>Set the x-axis range.</td>
<td>In the <strong>Select Plot Type</strong> window, change the x-axis range to $-2 \ldots 2$.</td>
</tr>
<tr>
<td>Set plot options.</td>
<td>In the <strong>Plot Options</strong> window:</td>
</tr>
<tr>
<td></td>
<td>a. From the <strong>Line</strong> group box, select <strong>dot</strong>.</td>
</tr>
<tr>
<td></td>
<td>b. From the <strong>Color</strong> group box, select <strong>blue</strong>.</td>
</tr>
<tr>
<td></td>
<td>c. From the <strong>Axes</strong> group box, select <strong>frame</strong>.</td>
</tr>
<tr>
<td></td>
<td>d. From the <strong>Title</strong> group box, enter <strong>My Plot</strong> in the text field.</td>
</tr>
<tr>
<td>Plot the expression.</td>
<td>Click <strong>Plot</strong>.</td>
</tr>
</tbody>
</table>

![Graph](image)

**Context Menu Options**

Using the context menu, you can alter a plot by right-clicking (for Macintosh, **Control**-clicking) the plot output. You can also access a large subset of plot...
options using the **Plot** toolbar and **Plot** menu options. These menus display when a plot region is selected. Regardless of the method used to insert a plot into Maple, you can use the context menu to apply different plot options. For a list of options available when plotting in two and three dimensions, see *The plot and plot3d Options (page 219)*.

### 2-D Plot Options

Some plots do not display as you would expect using default option values. A expression with a singularity is one such example.

\[
> \text{plot}\left(\frac{1}{(x-1)^2}, x = -5..5\right)
\]

![Plot](image)

In the previous plot, all interesting details of the plot are lost because there is a singularity at \(x = 1\). The solution is to view a narrower range, for example, from \(y = 0\) to 7.

**Table 5.10: Customizing 2-D Plots Using the Context Menu**

<table>
<thead>
<tr>
<th>Details</th>
<th>Steps</th>
</tr>
</thead>
</table>
| Alter the y-axis range. | 1. Right-click the plot region. Select **Axes**, and then **Range**.  
2. In the **Axes Ranges** dialog, in the y group box, select the bottom radio button and enter 0 and 7 in the text regions provided. |
Place the mouse pointer on the curve and right-click (Control-click, for Macintosh). **Note:** The curve is selected when it becomes highlighted. Select **Color**, and then **Green**.

Select **Style**, and then **Point**.

### 3-D Plot Options

By default, Maple displays the graph as a shaded surface and scales the plot to fit the window. To change these options, use the context menu.

\[
plot3d\left(\frac{xy}{x^2 + y^2}, x = -10 .. 10, y = -5 .. 5\right)
\]

Maple has many preselected light source configurations.

**Table 5.11: Customizing 3-D Plots Using the Context Menu**

<table>
<thead>
<tr>
<th>Steps</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the style.</td>
<td>Right-click the plot region. Select <strong>Style</strong>, and then <strong>Patch</strong> (Without Grid).</td>
</tr>
<tr>
<td>Apply a light scheme.</td>
<td>Select <strong>Lighting</strong>, and then <strong>Light Scheme 1</strong>.</td>
</tr>
<tr>
<td>Change the color.</td>
<td>Select <strong>Color</strong>, and then <strong>Z</strong> (Grayscale).</td>
</tr>
</tbody>
</table>
## The plot and plot3d Options

If you are using commands to insert a plot, you can specify plot options as arguments at the end of the calling sequence. You can specify the options in any order. Applying plot options in the command syntax offers a few more options and greater control than what is available in the Interactive Plot Builder and context menus.

### Table 5.12: Popular Plot Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>axes</td>
<td>Defines the type of axes, one of: boxed, frame, none, or normal</td>
</tr>
<tr>
<td>caption</td>
<td>Defines the caption for the plot</td>
</tr>
<tr>
<td>color</td>
<td>Defines a color for the curves to be plotted</td>
</tr>
<tr>
<td>font</td>
<td>Defines the font for text objects in the plot</td>
</tr>
<tr>
<td>glossiness (3-D)</td>
<td>Controls the amount of light reflected from the surface</td>
</tr>
<tr>
<td>gridlines (2-D)</td>
<td>Defines gridlines in the plot</td>
</tr>
<tr>
<td>lightmodel (3-D)</td>
<td>Controls the light model to illuminate the plot, one of: none, light1, light2, light3, or light4</td>
</tr>
<tr>
<td>linestyle</td>
<td>Defines the dash pattern used to render lines in the plot, one of: dash, dashdot, dot, or solid</td>
</tr>
<tr>
<td>legend (2-D)</td>
<td>Defines a legend for the plot</td>
</tr>
<tr>
<td>numpoints</td>
<td>Controls the minimum total number of points generated</td>
</tr>
<tr>
<td>scaling</td>
<td>Controls the scaling of the graph, one of: constrained or unconstrained</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>shading (3-D)</td>
<td>Defines how the surface is colored, one of: xyz, xy, z, grayscale, zhue, or none</td>
</tr>
<tr>
<td>style</td>
<td>Defines how the surface is to be drawn, one of: line, point, polygon, or polygonoutline for 2-D plots; contour, point, surface, surfacecontour, surfacewireframe, wireframe, or wireframeopaque for 3-D plots</td>
</tr>
<tr>
<td>symbol</td>
<td>Defines the symbol for points in the plot, one of: asterisk, box, circle, cross, diagonalcross, diamond, point, solidbox, solidecircle, or soliddiamond for 2-D plots; asterisk, box, circle, cross, diagonalcross, diamond, point, solidsphere, or sphere for 3-D plots</td>
</tr>
<tr>
<td>title</td>
<td>Defines a title for the plot</td>
</tr>
<tr>
<td>thickness</td>
<td>Defines the thickness of lines in the plot</td>
</tr>
<tr>
<td>transparency (3-D)</td>
<td>Controls the transparency of the plot surface</td>
</tr>
<tr>
<td>view</td>
<td>Defines the minimum and maximum coordinate values of the curve displayed on the screen</td>
</tr>
</tbody>
</table>

For a complete list of plot options, refer to the `?plot/options` and `?plot3d/options` help pages.
To create a smoother or more precise plot, calculate more points using the `numpoints` option.

```plaintext
> plot(Si(x), x = -20 .. 20, title = "Plot of the Sine Integral", titlefont = [HELVETICA, 12], color = blue, style = point)
```

To create a smoother or more precise plot, calculate more points using the `numpoints` option.

```plaintext
> plot3d(x * y^2 / (x^2 + y^4), x = -10 .. 10, y = -10 .. 10, axes = boxed, numpoints = 1500, lightmodel = light3, shading = zgrayscale, orientation = [160, 20], style = patchnogrid)
```
5.4 Analyzing Plots

Point Probe, Rotate, Pan, and Zoom Tools

To gain further insight into a plot, Maple offers various tools to analyze plot regions. These tools are available in the Plot menu menu, Context Bar and in the context menu under Transform when the plot region is selected.

Table 5.13: Plot Analysis Options

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point probe (2-D)</td>
<td>![Point probe icon]</td>
<td>Display the coordinates corresponding to the cursor position on a two-dimensional plot in the context bar (upper left-hand corner)</td>
</tr>
<tr>
<td>Rotate (3-D)</td>
<td>![Rotate icon]</td>
<td>Rotate a three-dimensional plot to see it from a different point of view</td>
</tr>
<tr>
<td>Pan</td>
<td>![Pan icon]</td>
<td>Pan the plot by changing the view ranges for 2-D plots. Smartplots will resample to reflect the new view. Change the position of the plot in the plot region for 3-D plots</td>
</tr>
<tr>
<td>Zoom</td>
<td>![Zoom icon]</td>
<td>Zoom into or out of the plot by changing the view ranges for 2-D plots. Smartplots will resample to reflect the new view. Make the plot larger or smaller in the plot window for 3-D plots</td>
</tr>
</tbody>
</table>

5.5 Creating Animations

Plotting is an excellent way to represent information. Animations allow you to emphasize certain graphical behavior, such as the deformation of a bouncing ball, clearer than in a static plot. A Maple animation is a number of plot frames displayed in sequence, similar to the action of movie frames. To create an animation, use the Interactive Plot Builder or commands.
## Interactive Plot Builder

### Table 5.14: Creating Animations Using the Interactive Plot Builder

<table>
<thead>
<tr>
<th>Steps</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Launch the Interactive Plot Builder and enter the expression.</td>
<td>Add the expression ( \sin(i\sqrt{x^2+y^2}/10) ). For information on interacting with the Interactive Plot Builder, see Example 1 - Display a plot of a single variable expression (page 192).</td>
</tr>
<tr>
<td>Set axes and animation parameter range.</td>
<td>In the Select Plot Type window:</td>
</tr>
<tr>
<td></td>
<td>a. From the Select Plot Type drop-down menu, select <strong>Animation</strong>.</td>
</tr>
<tr>
<td></td>
<td>b. Change the <strong>x Axis</strong> range to -6 .. 6.</td>
</tr>
<tr>
<td></td>
<td>c. Change the <strong>y Axis</strong> range to -6 .. 6.</td>
</tr>
<tr>
<td></td>
<td>d. Change the <strong>Animation Parameter</strong> (i) range to 1 .. 30.</td>
</tr>
<tr>
<td>Set plot options.</td>
<td>In the Plot Options window:</td>
</tr>
<tr>
<td></td>
<td>a. From the <strong>Style</strong> group box, select <strong>Surface</strong>.</td>
</tr>
<tr>
<td></td>
<td>b. From the <strong>Color</strong> group box, in the Light Model drop-down menu select <strong>red-turquoise</strong>.</td>
</tr>
<tr>
<td></td>
<td>b. From the <strong>Color</strong> group box, in the Shading drop-down menu select <strong>z (grayscale)</strong>.</td>
</tr>
<tr>
<td></td>
<td>c. In the View group box, select the <strong>Constrained Scaling</strong> check box.</td>
</tr>
</tbody>
</table>
Details

Steps | Details
--- | ---
Plot the expression. | Click Plot.

> plots[interactive]();

For information on playing the animation, see Playing Animations (page 226). To see the Maple syntax used to generate this plot, see Maple Syntax for Creating Animations: Interactive Plot Builder Example (page 225).

The plots[animate] Command

You can also use the animate command, in the plots package, to generate animations.
Table 5.15: The animate Command

| animate(plotcommand, plotarguments, t=a..b, ...) |
| animate(plotcommand, plotarguments, t=L, ...) |
- `plotcommand` - Maple procedure that generates a 2-D or 3-D plot
- `plotarguments` - arguments to the plot command
- `t=a..b` - name and range of the animation parameter
- `t=L` - name and list of real or complex constants

To access the command, use the short form name after invoking the `with(plots)` command.

> `with(plots):`

**Maple Syntax for Creating Animations: Interactive Plot Builder Example**

The following example shows the plotting command returned by the example in *Interactive Plot Builder* (page 223).

> `animate(plot3d, \left[ \sin\left( \frac{i \sqrt{x^2 + y^2}}{10} \right), x = -6..6, y = -6..6, style = patchnogrid, lightmodel = light3, shading = zgrayscale, scaling = constrained \right], i = 1..30)`

**Animate a 2-D plot**

> `animate(plot, [5 \cos(2 \theta), \theta = 0..t, coords = polar], t = 0..2 \pi, frames = 50)`
For more information on the `animate` command, refer to the `plots[animate]` help page.

5.6 Playing Animations

Animation Context Bar

To run the animation, click the plot to display the `Animate` context bar.

Table 5.16: Animation Options

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Previous Frame</td>
<td>![Previous Frame Icon]</td>
<td>View the previous frame in the animation.</td>
</tr>
<tr>
<td>Stop</td>
<td>![Stop Icon]</td>
<td>Stop the animation.</td>
</tr>
<tr>
<td>Play</td>
<td>![Play Icon]</td>
<td>Play the selected animation.</td>
</tr>
<tr>
<td>Next Frame</td>
<td>![Next Frame Icon]</td>
<td>View the next frame in the animation.</td>
</tr>
<tr>
<td>Name</td>
<td>Icon</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Current Frame</td>
<td><img src="image1.png" alt="Current Frame Icon" /></td>
<td>Slider control for viewing individual frames of an animated plot. The frame speed in frames per second (FPS) is displayed when increasing or decreasing the animation speed of a plot.</td>
</tr>
</tbody>
</table>
| Forward Oscillate     | ![Forward Oscillate Icon](image2.png)     | • Forward - Play the animation forward.  
• Oscillate - Play the animation forward and backward.  
• Backward - Play the animation backward. |
| Backward              | ![Backward Icon](image3.png)              |                                                                                                                                            |
| Single Continuous     | ![Single Continuous Icon](image4.png)     | • Single - Run the animation in single cycle mode. The animation is displayed only once.  
• Continuous - Run the animation in continuous mode. The animation repeats until you stop it. |
| Frames per second     | ![Frames per second Icon](image5.png)     | Set the animation to play at a faster or slower speed.                                                                                     |

You can also run the animation using the context menu or the **Plot** menu.
5.7 Customizing Animations

The display options that are available for static plots are also available for Maple animations.

Interactive Plot Builder Animation Options

Using the Interactive Plot Builder, you can apply various plot options within the Plot Options window. See the Interactive Plot Builder (page 223) example.

Context Menu Options

As with static plots, you can apply plot options to the animation by right-clicking (for Macintosh, Control-clicking) the animation output.

\[
\text{with(plots):}
\]

\[
\text{animate(plot, [sin(x) \cdot e^{\frac{-x}{5}}, x=t-2 \pi..t], t=0..20, frames=50,}
\]

\[
\text{view=[0..20, -1..1]}
\]
Table 5.17: Customizing Animations Using the Context Menu

<table>
<thead>
<tr>
<th>Step</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the line style</td>
<td>Right-click the plot region. Select <strong>Style</strong>, and then <strong>Point</strong>.</td>
</tr>
<tr>
<td>Remove the axes</td>
<td>Select <strong>Axes</strong>, and then <strong>None</strong>.</td>
</tr>
</tbody>
</table>

The **animate** Command Options

The **animate** command offers a few options that are not available for static plots. Refer to the `?animate` help page for information on these additional options. By default, a two-dimensional animation consists of sixteen plots (frames) and a three-dimensional animation consists of eight plots (frames). To create a smoother animation, increase the number of frames using the **frames** option.

**Note:** Computing more frames increases time and memory requirements.

\[
\text{\texttt{animate(pointplot, [ [ t, \sin(t) \ e^{-t/5}], symbol = circle, symbolsize = 20], t=0 .. 0.20, frames = 60, background = sinewave})}
\]

\[
\text{\texttt{sinewave := plot(\sin(x) \ e^{-x/5}, x = 0 .. 0.20)}}
\]
5.8 Exporting

You can export a generated graph or animation to an image in various file formats, including DXF, EPS, GIF, JPEG/JPG, POV, Windows BMP, and WMF. Exporting an animation to GIF produces an animated image file. The exported images can be included in presentations, Web pages, Microsoft Word, or other software.

To export an image:

1. Right-click the plot region (for Macintosh, Control-click).
2. Select Export and the file format.

Alternatively:

1. Click the plot.
2. From the Plot menu, select Export, and then the file format.

Maple has various plot drivers. By setting the plotdevice, a file can be automatically created without returning the image to the document. For more information, refer to the ?plotdevice help page.

5.9 Code for Color Plates

Generating impressive graphics in Maple can require only a few lines of code, as shown by the examples in this chapter. However, other graphics require many lines of code. Code for the color plates is available at the Maple Application Center.

From the Help menu, select Manuals, Dictionary, and more, On the Web, and then Application Center.

To access the color plate code:

1. Go to the Maple Application Center.
2. Search for Color Plates.
6 Creating Mathematical Documents

Maple allows you to create powerful documents as business and education tools, technical reports, presentations, assignments, and handouts.

You can:

• Place instructions and equations side by side
• Format text for reports or course material
• Insert hyperlinks to other Maple files, Web sites, or email addresses
• Insert images, tables, and symbols
• Generate two- and three-dimensional plots and animations
• Sketch in the document
• Copy, cut, and paste information
• Bookmark specific areas
• Easily update, revise, and distribute your documents

This User Manual was written using Maple.
## 6.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Document Formatting - Add various formatting elements | • Quick Character Formatting  
• Quick Paragraph Formatting  
• Copy and Paste  
• Sections  
• Displaying Hidden Formatting Attributes  
• Indentation and the Tab Key  
• Character and Paragraph Styles  
• Document Blocks  
• Typesetting  
• Using Tables for Layout  
• Formatting Lists: Bullets, Numbers, Indent  
• Bookmarks  
• Inserting Images  
• Show or Hide Document Content |
| Embedded Components - Insert buttons, sliders, and more in your document | • Adding Graphical Interface Components  
• Editing Component Properties  
• Removing Graphical Interface Components  
• Example Component Properties  
• Printing and Exporting with Embedded Components |
| Creating Graded Assignments - Create documents for automated testing and assessment | • Creating a Question  
• Viewing Questions in Maple  
• Saving Test Content |
<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Auto-execute - Execute selected regions of your document | • Setting the Auto-Execute Feature  
• Removing the Auto-Execute Setting  
• Repeating Auto-Execution  
• Security Levels |
| Canvas- Sketch an idea in the document by inserting a canvas | • Insert a Canvas  
• Drawing  
• Canvas Style  
• Erase or Clear Content  
• Selection Tool |
| Spell Checking - Verify text with the Maple spell checking utility | • How to Use the Spellcheck Utility  
• Selecting a Suggestion  
• Spellcheck Usage and the Document  
• User Dictionary |
| Hyperlinks - Add hyperlinks to various sources | • Inserting a Hyperlink in the Document  
• Linking to an Email Address, Dictionary Topic, Help Page, Maplet Application, Web Page, or Document |
| Worksheet Compatibility - Classic Worksheet interface does not support all Standard Worksheet interface features | • Compatibility Issues |

### 6.2 Document Formatting

#### Quick Character Formatting

The Format>Character menu provides access to the following quick formatting features: **Bold**, **Italic**, **Underline**, **Superscript**, **Subscript**, font **Color**, and **Highlight Color**.
To modify text:

1. In the document, select the text to modify.

2. From the Format menu, select Character, and then the appropriate feature. Alternatively, use the context bar icons.

- Font Color Context Bar Icon
- Highlight Color Context Icon

For font and highlight colors, you can select from Swatches, HSB, or RGB values. See Figure 6.1.

![Select Character Color Dialog](image)

Figure 6.1: Select Color Dialog
Attributes Submenu: Setting Fonts, Character Size, and Attributes

You can change various character attributes such as font, character size, style, and color in one dialog.

To modify text:

1. In the document, select text to modify.
2. From the **Format** menu, select **Character**, and then **Attributes**. The **Character Style** dialog opens. See Figure 6.2.

![Character Style Dialog](image)

Figure 6.2: Character Style Dialog

Quick Paragraph Formatting

The **Format**>**Paragraph** menu provides access to the following quick alignment features: **Align Left**, **Center**, **Align Right**, and **Justify**.

To modify a paragraph:

1. In the document, select the paragraph to modify.
2. From the **Format** menu, select **Paragraph**, and then the appropriate feature.
Attributes Submenu: Spacing, Indent, Alignment, Bullets, Line Break, and Page Break

You can change various paragraph attributes in one dialog.

- From the **Format** menu, select **Paragraph**, and then **Attributes**. The **Paragraph Style** dialog opens. See Figure 6.3.
- When changing spacing, you must indicate units (inches, centimeters, or points) in the **Units** drop-down list.

![Figure 6.3: Paragraph Style Dialog](image)

**Copy and Paste**

You can cut, copy, and paste content in Maple documents.

To copy an expression, or part of an expression, to another location on the document:

1. Select the expression, or part of the expression, to copy.
2. From the **Edit** menu, select **Copy**.

3. Place the cursor at the insertion point.

4. From the **Edit** menu, select **Paste**.

   If you paste into an input region, Maple interprets all the pasted content as input. If you paste into a text region, Maple interprets all the pasted content as text. Note, however, that 2-D Math retains its format in both input and text regions.

   When you copy and paste to another application, in general, Maple retains the original structure.

**Sections**

You can organize your document into sections.

```
\begin{itemize}
  \item \textbf{First Section}
    \begin{itemize}
    \item The introductory sentence.
    \item $\int \cos(x) \, dx$
    \end{itemize}
  \end{itemize}

\begin{itemize}
  \item \textbf{Subsection}
    \begin{itemize}
    \item $\int \sin(x) \, dx$
    \end{itemize}
  \end{itemize}
```

**Using the Insert Menu to Add Sections**

1. Place the cursor in the paragraph or execution group above the location at which to insert a new section.

   - If the cursor is inside a section, Maple inserts the new section after the current section.
   - If the cursor is in an execution group, Maple inserts the new section after the execution group.

2. From the **Insert** menu, select **Section**. An arrow marks the start of the section.
3. Enter the section heading.

4. Press the **Enter** key.

5. Enter the body of the section.

**Using the Indent and Outdent Toolbar Icons**

You can shift sections to create or remove subsections.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Indent Icon" /></td>
<td>Enclose the selection in a subsection</td>
</tr>
<tr>
<td><img src="image" alt="Outdent Icon" /></td>
<td>Outdent the selection</td>
</tr>
</tbody>
</table>

**Display Hidden Formatting Attributes**

You can display icons that indicate the presence of hidden formatting attributes in the document, such as document block boundaries, execution groups marked for autoexecute, and bookmarks.

**To activate the marker feature:**

- From the **View** menu, select **Markers**. A vertical bar is displayed along the left pane of the document. Icons for hidden elements are displayed in the vertical bar next to the associated content in the document.

**Indentation and the Tab Key**

The Tab icon allows you to set the **Tab** key to move between placeholders or to indent.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Tab Icon" /></td>
<td><strong>Tab icon off.</strong> Allows you to move between placeholders using the <strong>Tab</strong> key. As an illustration, click the exponent button in the <strong>Expression</strong> palette. The expression is inserted with the first placeholder highlighted. To move to the next placeholder, use the <strong>Tab</strong> key.</td>
</tr>
</tbody>
</table>
The Tab icon is disabled when using 2-D Math (Math mode), and as such, the Tab key allows you to move between placeholders.

Tab icon on. Allows you to indent in the document using the Tab key.

Character and Paragraph Styles

Maple has predefined styles for characters and paragraphs. A style is a set of formatting characteristics that you can apply to text in your document to change the appearance of that text. When you apply a style, you apply a group of formats in one simple action.

- A **paragraph style** controls all aspects of a paragraph's appearance, such as text alignment, line spacing, and indentation. In Maple, each paragraph style includes a character style.

- A **character style** controls text font, size, and color, and attributes, such as bold and italic. To override the character style within a paragraph style, you must apply a character style or character formatting.

![Figure 6.4: Style Management Dialog](image)

**Applying Character Styles**

By using the drop-down list in the document context bar, you can apply:

- Existing Maple character styles.
To apply a character style to text in your document:

1. Select the text to modify.

2. In the styles drop-down list in the context bar of your document, select an appropriate character style. All character styles are preceded by the letter C. The selected text now reflects the attributes of the character style you have chosen.

3. (Optional) If necessary, you can remove this style. From the Edit menu, select Undo.

Creating Character Styles

You can create custom character styles to apply to text. New styles are listed in the styles drop-down list in the context bar of your document.

1. From the Format menu, select Styles. The Style Management dialog opens. See Figure 6.4.

2. Click Create Character Style. The Character Style dialog opens. See Figure 6.5.

3. In the Style group box, enter a style name in the blank text field.

4. Select the properties for the new character style, such as Font, Size, Attributes, and Color. In the Attributes group box, the Superscript and Subscript check boxes are mutually exclusive. When you select one of the
two check boxes, the other is disabled. You must clear one before selecting the other.

**Note:** A preview of the style is displayed in the *Example* group box at the bottom of the *Character Style* dialog.

5. To create the style, click **OK** or to abandon creation, click **Cancel**.

---

**Figure 6.5: Character Style Dialog**

**Modifying Character Styles**

**To modify character styles:**

1. From the **Format** menu, select **Styles**. The **Style Management** dialog opens. See Figure 6.4.

2. From the style list, select the style to modify.

3. Click **Modify**. The **Character Style** dialog opens with the current attributes displayed. See Figure 6.5.
4. Select the properties to modify, such as **Font**, **Size**, **Attributes**, and **Color**. In the **Attributes** group box, the **Superscript** and **Subscript** check boxes are mutually exclusive. When you select one of the two check boxes, the other is disabled. You must clear one before selecting the other.

A preview of the style is displayed in the **Example** group box at the bottom of the **Character Style** dialog.

5. To accept changes, click **OK** or to cancel changes, click **Cancel**.

**Applying Paragraph Styles**

By using the drop-down list in the document context bar, you can apply:

- Existing Maple paragraph styles.
- New styles that you have created through the **Style Management** (Figure 6.4) and **Paragraph Style** (Figure 6.6) dialogs.

**To apply a Maple paragraph style to text in your document:**

1. Select the text to modify.

2. In the styles drop-down list in the context bar of your document, select an appropriate paragraph style. All Maple paragraph styles are preceded by the letter **P**. The selected text now reflects the attributes of the paragraph style you have chosen.

3. (Optional) If necessary, you can remove this style. From the **Edit** menu, select **Undo**.
Creating Paragraph Styles

You can create custom paragraph styles to apply to text. New styles are listed in the styles drop-down list in the context bar of your document.

1. From the Format menu, select Styles. The Style Management dialog opens. See Figure 6.4.

2. Click Create Paragraph Style. The Paragraph Style dialog opens. See Figure 6.6.

3. In the Style group box, enter the new paragraph style name in the blank text field.

4. In the Units drop-down list, select the units used to determine spacing and indentation. Select from inches (in), centimeters (cm), or points (pt).

5. Select the properties to use for this paragraph style, such as Spacing, Indent, Justification, Bullet Style, Linebreak, and Page Break Before.

6. To add a font style, click Font. The Character Style dialog opens. For detailed instructions, see Creating Character Styles (page 240).

7. To create the style, click OK, or to abandon creation, click Cancel.
Modifying Paragraph Styles

To modify a paragraph style:

1. From the Format menu, select Styles. The Style Management dialog opens. See Figure 6.4.

2. Select a paragraph style to modify, and click Modify. The Paragraph Style dialog opens with the current attributes displayed.

3. Select the properties you want to modify, such as Spacing, Indent, Justification, and Bullet, Linebreak, and Units.

4. To modify the existing font style, click Font.

5. To accept changes, click OK, or to cancel changes, click Cancel.
Style Set Management: Saving Styles for Future Use

You can use the style set of a particular document as the default style for all documents.

![Style Set Management Dialog](image)

**Figure 6.7: Style Set Management Dialog**

Creating and Applying Style Sets

- Task 1 - Create Styles
- Task 2 - Create a New Style Set
- Task 3 - Apply a (New) Style Set

**TASK 1 - Create Styles:**

- Create paragraph or character styles for the current document.

**TASK 2 - Create a New Style Set:**

1. From the **Format** menu, select **Manage Style Sets**. The **Style Set Management** dialog opens. See Figure 6.7.

2. In the **Style Set Operations** group box, click **New Style Set**. The **Choose Styles** dialog opens. See Figure 6.8.
3. Select all the styles that are part of your document style set. For example, if you modified the Author paragraph style to justify left versus the default style of centered, ensure that you have selected the Author check box in the Choose Styles dialog.

4. Click OK. The Choose Filename dialog opens.

5. Save your style set. The style is now available for future use in other documents.

**TASK 3 - Apply a (New) Style Set:**

1. From the Format menu, select Manage Style Sets. The Style Set Management dialog opens. See Figure 6.7.

2. In the Style Set Operations group box, click Apply Style Set. The Choose Filename dialog opens.

3. Select the style file and click Open. The Choose Styles dialog opens. At this point, you can overwrite all the styles in your current document with the new style set or apply only a few.

4. Click OK. The style set is applied to your document.

**Reverting to a Style Set**

At any point, you can revert your document style set to the Default Maple Style Set or to a User-defined Style Set.
To revert to a style set:

1. From the **Format** menu, select **Manage Style Sets**. The **Style Set Management** dialog opens.

2. In the **Current Style Set** group box, select the **Default Maple Style Set** or **User-defined Style Set**. For user-defined style sets, navigate (click **Browse**) to the file (**Choose Filename** dialog) and open the file (click **Open**).

3. In the **Style Set Operations** group box, click **Revert to StyleSet**.

4. In the **Choose Styles** dialog, select all the styles to revert, that is, overwrite with either the **Default Maple Style Set** or the **User-defined Style Set**.

5. Click **OK**.

**Document Blocks**

With document blocks, you can create documents that present text and math in formats similar to those found in business and education documents.

In a document block an input prompt or execution group is not displayed.

By hiding Maple input such that only text and results are visible, you create a document with better presentation flow. Before using document blocks, it is recommended that you display **Markers**. A vertical bar is displayed along the left pane of the document. Icons representing document blocks are displayed in this vertical bar next to associated content.

To activate Markers:

- From the **View** menu, select **Markers**.
Applying Document Blocks: General Process

Important: The following instructions are for Worksheet mode.

To apply a document block to selected content:

1. Enter input at the Maple command prompt, creating input that can be referenced elsewhere in the document. See the ?EquationLabels help page.

2. Execute the area, creating output that can be referenced elsewhere in the document.

3. Intersperse the area with content that is to remain visible, adding references to the input and output in the appropriate locations.

\[
\begin{align*}
\text{The answer to} \\
&\int \sin(x) \, dx \\
\text{is} \\
&\text{value}\left(1\right) \\
\end{align*}
\]

4. Select the entire area (text and math content) to format.

5. From the Format menu, select Create Document Block.

6. Select the entire area. From the View menu, select Inline Document Output.
The block displays text and output only. You can select areas to display input only.

7. Select the output region you want to display as input. From the View menu, select Toggle Input/Output Display. The selected region displays input.

Working in Document Mode

You can work directly in Document mode, entering text and expressions, and then evaluating expressions.

To start a document in Document mode:

1. From the File menu, select New, and then Document Mode. A document opens with the Document mode markers indicated in the left margin. Note that margin markers are visible if you select View>Markers.

2. Enter text and an expression to evaluate.

3. Select the expression and right-click (Control-click, for Macintosh) to display the context menu.

4. Click the Evaluate and Display Inline menu item. The expression is evaluated.

**Note:** Each time you press Enter, a new document block appears. Documents consist of a series of document blocks.

In the following figures, note how the expression is entered as part of the text and then evaluated with the context menu option Evaluate and Display Inline.
Figure 6.9: Working in Document Mode

View Document Code

To view the contents, that is, all code and expanded execution groups within a document block, you must expand the document block.

1. Place the cursor in the document block region.
2. From the View menu, select Expand Document Block.
3. To hide code again, select View>Collapse Document Block.

Expand an Execution Group within a Document Block

An execution group is a grouping of Maple input with its corresponding Maple output. It is distinguished by a large square bracket at the left called a group boundary.
As document blocks can contain many execution groups, you can select to expand an execution group within a document block.

1. Place the cursor in the document block region.

2. From the View menu, select Expand Execution Group.

3. To hide the group, select View>Collapse Execution Group.

Switch between Input and Output

1. Place the cursor in the document block region.

2. From the View menu, select Toggle Input-Output Display.

Input is displayed in one instance, or only output is displayed.

Inline Document

Document blocks can display content inline, that is, text, input, and output in one line as presented in business and education documents.

To display content inline:

1. Place the cursor in the document block.

2. From the View menu, select Inline Document Output.
Typesetting

You can control typesetting and 2-D Math equation parsing options in the Standard Worksheet interface. Extended typesetting uses a customizable set of rules for displaying expressions.

The rule-based typesetting functionality is available when Typesetting level is set to Extended (Tools>Options>Display tab). This parsing functionality applies to 2-D Math editing (Math mode) only.

To specify rules, use the Typesetting Rule Assistant.

• From the View menu, select Typesetting Rules. The Typesetting Rule Assistant dialog opens.

For more information, see the ?Typesetting, ?TypesettingRuleAssist, and ?OptionsDialog help pages.

Using Tables for Layout

Tables allow you to organize content in a document.

Creating a Table

To create a table:

1. From the Insert menu, select Table.

2. Specify the number of rows and columns in the table creation dialog.

3. Click OK.

The default properties for the table include visible borders and auto-adjustment to 100% of the document width. These options, as well as the table
dimensions, can be modified after table creation. The following is an example table using the default settings.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Cell Contents**

Any content that can be placed into a document can also be placed into a table cell, including other sections and tables. Table cells can contain a mix of:

- Input commands
- 2-D Math
- Embedded components - buttons, sliders, check boxes, and more
- Plots
- Images

**Navigating Table Cells**

Use the **Tab** key to move to the next cell.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Tab icon off" /></td>
<td>Tab icon <strong>off</strong>. Allows you to move between cells using the <strong>Tab</strong> key.</td>
</tr>
<tr>
<td><img src="image" alt="Tab icon on" /></td>
<td>Tab icon <strong>on</strong>. Allows you to indent in the table using the <strong>Tab</strong> key.</td>
</tr>
</tbody>
</table>

**Modifying the Structural Layout of a Table**

The number of rows and columns in a table are modified using the **Insert** and **Delete** submenus in the **Table** menu or by using the **Cut** and **Paste** tools.

**Inserting Rows and Columns**

Row and column insertion is relative to the table cell that currently contains the cursor. If the document has an active selection, insertion is relative to the selection boundaries.
• Column insertion can be to the left or right of the document position marker or selection.

• Row insertion can be above or below the marker or selection.

Deleting Rows and Columns

With deleting operations using the Delete key, the Delete Table Contents dialog opens allowing you to specify the desired behavior. For example, you can delete the selected rows, or delete the contents of the selected cells.

Pasting

Pasting a table subselection into a table may result in the creation of additional rows or columns, overwriting existing cell content, or the insertion of a subtable within the active table cell.

Merging

You can merge cells across row or column borders. See Figure 6.10. The resultant cell must be rectangular. The contents of the individual cells in the merge operation are concatenated in execution order. See Figure 6.11.

![Figure 6.10: Two cells](image1)

![Figure 6.11: Merged Cells](image2)

Modifying the Physical Dimensions of a Table

The overall width of the table can be controlled in several ways.

The most direct way is to press the left mouse button (press mouse button, for Macintosh) while hovering over the left or right table boundary and dragging the mouse left or right. Upon release of the mouse button, the table boundary is updated. This approach can also be used to resize the relative width of table columns.
Alternatively, the size of the table can be controlled from the Table Properties dialog. Select Tables>Properties. Two sizing modes are supported.

1. **Fixed percentage of page width.** Using this option, the table width adjusts whenever the width of the document changes. This option is useful for ensuring that the entire content of the table fits in the screen or printed page.

2. **Scale with zoom factor.** This option is used to preserve the size and layout of the table regardless of the size of the document window or the zoom factor. If the table exceeds the width of the document window, the horizontal scroll bar can be used to view the rightmost columns. **Note:** Using this option, tables may be incomplete when printed.

**Modifying the Appearance of a Table**

**Table Borders**

The style of exterior and interior borders is set using the Table Properties dialog. Select Table>Properties.

- You can set all, none, or only some of the borders to be visible in a table.
- You can control the visibility of interior borders by using the Group submenu of the Table menu.
- Grouping rows or columns suppresses interior borders within the table selection.
- Grouping rows and columns requires that the interior border style is set by row and column group.
- Hidden borders are visible when the mouse hovers over a table. Note that you can hide the visibility of lines on mouse pointer roll over by using the View>Show/Hide Contents dialog, and clearing the Hidden Table Borders check box.

**Alignment Options**

The table alignment tools control the horizontal alignment of columns and vertical alignment of rows.
For column alignment, the current selection is expanded to encompass all rows in the selected columns. The alignment choice applies to all cells within the expanded selection. If the document does not contain a selection, the cursor position is used to identify the column.

Similarly, the selection is expanded to include all columns in the selected rows for vertical alignment options. The following table illustrates the vertical alignment options. The baseline option is useful for aligning equations across multiple cells within a row of a table.

<table>
<thead>
<tr>
<th></th>
<th>Top</th>
<th>Center</th>
<th>Bottom</th>
<th>Baseline</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>$\frac{1}{x}$</td>
<td>$\frac{1}{y}$</td>
<td>$\frac{1}{x}$</td>
<td>$\frac{1}{y}$</td>
</tr>
<tr>
<td></td>
<td>$\frac{1}{y}$</td>
<td>$\frac{1}{x}$</td>
<td>$\frac{1}{x}$</td>
<td>$\frac{1}{y}$</td>
</tr>
</tbody>
</table>

**Controlling the Visibility of Cell Content**

The **Table Properties** dialog includes two options to control the visibility of cell content. These options allow control over the visibility of Maple input and execution group boundaries. Thus, Maple input can be hidden in a table even if input is set to visible for the document in the **View>Show/Hide Contents** dialog.
Printing Options

The **Table Properties** dialog contains options to control the placement of page breaks when printing. You can fit a table on a single page, allow page breaks between rows, or allow page breaks within a row.

Execution Order Dependency

The order in which cells are executed is set in the **Table Properties** dialog. The following tables illustrate the effect of execution order.

<table>
<thead>
<tr>
<th>Row-wise execution order</th>
</tr>
</thead>
<tbody>
<tr>
<td>( &gt; x := 1; )</td>
</tr>
<tr>
<td>( x := 1 )</td>
</tr>
<tr>
<td>( &gt; )</td>
</tr>
<tr>
<td>( &gt; x := x + 1; )</td>
</tr>
<tr>
<td>( x := 3 )</td>
</tr>
<tr>
<td>( &gt; )</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Column-wise execution order</th>
</tr>
</thead>
<tbody>
<tr>
<td>( &gt; x := 1; )</td>
</tr>
<tr>
<td>( x := 1 )</td>
</tr>
<tr>
<td>( &gt; )</td>
</tr>
<tr>
<td>( &gt; x := x + 1; )</td>
</tr>
<tr>
<td>( x := 2 )</td>
</tr>
<tr>
<td>( &gt; )</td>
</tr>
</tbody>
</table>
Tables and the Classic Worksheet

Tables are flattened on export to the Classic Worksheet interface. For example, the following table in the Standard Worksheet appears as one column in the Classic Worksheet interface.

<table>
<thead>
<tr>
<th>Table in Standard Worksheet</th>
<th>Table in Classic Worksheet</th>
</tr>
</thead>
<tbody>
<tr>
<td>aaa ddd</td>
<td>aaa ddd</td>
</tr>
<tr>
<td>bbb eee</td>
<td>bbb eee</td>
</tr>
<tr>
<td>ccc fff</td>
<td>ccc fff</td>
</tr>
</tbody>
</table>

Examples

Table of Values

This example illustrates how to set the visibility options for cell contents to display a table of values.

> y := t -> 1/2*t^2:

<table>
<thead>
<tr>
<th>t [s]</th>
<th>0</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
</tr>
</thead>
<tbody>
<tr>
<td>y(t) [m]</td>
<td>&gt; y(0);</td>
<td>&gt; y(1);</td>
<td>&gt; y(2);</td>
<td>&gt; y(3);</td>
<td>&gt; y(4);</td>
<td>&gt; y(5);</td>
<td>&gt; y(6);</td>
</tr>
<tr>
<td></td>
<td>0</td>
<td>(\frac{1}{2})</td>
<td>2</td>
<td>(\frac{9}{2})</td>
<td>8</td>
<td>(\frac{25}{2})</td>
<td>18</td>
</tr>
</tbody>
</table>

Table settings:

In the Properties dialog (Table>Properties menu):

1. Set Table Size Mode to Scale with zoom factor.

2. Hide Maple input and execution group boundaries: Clear the Show input and Show execution group boundaries check boxes.
### Formatting Table Headers

The following table uses cell merging for formatting row and column headers, and row and column grouping to control the visibility of cell boundaries.

By default, invisible cell boundaries are visible on mouse pointer roll over. You can hide the visibility of lines on mouse pointer roll over by using the `View>Show/Hide Contents` dialog, and clearing the `Hidden Table Borders` check box.

<table>
<thead>
<tr>
<th>Parameter 1</th>
<th>Parameter 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Low</td>
<td>13</td>
</tr>
<tr>
<td>High</td>
<td>18</td>
</tr>
</tbody>
</table>

**Table settings:**

1. Insert a table with 4 rows and 4 columns.

Using the **Table** menu:

2. **Merge** the following sets of (Row,Column) cells: (R1,C1) to (R2,C2), (R1,C3) to (R1,C4), and (R3,C1) to (R4,C1).

3. **Group** columns 1 and 2, and columns 3 and 4.

4. **Group** rows 1 and 2, and rows 3 and 4.

In the **Properties** dialog (**Table>Properties** menu):

5. Set **Exterior Borders** to **None**.

<table>
<thead>
<tr>
<th>t [s]</th>
<th>0</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
</tr>
</thead>
<tbody>
<tr>
<td>y(t) [m]</td>
<td>0</td>
<td>(\frac{1}{2})</td>
<td>2</td>
<td>(\frac{9}{2})</td>
<td>8</td>
<td>(\frac{25}{2})</td>
<td>18</td>
</tr>
</tbody>
</table>
6. (Optional) Change **Table Size Mode** size option to **Scale with zoom factor**.

Using the **Table** menu:

7. Set **Alignment** of columns 3 and 4 to **Center**.

### 2-D Math and Plots

The following example illustrates the use of tables to display 2-D Math and plots side by side.

Approximating \( \exp(-x) \) as a rational polynomial using a 3\(^{rd}\) order Padé approximation.

\[
e^{-x} \approx \frac{1 - \frac{1}{2} x + \frac{1}{10} x^2 - \frac{1}{120} x^3}{1 + \frac{1}{2} x + \frac{1}{10} x^2 + \frac{1}{120} x^3}
\]

![Plot of \( e^{-x} \) and its rational approximation](image)

**Table Settings:**

In the **Properties** dialog (**Table>Properties** menu):

1. Set **Exterior** and **Interior Borders** to **None**.

2. Hide Maple input and execution group boundaries: Clear the **Show input** and **Show execution group boundaries** check boxes.

Using the **Table** menu:
3. Change row **Alignment** to **Center**.

### Table of Mathematical Expressions

This example illustrates using the baseline alignment option to align equations across columns in a table.

<table>
<thead>
<tr>
<th>( f(x) )</th>
<th>( \int f(x) , dx )</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \frac{1}{1 + \frac{1}{1 + \frac{1}{x}}} )</td>
<td>( \frac{2}{3} x - \frac{1}{9} \ln(3x + 2) )</td>
</tr>
<tr>
<td>( \sin(\omega t) e^{(-\alpha t)} )</td>
<td>( -\frac{\omega e^{-\alpha t} \cos(\omega t)}{a^2 + \omega^2} - \frac{ae^{-\alpha t} \sin(\omega t)}{a^2 + \omega^2} )</td>
</tr>
<tr>
<td>( \frac{d^2}{dx^2} f(x) )</td>
<td>( \frac{d}{dx} f(x) )</td>
</tr>
</tbody>
</table>

### Table Settings:

In the **Properties** dialog (**Table>Properties** menu):

1. Set **Exterior Border** to **Top** and **Bottom**.

Using the **Table** menu:

2. **Group** columns 1 and 2.

3. **Group** rows 2 to 4.

4. Set row **Alignment** to **Baseline** for all rows.
Formatting Lists: Bullets, Numbers, and Indent

Bullet, numbered, and indented lists provide an easy way to organize information in your document.

Formatting Lists Using the Context Bar

To arrange content in a bullet list using the context bar drop-down list:

1. Select the text to be arranged.

2. In the character and paragraph style drop-down list, select P Bullet Item. The selected text is displayed as a (dot) bullet list.

To arrange content in a numbered list using the context bar drop-down list:

1. Select the text to be arranged.

2. In the character and paragraph style drop-down list, select P Ordered List 1. The selected text is displayed as a numbered list.

Ordered lists have 5 default styles. See Figure 6.12. List 1 begins at the left margin. By default, subsequent lists are indented half an inch. To change the default, see Modifying Paragraph Styles (page 244). The numbering style uses numbers, lowercase letters, lowercase roman numerals, uppercase letters, uppercase Roman numerals.
To arrange content in an indented list using the context bar drop-down list:

1. Select the text to be arranged.

2. In the character and paragraph style drop-down list, select P List Item. The selected text is displayed as an indented list.

Formatting Lists Using the Paragraph Style Dialog

With the Paragraph Style dialog, you can select various list styles: dot, dash, indent, numbers, lowercase letters, uppercase letters, lowercase Roman numerals, and uppercase Roman numerals.

To arrange content in a list using the Paragraph Style dialog:

1. Select the text to be arranged.

2. From the Format menu, select Paragraph, and then Attributes. The Paragraph Style dialog opens.

3. In the Bullet and Numbering drop-down list, select one of the styles.

4. If you have selected one of the numbered styles (number, letters, Roman numerals), set an initial list value.
5. To continue numbering this list from a previous list in your document, select the **Linked to Previous List** check box.

6. Click **OK** to accept this style.

**Bookmarks**

Use a bookmark to designate a location in an active document. This bookmark can then be accessed from other regions in your document or by using hyperlinks in other documents.

To display bookmark formatting icons, activate the **Marker** feature.

- From the **View** menu, select **Markers**.

---

**Inserting, Renaming, and Deleting a Bookmark**

**To insert a bookmark:**

1. Place the cursor at the location at which to place the bookmark.

2. From the **Format** menu, select **Bookmarks**. The **Bookmark** dialog opens, listing existing bookmarks in the document.

3. Click **New**. The **Create Bookmark** dialog opens. Enter a bookmark name and click **Create**.

4. The new bookmark appears in the **Bookmark** dialog list. Click **OK**.

**Note:** You can also rename and delete bookmarks using the **Bookmark** dialog.
Go to a Bookmark

You can automatically move the cursor to the location of the bookmark in the active document.

1. From the Edit menu, select Go To Bookmark. The Go To Bookmark dialog opens with the current bookmarks listed.

2. Select the bookmark and click OK. The cursor moves to the bookmark.

Inserting Images

Images help illustrate ideas and enhance presentations. You can insert images in your document at a cursor location or in a table.

You can insert images in these file formats into your document.

- Graphics Interchange Format - gif
- Joint Photographic Experts Group - jpe, jpeg, jpg
- Portable Network Graphics - png
- Bitmap Graphics - bmp
- Tagged Image File Format - tif, tiff, jfx
- Portable aNyMap - pnm
- Kodak FlashPix - fpx

To insert an image into the document at the cursor location:

1. From the Insert menu, select Image. The Load Image dialog opens.

2. Specify a path or folder name.

3. Select a filename.

4. Click Open. The image is displayed in the document.
If the source file is altered, the embedded image does not change because the original object is pasted into the document.

**To resize an inserted image:**

1. Click the image. Resizing anchors appear at the sides and corners of the image.

2. Move the mouse over the resize anchor. Resizing arrows appear.

3. Click and drag the image to the desired size.

**ImageTools Package**

You can manipulate image data using the `ImageTools` package. This package is a collection of utilities for reading and writing common image file formats, and for performing basic image processing operations within Maple.

Within Maple, images are represented as dense, rectangular Arrays of 64-bit hardware floating-point numbers. Grayscale images are 2-D, whereas color images are 3-D (the third dimension representing the color channels).

In addition to the commands in the `ImageTools` package, many ordinary Array and Matrix operations are useful for image processing.

For details about this feature, refer to the `?ImageTools` help page.

**Show or Hide Worksheet Content**

You can hide document elements of a specific type so that they are not visible. This does not delete them, but hides them from view. Hidden elements are not printed or exported, but they are copied and pasted.

In a document, use the `Show Contents` dialog to hide all spreadsheets, input, output, or graphics, plus section boundaries, execution group boundaries, and hidden table borders on mouse pointer roll over. The dialog is accessed from the `View>Show/Hide Contents` menu.
Using the Show Contents Dialog

A check mark beside the item indicates that all document elements of that type are displayed for the current document.

1. From the View menu, select Show/Hide Contents. The Show Contents dialog opens with all items selected for display.

2. Clear the check box associated with the document components or ranges to hide.

By clearing the Input check box, only Maple Input and 2-D Math input, that is, 2-D Math content that has been evaluated, are hidden. Clearing the Graphics check box ensures that a plot, an image, or the Canvas inserted in the document by using the Insert menu option is also hidden.

Command Output Versus Insertion

Output is considered an element that results from executing a command. Inserted components are not considered output.

Consider the following examples.

The plot resulting from executing the plot(sin) call is considered output.

- To show a plot from the plot(sin) call, select both the Output and Graphics check boxes in the Show Contents dialog.

If you insert a plot by using the Insert menu option, that plot is not considered output. Therefore, if you clear the Output check box in the Show Contents dialog, that plot will be visible in the document.

- To hide an inserted plot, clear the Graphics check box in the Show Contents dialog.

Inserted images and the Canvas are not considered output. As such, they are not hidden if you clear the Output check box.

- To hide an inserted image or canvas, clear the Graphics check box in the Show Contents dialog.
You can embed simple graphical interface components, for example, a button, in your document. These components can then be associated with actions that are to be executed. For example, the value of a slider component can be assigned to a document variable, or a text field can be part of an input equation.

**Adding Graphical Interface Components**

The graphical interface components can be inserted by using the **Components** palette (Figure 6.13) or by cutting/copying and pasting existing components to another area of the document. Although copied components have the same characteristics, they are distinct.

By default, palettes are displayed when you launch Maple. If palettes are not visible, use the following procedure.

**To view palettes:**

1. From the **View** menu, select **Palettes**.
2. Select **Expand Docks**.
3. If the **Components** palette is not displayed, right-click (Control-click, for Macintosh) the palette dock. From the context menu, select **Show Palette**, and then **Components**.

You can embed the following items.

- Button, Toggle Button
- Combo Box, Check Box, List Box
- Text Area, Label
- Slider, Plot, Function
Editing Component Properties: General Process

To edit properties of components embedded in the document:

1. Right-click (Control-click, for Macintosh) the component to display the context menu.

2. Select Component Properties. The related dialog opens.

3. Enter values and contents in the fields as necessary.

4. For actions, such as Action When Value Changes in the Slider component dialog, click Edit. A blank dialog opens allowing you to enter Maple code that is executed when the event occurs. For details, refer to the ?Document-Tools help page.

Removing Graphical Interface Components

You can remove an embedded component by:

- Using the Delete key
- Using the Backspace key
- Placing the cursor at the component and selecting from the document menu, Edit>Delete Element
Example Component Properties

The following example inserts a slider, and a label that indicates the current value of the slider.

1. Place the cursor in the location where the embedded component is to be inserted.

2. In the Components palette, click the Slider item. A slider is inserted into the document.

3. In the Components palette, click the Label item. A label is inserted next to the slider.

4. Right-click (Control-click, for Macintosh) the label component. Select Component Properties. The Label Properties dialog appears.

5. Name the component SliderLabel and click Ok.

6. Right-click (Control-click, for Macintosh) the slider component. Select Component Properties. The Slider Properties dialog opens.

7. Name the component Slider1.

8. Enter the lowest position as 0 and the highest as 100.

9. Enter minor tick marks at 10 and major tick marks at 20.

10. To define an action when the value of the slider changes, click Edit. The Action When Value Changes dialog opens.

11. Enter the following calling sequence and click OK to close all dialogs.

   DocumentTools[SetProperty ]('SliderLabel',caption,
   DocumentTools[GetProperty] ('Slider1', 'value' ) );

   The value from the slider as you move the arrow indicator populates the Label caption field.
For details on these commands, refer to the \texttt{DocumentTools/SetProperty} and the \texttt{DocumentTools/GetProperty} help pages.

**Printing and Exporting a Document with Embedded Components**

**Printing:** When printing a document, embedded components are rendered as they appear on screen.

**Exporting:** Exporting a document with embedded components to other formats produces the following results.

- HTML format - components are exported as \texttt{.gif} files.
- RTF format - components are rendered as \texttt{bitmap} images in the \texttt{.rtf} document.
- LaTeX - components are exported as \texttt{.eps} files.

### 6.4 Creating Graded Assignments

You can use Maple to create graded assignments. Question types include multiple choice, essay, true-or-false, fill-in-the-blanks, and Maple-graded.

**Note:** This feature can be used to create questions for Maple T.A.—an online automated testing and assessment system. For details about Maple T.A., see \textit{Input, Output, and Interacting with Other Products} (page 363).

**Creating a Question**

**To create a question:**

1. Open the Task browser (\texttt{Tools} > \texttt{Tasks} > Browser).
2. From the \texttt{Maple T.A.} folder, select the appropriate question type.
3. Insert the question template into a document.
4. Enter the question content as described in the template.
5. Repeat steps 1 to 4 for each question to add to the document.
Viewing Questions in Maple

To view and test your questions in Maple:

- From the View menu, select Assignment. This view displays all of the questions in your assignment with access to hints, plotting, and grading.

After answering your questions, you can test the grading function by clicking the Grade button. A Maplet dialog is displayed indicating if the question was answered correctly. If hints were provided in the question, these are also displayed.

Saving Test Content

When you save a document with test content, the authoring and assignment modes determine what the user sees when opening your document.

- If you save the document in authoring mode (task template contents visible), the user sees this content when opening the document.
- If you save the document in assignment mode, the users sees only the assignment layout.

In both cases the View>Assignment menu is accessible. As such, users (students) can switch between the original document contents and the displayed assignment.

6.5 Auto-Execute

An execution group is a grouping of Maple input with its corresponding Maple output. It is distinguished by a large square bracket, called a group boundary, at the left. An execution group may also contain any or all of the following: a plot, a spreadsheet, and text.

Execution groups are the fundamental computation and documentation elements in the document. If you place the cursor in an input command and press the Enter or Return key, Maple executes all of the input commands in the current execution group.
The **Autoexecute** feature allows you to designate regions of a document for automatic execution. These regions are executed when the document opens. This is useful when sharing documents. Important commands can be executed as soon as the user opens your document. The user is not required to execute all commands.

**Setting the Auto-Execute Feature**

1. Select the region that must be automatically executed when the document opens.

2. From the **Format** menu, select **Autoexecute**, and then **Set**.

**Removing the Auto-Execute Setting**

To remove the setting in a region:

1. Select the region.

2. From the **Format** menu, select **Autoexecute**, and then **Clear**.

To remove all autoexecution in a document:

- From the **Format** menu, select **Autoexecute**, and then **Clear All**.

**Repeating Auto-Execution**

To execute all marked groups:

- From the **Edit** menu, select **Execute**, and then **Repeat Autoexecution**.

**Security Levels**

By default, Maple prompts the user before automatically executing the document.

To set security levels for the autoexecute feature, use the **Security** tab in the **Options** dialog. For details, refer to the **?OptionsDialog** help page.
6.6 Canvas

Maple allows you to sketch an idea in a canvas, draw on plots, or even draw on images. See Figure 6.14. For details about the drawing feature, see the Maple help system.

![Figure 6.14: Canvas and Drawing Properties Palette](image)

**Insert a Canvas**

To insert a canvas:

1. Place the cursor where the canvas is to be inserted.

2. From the **Insert** menu, select **Canvas**. A canvas with grid lines appears in the document at the insertion point. The **Drawing** menu is available and associated context bar icons are displayed.
The tools include the following: selection tool, Pencil (free style drawing), eraser, text insert, straight line, square, rounded square, ellipse, diamond, alignment, launch drawing and canvas properties palettes.

**Drawing**

For details about the drawing feature, see the Maple help system.

**To draw with the pencil tool in the canvas:**

1. From the Drawing icons, select the pencil icon.
2. (Optional) Select a line thickness in the Drawing Properties palette.
3. Click and drag your mouse in the canvas to draw lines. Release the mouse to complete the drawing.

**To adjust the color of drawing tools:**

1. Open the **Drawing Properties** palette.
2. Click the color wheel. By default, the wheel is black. Move the slider to view more colors.
3. Select a color on the color wheel. The color is displayed in the rectangle.

**Canvas Style**

You can alter the **Canvas** in the following ways:

- Add a grid of horizontal and/or vertical lines. By default, the canvas opens with a grid of horizontal and vertical lines.
- Change the background color.
- Change the grid line color.
- Change the spacing between grid lines.

**To alter the canvas style:**

1. Expand the **Canvas Properties** palette.
2. For grid lines, select the appropriate grid check boxes (horizontal or vertical) and adjust spacing as required using the slider.

3. For colors, click the **Grid** or **Canvas** color. The color wheel opens. Select from various colors.

**To remove gridlines:**

- Clear the **Show horizontal grid** or **Show vertical grid** check boxes, and click **OK**.

### 6.7 Spell Checking

The **Spellcheck** utility examines all designated text regions of your document for potential spelling mistakes, including regions that are in collapsed sections. It does not check input, output, text in execution groups, or math in text regions. See Figure 6.15.

**Note:** The **Spellcheck** utility uses American spelling.

> The CodeGeneration package is a collection of commands and subpackages that enable the translation of Maple code to other programming languages.

![Spellcheck Dialog](image)

**Figure 6.15: Spellcheck Dialog**
How to Use the Spellcheck Utility


2. If the Spellcheck utility finds a word that it does not recognize, that word is displayed in the Not Found text box.

You have six choices:

- To ignore the word, click Ignore.
- To ignore all instances of the word, click Ignore All.
- To change the word, that is, accept one of the suggested spellings for the word, to the one that is in the Change To text box, click Change.
- To change all instances of the word, that is, accept the suggested spelling to replace all instances of the word, click Change All.
- To add the word to your dictionary, click Add. For details, see the following User Dictionary section.
- To close the Spellcheck dialog, that is, quit the Spellcheck utility, click Cancel.

3. When the Spellcheck is complete, a dialog containing the message "spellchecking complete" appears. Click OK to close this dialog.

Selecting a Suggestion

To select one of the suggestions as the correct spelling, click the appropriate word from the list in the Suggestions text box.

If none of the suggestions are correct, highlight the word in the Change To text box and enter the correct spelling. Click Change to accept this new spelling.
Spellcheck Usage and the Document

When using the Spellcheck utility, you can fix spelling errors in the Spellcheck dialog. You cannot change the text in the document while the Spellcheck utility is running.

The Spellcheck utility does not check grammar.

User Dictionary

You can create and maintain a custom dictionary that works with the Maple Spellcheck utility.

Properties of the Custom Dictionary File

- It must be a text file, that is, have the file extension .txt. For example, mydictionary.txt.
- It is a list of words, one word per line.
- It is case sensitive. This means that integer and Integer require individual entries in the dictionary file.
- It does not require manual maintenance. You build your dictionary file by using the Add functionality of the Spellcheck. However, you can manually edit the file if an error is introduced.

To specify a custom dictionary to be used with the Maple Spellcheck utility:

1. Create a .txt file using your favorite text editor in a directory/folder of your choice.

2. In Maple, open the Options dialog, Tools>Options, and select the General tab.

3. In the User Dictionary field, enter the path and name of the .txt file you created in step 1, or click Browse to select the location and filename.
4. To ignore Maple words that are command and function names, select the **Use Maple Words in Spellchecker** check box. A check mark indicates that the **Spellcheck** ignores Maple words.

5. Click **Apply to Session**, **Apply Globally**, or **Cancel**.

**Adding a Word to Your Dictionary**

When running the spellcheck, if the word in the **Not Found** text box is correct, you can add the word to your dictionary.

1. Click the **Add** button. If this is the first time you are adding a word, the **Select User Dictionary** dialog opens.

2. Enter or select the custom dictionary (.txt file) you created. See **User Dictionary** (page 278).

3. Click **Select**. The word is automatically added to your custom dictionary file.

**Note**: Specifications in the **Options** dialog determine whether this word is recognized in your next Maple session. If you set your custom dictionary use to **Apply to Session**, then this word will *not* be recognized in a new Maple session. If you set your custom dictionary use to **Apply Globally**, then this new word will be recognized. See **User Dictionary** (page 278).

**6.8 Hyperlinks**

Use a hyperlink in your document to access any of the following.

- Email
- Dictionary Topic
- Help Topic
- Maplet Application
- Web Page (URL)
- Document
Inserting a Hyperlink in a Document

To insert a hyperlink in the document:

1. Highlight the text that you want to make a hyperlink.

2. From the Format menu, select Hyperlink.

3. In the Hyperlink Properties dialog box, enter the text of the hyperlink name in the Link Text edit field. See Figure 6.16.

4. Optionally, use an image as the link. Select the Include an Image check box and Browse for the correct file. In .mw files, the image appears as the link, while in .mws files, the Link Text you entered appears as the link. You can resize the image as necessary. Click the image. Resizing anchors appear at the sides and corners of the image.

5. Specify the hyperlink Type and Target as described in the appropriate following section.

Linking to an Email Address

To link to an email address:

1. In the Type drop-down list, select Email.
2. In the **Target** field, enter the email address.

3. Click **OK**.

**Note**: For information about email hyperlinks in the Classic Worksheet interface, see *Worksheet Compatibility (page 283)*.

### Linking to a Dictionary Topic

**To link to a Dictionary topic:**

1. In the **Type** drop-down list, select **Dictionary Topic**.

2. In the **Target** field, enter a topic name. Dictionary topics begin with the prefix **Definition/**, for example, **Definition/dimension**.

3. Click **OK**.

### Linking to a Help Page

**To link to a help page:**

1. In the **Type** drop-down list, select **Help Topic**.

2. In the **Target** field, enter the topic of the help page.

(Optional) In the **Bookmark** drop-down list, enter or select a bookmark.

3. Click **OK**.

### Linking to a Maplet Application

**To link to a Maplet application:**

1. In the **Type** drop-down list, select **Maplet**.

2. In the **Target** field, enter the local path to a file with the `.maplet` extension. Optionally, click **Browse** to locate the file.
If the Maplet application exists, clicking the link launches the Maplet application. If the Maplet application contains syntax errors, then error messages are displayed in a pop-up window.

When linking to a custom Maplet application, the path is absolute. When sharing documents that contain links to Maplet applications, ensure that target Maplet applications are in the same directory.

3. Click **OK**.

**Note**: To link to a Maplet application available on a MapleNet Web page, use the URL hyperlink type to link to the Web page. For information on MapleNet, see *Input, Output, and Interacting with Other Products* (page 363).

### Linking to a Web Page

**To link to a Web page:**

1. In the **Type** drop-down list, select **URL**.
2. In the **Target** field, enter the URL, for example, **www.maplesoft.com**.
3. Click **OK**.

### Linking to a Document

**To link to a document:**

1. In the **Type** drop-down list, select **Worksheet**.
2. In the **Target** field, enter the path and filename of the document or click **Browse** to locate the file. (Optional) In the **Bookmark** drop-down list, enter or select a bookmark.

**Note**: When linking to a custom document, the path is absolute. When sharing documents that contain hyperlinks, ensure that target documents are in the same directory.

3. Click **OK**.
6.9 Worksheet Compatibility

Maple provides users with two worksheet interfaces: the Standard Worksheet and the Classic Worksheet. Both have access to the full mathematical engine of Maple and take advantage of the new functionality in Maple. The Classic Worksheet has the traditional Maple worksheet look and uses less memory.

If you create a document in the Standard Worksheet interface of Maple and then open it in the Classic Worksheet interface, you should note possible changes to your file. For example, a bulleted list in the Standard Worksheet will not be displayed with bullets in the Classic Worksheet.

If you are creating documents for distribution, refer to the ?Compatibility help page.
7 Maple Expressions

This chapter provides basic information on using Maple expressions, including an overview of the basic data structures. Many of the commands described in this chapter are useful for programming. For information on additional Maple programming concepts, such as looping, conditional execution, and procedures, see Basic Programming (page 321).

7.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Creating and Using Data Structures</strong></td>
<td>- Expression Sequences</td>
</tr>
<tr>
<td></td>
<td>- Sets</td>
</tr>
<tr>
<td></td>
<td>- Lists</td>
</tr>
<tr>
<td></td>
<td>- Tables</td>
</tr>
<tr>
<td></td>
<td>- Arrays</td>
</tr>
<tr>
<td></td>
<td>- Matrices and Vectors</td>
</tr>
<tr>
<td></td>
<td>- Functional Operators</td>
</tr>
<tr>
<td></td>
<td>- Strings</td>
</tr>
<tr>
<td><strong>Working with Maple Expressions</strong></td>
<td>- Low-Level Operations</td>
</tr>
<tr>
<td></td>
<td>- Manipulating Expressions</td>
</tr>
<tr>
<td></td>
<td>- Evaluating Expressions</td>
</tr>
</tbody>
</table>

7.2 Creating and Using Data Structures

Constants, data structures, mathematical expressions, and other objects are Maple expressions. For more information on expressions, refer to the Maple Help System.
This section describes the key data structures:

- Expression sequences
- Sets
- Lists
- Tables
- Arrays
- Matrices and Vectors
- Functional operators
- Strings

**Expression Sequences**

The fundamental Maple data structure is the *expression sequence*. It is a group of expressions separated by commas.

\[ S := 2, y, \sin(x^2), i; \]

**Accessing Elements**

To access one of the expressions:

- Enter the sequence name followed by the position of the expression enclosed in brackets([ ]).

For example:

\[ S[2] \]

\[ y \]

Using negative integers, you can select an expression from the end of a sequence.
You can select multiple expressions by specifying a range using the range operator (..).

\[ S[2..-2] \]

\[ y, \sin(x^2) \]

**Note:** This syntax is valid for most data structures.

### Sets

A set is an expression sequence enclosed in curly braces ({ }).

\[ \{4, 12 i, \sin\left(\frac{2}{3}\right)\} \]

A Maple set has the basic properties of a mathematical set.

- Each element is unique. Repeated elements are stored only once.
- The order of elements is not stored.

For example:

\[ \{c, a, a, a, b, c, a\} \]

\[ \{a, c, b\} \]

### Using Sets

To perform mathematical set operations, use the set data structure.
> {2, 6, 5, 1} ∪ {2, 8, 6, 7}

{1, 2, 5, 6, 7, 8}

Note: The union operator is available in 1-D Math input as \texttt{union}. For more information, refer to the \texttt{?union} help page.

For more information on sets, refer to the \texttt{?set} help page.

**Lists**

A list is an expression sequence enclosed in brackets ([ ]).

> $L := [2, 3, 3, 1, 0]$

$L := [2, 3, 3, 1, 0]$

Note: Lists preserve both the \texttt{order} and \texttt{repetition} of elements.

**Accessing Entries**

To refer to an element in a list:

- Use square brackets.

For example:

> $L[-2 .. -1]$

$[1, 0]$

For more information, see \textit{Accessing Elements} (page 286).

**Using Lists**

Some commands accept a list (or set) of expressions.

For example, you can solve a list (or set) of equations using a context menu or the \texttt{solve} command.
For more information, see Solving Equations and Inequations (page 78).

For more information on sets and lists, refer to the `?set` help page.

**Arrays**

Conceptually, the Array data structure is a generalized list. Each element has an index that you can use to access it.

The two important differences are:

- The indices can be any integers.
- The dimension can be greater than one.

**Creating and Using Arrays**

To define an Array, use the `Array` constructor.

Standard `Array` constructor arguments are:

- Expression sequences of ranges - Specify the indices for each dimension
- Nested lists - Specify the contents

For example:

```plaintext
> solve([x - y^2 = -2, x + y = 0])

{y = -2, x = 2}, {y = 1, x = -1}
```

For more information, see Solving Equations and Inequations (page 78).

For more information on sets and lists, refer to the `?set` help page.
The \texttt{Array} constructor supports other syntaxes. It also supports many options. For more information on the \texttt{Array} constructor and the Array data structure, refer to the \texttt{?Array} help page.

\section*{Large Arrays}

Only one- and two-dimensional Arrays (with at most 10 indices in each dimension) display in the document. Larger Arrays display as a placeholder.

\begin{verbatim}
> a[1,1]
1
> a[2,3]
6
\end{verbatim}

To view large Arrays:

- Double-click the placeholder.

The \textbf{Matrix Browser} displays the Array. For more information, see \textit{Editing and Viewing Large Matrices and Vectors} (page 136).

\section*{Tables}

Tables are conceptually an extension of the Array data structure, but the table data structure is implemented using hash tables. Tables can be indexed by any values, not only integers.
Defining Tables and Accessing Entries

> Greek := table([a = α, b = β, c = γ]):

> Greek[b]

β

You can also assign anything, for example, a list, to each element.

> Translation := table([one = [un, uno], two = [deux, dos], three = [trois, tres]]):

> Translation[two]

[deux, dos]

For more information on tables, refer to the ?table help page.

Matrices and Vectors

Matrices and Vectors are specialized data structures used in linear algebra and vector calculus computations.

> M := \[
\begin{bmatrix}
1 & 2 \\
3 & 3 \\
\end{bmatrix}
\];

v := <2, 14>:

For information on defining Matrices and Vectors, see Creating Matrices and Vectors (page 133).

> M.v

\[
\begin{bmatrix}
486 \\
334
\end{bmatrix}
\]
For more information on these data structures, including how to access entries and perform linear algebra computations, see Linear Algebra (page 133).

**Functional Operators**

A functional operator is a mapping $f: x \rightarrow y(x)$. The value of $f(x)$ is the result of evaluating $y(x)$.

Using functional operators, you can define mathematical functions.

**Defining a Function**

To define a function of one or two variables:

1. In the Expression palette, click one of the function definition items. See Figure 7.1. Maple inserts the function definition.

2. Replace the placeholder $f$ with the function name. Press Tab. **Note:** If pressing the Tab key inserts a tab, click the Tab icon in the toolbar.

3. Replace the parameter placeholders, $x$ or $x1$, $x2$, with the independent variable names. Press Tab.

4. Replace the final placeholder, $y$, with the expression that defines the function value. Press Enter.
Figure 7.1: Function Definition Palette Items

For example, define a function that adds 1 to its input.

\[ \texttt{add1 := } x \rightarrow x + 1; \]

**Note:** To insert the right arrow, you can enter the characters \(-\rightarrow\). In 2-D Math, Maple replaces \(-\rightarrow\) with the right arrow symbol \(-\rightarrow\). In 1-D Math, the characters are not replaced.

You can evaluate the function \texttt{add1} with symbolic or numeric arguments.

\[ \texttt{add1(12); add1(x + y)} \]

\[ \begin{align*}
\texttt{13} & \\
\texttt{x + y + 1} & 
\end{align*} \]

**Distinction between Functional Operators and Other Expressions**

The expression \( x + 1 \) is different from the functional operator \( x \rightarrow x + 1 \).

Assign the functional operator \( x \rightarrow x + 1 \) to \( f \).

\[ \texttt{f := } x \rightarrow x + 1; \]

Assign the expression \( x + 1 \) to \( g \).

\[ \texttt{g := } x + 1; \]

**To evaluate the functional operator \( f \) at a value of \( x \):**

- Specify the value as an argument to \( f \).
To evaluate the expression $g$ at a value of $x$:

- You must use the `eval` command.

```maple
> eval(g, x = 22)
```

For more information on the `eval` command, and using palettes and context menus to evaluate an expression at a point, see *Substituting a Value for a Subexpression* (page 310).

**Multivariate and Vector Functions**

**To define a multivariate or vector function:**

- Enclose coordinates or coordinate functions in parentheses ($( )$).

For example, a multivariate function:

```maple
> f := (x, y) -> x^3/(y^2 + 1):
> f(0, 0); f(-2.1, 1.9)
```

A vector function:

```maple
> g := t -> (sin(t), cos(t), t):
```
Using Operators

To perform an operation on a functional operator, specify arguments to the operator. For example, for the operator \( f \), specify \( f(x) \), which Maple evaluates as an expression. See the following examples.

**Plot an Operator as an Expression** Plot a three-dimensional function using the `plot3d` command.

\[
g(0); g\left(\frac{\pi}{2}\right) = 0, 1, 0
\]

\[
1, 0, \frac{1}{2} \pi
\]

\[
h := (x, y) \rightarrow x^2 \cos(y);
\]

\[
plot3d(h(x, y), x = -2..2, y = -2 \pi..2 \pi)
\]
For information on plotting, see *Plots and Animations (page 187)*.

**Integration** Integrate a function using the **int** command.

\[
\begin{align*}
&> k := x \rightarrow \sin(\cos(x)\pi): \\
&> \text{int}\left(k(t), t = 0..\frac{\pi}{2}\right)
\end{align*}
\]

\[
\frac{1}{2} \pi H_0(\pi)
\]

\(H_0\) represents the **Struve** function. For more information, refer to the **?StruveH** help page.

For information on integration and other calculus operations, see *Calculus (page 151)*.
Strings

A string is a sequence of characters enclosed in double quotes (" ").

> S := "This a sequence of characters."

Accessing Characters

You can access characters in a string using brackets.

> S[8..-2]

"sequence of characters"

Using Strings

The StringTools package is an advanced set of tools for manipulating and using strings.

> with(StringTools):

> Random(9)

"rVáIÄK"

> Stem("impressive")

"impress"

> Split("Create a list of strings from the words in a string")

[ "Create", "a", "list", "of", "strings", "from", "the", "words", "in", "a", "string"]
7.3 Working with Maple Expressions

This section describes how to manipulate expressions using context menus, palette items, and the underlying commands.

To display the context menu for an expression:

- Right-click (Control-click, for Macintosh) the expression.

To view the palettes:

- From the View menu, select Palettes, and then Expand Docks.

Low-Level Operations

Expression Types

A Maple type is a broad class of expressions that share common properties. Maple contains over 200 types, including:

- `+`
- boolean
- constant
- integer
- Matrix
- trig
- trufalse

For more information and a complete list of Maple types, refer to the ?type help page.

The type commands return true if the expression satisfies the type check. Otherwise, they return false.
Testing the Type of an Expression

To test whether an expression is of a specified type:

- Use the `type` command.

```maple
> type(sin(x), 'trig')

true
```

```maple
> type(sin(x) + cos(x), 'trig')

false
```

For information on enclosing keywords in right single quotes (`'`), see *Delaying Evaluation (page 317)*.

Maple types are not mutually exclusive. An expression can be of more than one type.

```maple
> type(3, 'constant')

true
```

```maple
> type(3, 'integer')

ture
```

For information on converting an expression to a different type, see *Converting (page 307)*.

Testing the Type of Subexpressions

To test whether an expression has a subexpression of a specified type:

- Use the `hastype` command.
Testing for a Subexpression

To test whether an expression contains an instance of a specified subexpression:

- Use the has command.

```maple
> has(sin(x + y), x)

true
```

```maple
> has(sin(x + y), x + y)

true
```

```maple
> has(sin(x + y), sin(x))

false
```

The has command searches the structure of the expression for an exactly matching subexpression.

For example, the following calling sequence returns false.

```maple
> has(x + y + z, x + z)

false
```

To return all subexpressions of a particular type, use the indets command. For more information, see Indeterminates (page 303).
Accessing Expression Components

Left and Right-Hand Side

The **lhs** and **rhs** commands return the left and right-hand side of an equation, inequality, or range.

**To extract the left-hand side of an expression:**

- Use the **lhs** command.

**To extract the right-hand side of an expression:**

- Use the **rhs** command.

For example:

```maple
> y = x + 1

y = x + 1

(7.1)

> lhs(7.1)

y

> rhs(7.1)

x + 1
```

For the following equation, the left endpoint of the range is the left-hand side of the right-hand side of the equation.

```maple
> x = 3 .. 5

x = 3 .. 5

(7.2)
```
To extract the numerator of an expression:

- Use the \texttt{numer} command.

To extract the denominator of an expression:

- Use the \texttt{denom} command.

If the expression is not in normal form, Maple normalizes the expression before selecting the numerator or denominator. (For more information on normal form, refer to the \texttt{?normal} help page.)

\begin{verbatim}
\texttt{e := (1 + \sin(x)^3 - \frac{y}{x}) / (y^2 - 1 + x)};
\end{verbatim}

\begin{verbatim}
\texttt{numer(e)} \quad x + \sin(x)^3 x - y
\end{verbatim}

\begin{verbatim}
\texttt{denom(e)} \quad x \left(y^2 - 1 + x\right)
\end{verbatim}

\begin{verbatim}
\texttt{denom(denom(e))} \quad 1
\end{verbatim}

The expression can be any algebraic expression. For information on the behavior for non-rational expressions, refer to the \texttt{?numer} help page.
Components of an Expression

The components of an expression are called its operands.

To count the number of operands in an expression:

- Use the \texttt{nops} command.

For example, construct a list of solutions to an equation.

\begin{verbatim}
> solutions := [solve(6*x^3 - x^2 + 7, x)]

solutions := [-1, 7/12 + 1/12*i*sqrt(119), 7/12 - 1/12*i*sqrt(119)]
\end{verbatim}

Using the \texttt{nops} command, count the number of solutions.

\begin{verbatim}
> nops(solutions)

3
\end{verbatim}

For more information on the \texttt{nops} command and operands, refer to the \texttt{?nops} help page.

Indeterminates

To find the indeterminates of an expression:

- Use the \texttt{indets} command.

The \texttt{indets} command returns the indeterminates as a set. Because the expression is expected to be rational, functions such as sin(x), f(x), and sqrt(x) are considered to be indeterminate.

\begin{verbatim}
> indets((3 + \pi) x^2 sin(\sqrt{1 + y}))

\{y, x, \sqrt{1 + y}, \sin(\sqrt{1 + y})\}
\end{verbatim}
To return all subexpressions of a particular type, specify the type as the second argument. For information on types, see *Testing the Type of an Expression* (page 299).

\[
> \text{indets}((3 + \pi)x^2 \sin(\sqrt{1 + y}), '\text{radical}')
\]

\[
\{\sqrt{y + 1}\}
\]

To test whether an expression has subexpressions of a specific type (without returning them), use the `has` command. For more information, see *Testing for a Subexpression* (page 300).

## Manipulating Expressions

This section introduces the most commonly used manipulation commands. For additional manipulation commands, see *Iterative Commands* (page 333).

### Simplifying

To simplify an expression:

- Use the `simplify` command.

The `simplify` command applies simplification rules to an expression. Maple has simplification rules for various types of expressions and forms, including trigonometric functions, radicals, logarithmic functions, exponential functions, powers, and various special functions. You can also specify custom simplification rules using a set of *side relations*.

\[
> \text{simplify} \left( 5 + 3 \cdot 2 - 8 \left( \frac{1}{3} \right) \right)
\]
To limit the simplification, specify the type of simplification to be performed.

\[ \text{\texttt{simplify}} \left( \sin(x)^2 + \ln(2 y) + \cos(x)^2 \right) \]

\[ 1 + \ln(2) + \ln(y) \]

You can also use the \texttt{simplify} command with \textit{side relations}. See \textit{Substituting a Value for a Subexpression} (page 310).

\section*{Factoring}

\textbf{To factor a polynomial:}

\begin{itemize}
  \item Use the \texttt{factor} command.
\end{itemize}

\[ \text{\texttt{factor}}(x^6 - x^5 - 9x^4 + x^3 + 20x^2 + 12x) \]

\[ x (x - 2) (x - 3) (x + 2) (x + 1)^2 \]

\[ \text{\texttt{factor}} \left( x^3 y + x^2 y^2 - 3 x^3 - x^2 y + 2 x y^2 - 6 x^2 - 5 x y + y^2 - 3 x - 3 y \right) \]

\[ (x + 1)^2 (-3 + y) (x + y) \]

Maple can factor polynomials over the domain specified by the coefficients. You can also factor polynomials over algebraic extensions. For details, refer to the \texttt{?factor} help page.
For more information on polynomials, see *Polynomial Algebra* (page 124).

**To factor an integer:**
- Use the `ifactor` command.

```maple
> ifactor(196911)

(3)^4 (11) (13) (17)
```

For more information on integers, see *Integer Operations* (page 71).

**Expanding**

**To expand an expression:**
- Use the `expand` command.

The `expand` command distributes products over sums and expands expressions within functions.

```maple
> expand((y-3) (x+1)^2 (x+y))

x^3 y + x^2 y^2 - 3 x^3 - x^2 y + 2 x y^2 - 6 x^2 - 5 x y + y^2 - 3 x - 3 y
```

```maple
> expand(sin(x+y))

sin(x) cos(y) + cos(x) sin(y)
```

**Combining**

**To combine subexpressions in an expression:**
- Use the `combine` command.
The **combine** command applies transformations that combine terms in sums, products, and powers into a single term.

```maple
> combine(sin(x) cos(y) + cos(x) sin(y))

sin(x + y)
```

```maple
> combine((x^a)^2)

x^(2*a + 1)
```

The **combine** command applies only transformations that are valid for all possible values of names in the expression.

```maple
> combine(4 ln(x) - ln(y))

4*ln(x) - ln(y)
```

To perform the operation under assumptions on the names, use the **assuming** command. For more information about assumptions, see *Assumptions on Variables* (page 116).

```maple
> combine(4 ln(x) - ln(y)) assuming x > 0, y > 0

ln(x^4/y)
```

**Converting**

**To convert an expression:**

- Use the **convert** command.

The **convert** command converts expressions to a new form, type (see *Expression Types* (page 298)), or in terms of a function. For a complete list of conversions, refer to the **?convert** help page.
Convert a measurement in radians to degrees:

\[ \text{convert}(\pi, \text{'degrees'}) \]

180 degrees

To convert measurements that use units, use the Unit Converter or the `convert/units` command.

\[ \text{convert}(450.2\text{[kg]}, \text{'units', lb}) \]

992.5211043 [lb]

For information on the Unit Converter and using units, see Units (page 96).

Convert a list to a set:

\[ \text{convert}([a, b, c, d], \text{'set'}) \]

\{a, b, c, d\}

Maple has extensive support for converting mathematical expressions to a new function or function class.

\[ \text{convert}({\cos(x}), \text{exp}) \]

\[ \frac{1}{2} e^{ix} + \frac{1}{2} \frac{1}{e^{ix}} \]

Find an expression equivalent to the inverse hyperbolic cotangent function in terms of Legendre functions.

\[ \text{convert}(\text{arccoth}(z), \text{Legendre}) \]

\[ Q_0\left(\frac{1}{z}\right) + \frac{1}{2} \frac{\pi \sqrt{(-(z-1)^2)}}{z-1} \]
\( Q_0 \) represents the Legendre function of the second kind. For more information, refer to the \texttt{LegendreQ} help page.

For more information on converting to a class of functions, refer to the \texttt{convert/to_special_function} help page.

**Normalizing**

**To normalize an expression:**

- Use the \texttt{normal} command.

The \texttt{normal} command converts expressions into \textit{factored normal form}.

\[
\texttt{normal} \left( \frac{x^2 - y^2}{(x-y)^3} \right)
\]

\[
\frac{x+y}{(-x+y)^2}
\]

You can also use the \texttt{normal} command for zero recognition.

\[
\texttt{normal}(x^3 + 1 - (x + 1)^3 + 3x(1+x))
\]

\[
0
\]

To expand the numerator and denominator, use the \texttt{expanded} option.

\[
\texttt{normal} \left( \frac{x^2 - y^2}{(x-y)^3}, \text{'expanded'} \right)
\]

\[
\frac{x+y}{x^2 - 2xy + y^2}
\]

\[
\texttt{normal} \left( \sin \left( 1 + \frac{1}{x} \right) \right)
\]
Sorting

To sort the elements of an expression:

- Use the `sort` command.

The `sort` command orders a list of values or terms of a polynomial.

```maple
> sort([4, 3, 2.1, -4, 43, 0])

[-4, 0, 2.1, 3, 4, 43]

> sort(x + 4*x^5 - 7*x^2 + 1 + 9*x^4 - 5*x^3)

4*x^5 + 9*x^4 - 5*x^3 - 7*x^2 + x + 1

> sort(x*y - 6*y^2*x + 2*y^3 + 5*x - 1)

2*y^3 - 6*y^2*x + y*x + 5*x - 1
```

For information on sorting polynomials, see Sorting Terms (page 126).

For more information on sorting, refer to the `?sort` help page.

Evaluating Expressions

Substituting a Value for a Subexpression

To evaluate an expression at a point, you must substitute a value for a variable.

To substitute a value for a variable:
1. Right-click (Control-click, for Macintosh) the expression. Maple displays a context menu.

2. From the context menu, select **Evaluate at a Point**. The **Evaluate at a Point** dialog is displayed.

3. In the drop-down list, select the variable to substitute.

4. In the text field, enter the value to substitute for the variable. Click **OK**.

   Maple inserts the **eval** command calling sequence that performs the substitution. This is the most common use of the **eval** command.

   For example, substitute \( x = 3 \) in the following polynomial.

   \[
   x^3 + 4x^2 - 7x + 2
   \]

   \[
   \text{eval}(x^3 + 4x^2 - 7x + 2, [x = 3])
   \]

   \[
   44
   \]

   (7.3)

   **To substitute a value for a variable using palettes:**

   1. In the **Expression** palette, click the evaluation at a point item.

   2. Specify the expression, variable, and value to be substituted.

   For example:

   \[
   \sqrt{x^2 - x - 3}
   \]

   \[
   x = 5
   \]

   \[
   \sqrt{17}
   \]
Substitutions performed by the `eval` function are syntactical, not the more powerful algebraic form of substitution.

If the left-hand side of the substitution is a name, Maple performs the substitution.

\[
\texttt{\textgreater eval}\left(\cos(a \ b \ c), a = \frac{\pi}{6}\right)
\]

\[
\cos\left(\frac{1}{6} \ \pi \ b \ c\right)
\]

If the left-hand side of the substitution is not a name, Maple performs the substitution only if the left-hand side of the substitution is an operand of the expression.

\[
\texttt{\textgreater eval}\left(\cos(a \ b), a \ b = \frac{\pi}{6}\right)
\]

\[
\frac{1}{2} \ \sqrt{3}
\]

\[
\texttt{\textgreater eval}\left(\cos(a \ b \ c), a \ b = \frac{\pi}{6}\right)
\]

\[
\cos(a \ b \ c)
\]

Maple did not perform the evaluation because \(a \ b\) is not an operand of \(\cos(a \ b \ c)\). For information on operands, refer to the `\?op` help page.

For algebraic substitution, use the `algsubs` command, or the `simplify` command with side relations.
Numerical Approximation

To compute an approximate numerical value of an expression:

- Use the \texttt{evalf} command.

The \texttt{evalf} command returns a floating-point (or complex floating-point) number or expression.

\begin{verbatim}
> algsubs(a*b = pi/6, cos(a*b*c))

\verb|cos(1/6*c*pi)|
\end{verbatim}

\begin{verbatim}
> simplify(cos(a*b*c), \{a*b = pi/6\})

\verb|cos(1/6*c*pi)|
\end{verbatim}

(7.3 Working with Maple Expressions)
By default, Maple calculates the result to ten digits of accuracy, but you can specify any number of digits as an index, that is, in brackets ([ ]).

> `evalf[40](\pi)`

\[ 3.141592653589793238462643383279502884197 \]

For more information, refer to the `?evalf` help page.

See also *Numerically Computing a Limit* (page 153) and *Numeric Integration* (page 163).

**Evaluating Complex Expressions**

To evaluate a complex expression:

- Use the `evalc` command.

If possible, the `evalc` command returns the output in the canonical form `expr1 + i expr2`.

You can enter the imaginary unit using the following two methods.

- In the **Common Symbols** palette, click the i or j item. See *Palettes* (page 11).
- Enter i or j, and then press the symbol completion key. See *Symbol Names* (page 16).

> `evalc(\sqrt{1 + i})`

\[ \frac{1}{2} \sqrt{2 + 2\sqrt{2}} + \frac{1}{2} i \sqrt{(-2 + 2\sqrt{2})} \]

> `evalc(sin(3 + 5 i))`

\[ \sin(3) \cosh(5) + i \cos(3) \sinh(5) \]

In 1-D Math input, enter the imaginary unit as an uppercase i (I).
\[
> \text{evalc}(2^{1+I});
\]

\[2 \cos(\ln(2)) + 2i \sin(\ln(2))\]

**Evaluating Boolean Expressions**

To evaluate an expression involving relational operators (\(=\), \(\neq\), \(>\), \(<\), \(\leq\), and \(\geq\)):

- Use the `evalb` command.

**Note:** In 1-D Math input, enter \(\neq\), \(\leq\), and \(\geq\) using the ```<>``` , ```<=``` , and ```>=``` operators.

The `evalb` command uses a three-valued logic system. The return values are `true`, `false`, and `FAIL`. If evaluation is not possible, an unevaluated expression is returned.

\[
> \text{evalb}(x = x)
\]

```
true
```

\[
> \text{evalb}(x = y)
\]

```
false
```

\[
> \text{evalb}(3 + 2i < 2 + 3i)
\]

```
FAIL
```

**Important:** The `evalb` command does not perform arithmetic for inequalities involving \(<\), \(\leq\), \(>\), or \(\geq\), and does not simplify expressions. Ensure that you perform these operations before using the `evalb` command.

\[
> \text{evalb}(\Re(x) < \Re(x + 1))
\]
In a symbolic mathematics program such as Maple, you encounter the issue of levels of evaluation. If you assign y to x, z to y, and then 5 to z, what is the value of x?

At the top-level, Maple fully evaluates names. That is, Maple checks if the name or symbol has an assigned value. If it has a value, Maple substitutes the value for the name. If this value has an assigned value, Maple performs a substitution, recursively, until no more substitutions are possible.

For example:

```plaintext
> x := y;

> y := z;

> z := 5;
```

Maple fully evaluates the name x, and returns the value 5.

```plaintext
> x
```

5

**Levels of Evaluation**

To control the level of evaluation of an expression:

- Use the `eval` command with an integer second argument.

If passed a single argument, the `eval` command fully evaluates that expression. If you specify an integer second argument, Maple evaluates the expression to that level.
For more details on levels of evaluation, refer to the %lastnameevaluation, %assigned, and %evaln help pages.

### Delaying Evaluation

To prevent Maple from immediately evaluating an expression:

- Enclose the expression in right single quotes (' ').

Because right single quotes delay evaluation, they are referred to as unevaluation quotes.

```maple
> i := 4:

> i
```

4
Using an Assigned Name as a Variable or Keyword

If you use an assigned name as a variable, Maple evaluates the name to its value, and passes the value to the command.

\[
\sum_{i=1}^{5} i^2
\]

Error, (in sum) summation variable previously assigned, second argument evaluates to 4 = 1 .. 5

Note: In general, it is recommended that you unassign a name to use it as a variable. See Unassigning a Name Using Unevaluation Quotes (page 319).

To use an assigned name as a variable:

- Enclose the name in unevaluation quotes. Maple passes the name to the command.

\[
\sum_{i'=1}^{5} 'i'^2
\]

55

Important: It is recommended that you enclose keywords in unevaluation quotes.

For example, if you enclose the keyword \texttt{left} in unevaluation quotes, Maple uses the name, not its assigned value.

\[
left := 3:
\]
> \texttt{limit\left(\frac{1}{x}, x=0, \text{'left'}\right)}

\[ -\infty \]

**Full Evaluation of an Expression in Quotes**

Full evaluation of a quoted expression removes one set of right single quotes.

\begin{itemize}
  \item \texttt{i := 4:}
  \item \texttt{''i' + 1'}
  \end{itemize}

\[ 'i' + 1 \quad (7.6) \]

\begin{itemize}
  \item \texttt{(7.6)}
  \end{itemize}

\[ i + 1 \quad (7.7) \]

\begin{itemize}
  \item \texttt{(7.7)}
  \end{itemize}

\[ 5 \]

For information on equation labels and equation label references, see *Equation Labels* (page 59).

Enclosing an expression in unevaluation quotes delays evaluation, but does not prevent automatic simplification.

\begin{itemize}
  \item \texttt{'q-i + 3 q'}
  \end{itemize}

\[ 4q - i \]

**Unassigning a Name Using Unevaluation Quotes**

To unassign a name:

- Assign the name enclosed in unevaluation quotes to itself.
You can also unassign a name using the \texttt{unassign} command. For more information, see \textit{Unassigning Names (page 57)}.
8 Basic Programming

You have used Maple interactively in the previous chapters, sequentially performing operations such as executing a single command. Because Maple has a complete programming language, you can also use sophisticated programming constructs.

Important: It is strongly recommended that you use the Worksheet mode and 1-D Math input when programming or using programming commands. Hence, all input in this chapter is entered as 1-D Math.

8.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flow Control - Basic programming constructs</td>
<td>• Conditional Execution (if Statement)</td>
</tr>
<tr>
<td></td>
<td>• Repetition (for Statement)</td>
</tr>
<tr>
<td>Iterative Commands - Specialized, efficient</td>
<td>• Creating a sequence</td>
</tr>
<tr>
<td>iterative commands</td>
<td>• Adding and Multiplying Expressions</td>
</tr>
<tr>
<td></td>
<td>• Selecting Expression Operands</td>
</tr>
<tr>
<td></td>
<td>• Mapping a Command over a Set or List</td>
</tr>
<tr>
<td></td>
<td>• Mapping a Binary Command over Two Lists or Vectors</td>
</tr>
<tr>
<td>Procedures - Maple programs</td>
<td>• Defining and Running Simple Procedures</td>
</tr>
<tr>
<td></td>
<td>• Procedures with Inputs</td>
</tr>
<tr>
<td></td>
<td>• Procedure Return Values</td>
</tr>
<tr>
<td></td>
<td>• Displaying Procedure Definitions</td>
</tr>
<tr>
<td></td>
<td>• Displaying Maple Library Procedure Definitions</td>
</tr>
<tr>
<td></td>
<td>• Modules</td>
</tr>
</tbody>
</table>
8.2 Flow Control

Two basic programming constructs in Maple are the if statement, which controls the conditional execution of statement sequences, and the for statement, which controls the repeated execution of a statement sequence.

Conditional Execution (if Statement)

You can specify that Maple perform an action only if a condition holds. You can also perform an action, from a set of many, depending on which conditions hold.

Using the if statement, you can execute one statement from a series of statements based on a boolean (true, false, or FAIL) condition. Maple tests each condition in order. When a condition is satisfied, Maple executes the corresponding statement, and then exits the if statement.

Syntax

The if statement has the following syntax.

```plaintext
> if conditional_expression1 then
    statement_sequence1
elif conditional_expression2 then
    statement_sequence2
elif conditional_expression3 then
    statement_sequence3
...
else
    statement_sequenceN
end if;
```

The conditional expressions (conditional_expression1, conditional_expression2, ...) can be any boolean expression. You can construct boolean expressions using:

- Relational operators - <, <=, =, >=, >, <>
• Logical operators - **and**, **or**, **xor**, **implies**, **not**

• Logical names - **true**, **false**, **FAIL**

The statement sequences \((\text{statement\_sequence}_1, \text{statement\_sequence}_2, \ldots, \text{statement\_sequence}_N)\) can be any sequence of Maple statements, including **if** statements.

The **elif** clauses are optional. You can specify any number of **elif** clauses.

The **else** clause is optional.

**Simple if Statements**

The simplest **if** statement has only one conditional expression.

\[
> \text{if conditional\_expression then} \\
> \quad \text{statement\_sequence} \\
> \text{end if};
\]

If the conditional expression evaluates to **true**, the sequence of statements is executed. Otherwise, Maple immediately exits the **if** statement.

For example:

\[
> x := 1173:
\]

\[
> \text{if not isprime(x) then} \\
> \quad \text{ifactor(x)}; \\
> \text{end if;}
\]

\[
(3) (17) (23)
\]

**else Clause**

In a simple **if** statement with an **else** clause, if the evaluation of the conditional expressions returns **false** or **FAIL**, Maple executes the statement sequence in the **else** clause.
For example:

> if false then
    "if statement";
else
    "else statement";
end if;

"else statement"

elif Clauses

In an if statement with elif clauses, Maple evaluates the conditional expressions in order until one returns true. Maple executes the corresponding statement sequence, and then exits the if statement. If no evaluation returns true, Maple exits the if statement.

> x := 11:

> if not type(x, integer) then
    printf("%a is not an integer.", x);
elif x >= 10 then
    printf("%a is an integer with more than one digit.", x);
elif x >= 0 then
    printf("%a is an integer with one digit.", x);
end if;

11 is an integer with more than one digit.

Order of elif Clauses An elif clause's statement sequence is executed only if the evaluation of all previous conditional expressions returns false or FAIL, and the evaluation of its conditional expression returns true. This means that changing the order of elif clauses may change the behavior of the if statement.

In the following if statement, the elif clauses are in the wrong order.
> if not(type(x, integer)) then
    printf("%a is not an integer.", x);
elif x >= 0 then
    printf("%a is an integer with one digit.", x);
elif x >= 10 then
    printf("%a is an integer with more than one digit.", x);
end if;

11 is an integer with one digit.

**elif and else Clauses**

In an if statement with elif and else clauses, Maple evaluates the conditional expressions in order until one returns true. Maple executes the corresponding statement sequence, and then exits the if statement. If no evaluation returns true, Maple executes the statement sequence in the else clause.

> x := -12:

> if not type(x, integer) then
    printf("%a is not an integer.", x);
elif x >= 10 then
    printf("%a is an integer with more than one digit.", x);
elif x >= 0 then
    printf("%a is an integer with one digit.", x);
else
    printf("%a is a negative integer.", x);
end if;

-12 is a negative integer.

For more information on the if statement, refer to the ?if help page.

**Repetition (for Statement)**

Using repetition statements, you can repeatedly execute a statement sequence. You can repeat the statements in three ways.
• Until a counter variable value exceeds a limit (for/from loop)
• For each operand of an expression (for/in loop)
• Until a boolean condition does not hold (while loop)

**for/from Loop**

The `for/from` loop statement repeats a statement sequence until a counter variable value exceeds a limit.

**Syntax**

The `for/from` loop has the following syntax.

```
> for counter from initial by increment to final do
   statement_sequence
end do;
```

The behavior of the `for/from` loop is:

1. Assign the *initial* value to the name *counter*.
2. Compare the value of *counter* to the value of *final*. If the *counter* value *exceeds* the *final* value, exit the loop. (This is the *loop bound test*.)
3. Execute the *statement_sequence*.
4. Increment the *counter* value by the value of *increment*.
5. Repeat steps 2 to 4, until Maple exits the loop.

The *from*, *by*, and *to* clauses are optional and can be in any order between the *for* clause and the *do* keyword.

Table 8.1 lists the default clause values.
Table 8.1: Default Clause Values

<table>
<thead>
<tr>
<th>Clause</th>
<th>Default Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>from initial</td>
<td>1</td>
</tr>
<tr>
<td>by increment</td>
<td>1</td>
</tr>
<tr>
<td>to final</td>
<td>infinity (∞)</td>
</tr>
</tbody>
</table>

Examples

The following loop returns the square root of the integers 1 to 5 (inclusive).

```maple
> for n to 5 do
    evalf(sqrt(n));
    end do;
```

```
1.
1.414213562

1.732050808

2.
2.236067977

When the value of the counter variable n is strictly greater than 5, Maple exits the loop.

```maple
> n;
```

```
6
```

The previous loop is equivalent to the following for/from statement.
The by value can be negative. The loop repeats until the value of the counter variable is strictly less than the final value.

```plaintext
> for n from 1 by 1 to 5 do
    evalf(sqrt(n));
end do;
```

7
5
3
2

> n;

```plaintext
> for n from 10 by -1 to 3 do
    if isprime(n) then
        print(n);
    end if;
end do;
```

for/in Loop

The for/in loop statement repeats a statement sequence for each component (operand) of an expression, for example, the elements of a list.

Syntax

The for/in loop has the following syntax.

```plaintext
> for variable in expression do
    statement_sequence
end do;
```
The **for** clause must appear first.

The behavior of the **for/in** loop is:

1. Assign the first operand of *expression* to the name *variable*.
2. Execute the *statement_sequence*.
3. Assign the next operand of *expression* to *variable*.
4. Repeat steps 2 and 3 for each operand in *expression*. If there are no more operands, exit the loop. (This is the *loop bound test*.)

**Example**

The following loop returns a floating-point approximation to the *sin* function at the angles (measured in degree) in the list *L*.

```latex
L := [23.4, 87.2, 43.0, 99.7]:

> for i in L do
  >   evalf(sin(i*Pi/180));
  > end do;
```

```
0.3971478907
0.9988061374
0.6819983602
0.9857034690
```

**while Loop**

The **while** loop repeats a statement sequence until a boolean expression does not hold.
Syntax

The **while** loop has the following syntax.

```plaintext
> while conditional_expression do
  statement_sequence
end do;
```

A **while** loop repeats until its boolean expression *conditional_expression* evaluates to **false** or **FAIL**. For more information on boolean expressions, see *Conditional Execution (if Statement)* (page 322).

Example

The following loop computes the digits of 872, 349 in base 7 (in order of *increasing* significance).

```plaintext
> x := 872349:

> while x > 0 do
  irem(x, 7);
  x := iquo(x, 7);
end do;

2
x := 124621
0
x := 17803
2
x := 2543
```
To perform such conversions efficiently, use the `convert/base` command.

```plaintext
> convert(872349, base, 7);

[2, 0, 2, 2, 6, 2, 0, 1]
```

For information on non-base 10 numbers, see *Non-Base 10 Numbers* (page 74).

**General Loop Statements**

You can include a `while` statement in a `for/from` or `for/in` loop.

The general `for/from` loop has the following syntax.
for counter from initial by increment to final
while conditional_expression do
    statement_sequence
end do;

The general for/in loop has the following syntax.

> for variable in expression
    while conditional_expression do
        statement_sequence
    end do;

After testing the loop bound condition at the beginning of each iteration of the for loop, Maple evaluates conditional_expression.

- If conditional_expression evaluates to false or FAIL, Maple exits the loop.
- If conditional_expression evaluates to true, Maple executes statement_sequence.

Infinite Loops

You can construct a loop for which there is no exit condition, for example, a while loop in which the conditional_expression always evaluates to true. This is called an infinite loop. Maple indefinitely executes an infinite loop unless it executes a break, quit, or return statement or you interrupt the computation. For more information, refer to the ?break, ?quit, ?return, and ?interrupt help pages.

Additional Information

For more information on the for statement and looping, refer to the ?do help page.
8.3 Iterative Commands

Maple has commands that perform common selection and repetition operations. These commands are more efficient than similar algorithms implemented using library commands. Table 8.2 lists the iterative commands.

Table 8.2: Iterative Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>seq</td>
<td>Create sequence</td>
</tr>
<tr>
<td>add</td>
<td>Compute numeric sum</td>
</tr>
<tr>
<td>mul</td>
<td>Compute numeric product</td>
</tr>
<tr>
<td>select</td>
<td>Return operands that satisfy a condition</td>
</tr>
<tr>
<td>remove</td>
<td>Return operands that do not satisfy a condition</td>
</tr>
<tr>
<td>selectremove</td>
<td>Return operands that satisfy a condition and separately return operands that do not satisfy a condition</td>
</tr>
<tr>
<td>map</td>
<td>Apply command to the operands of an expression</td>
</tr>
<tr>
<td>zip</td>
<td>Apply binary command to the operands of two lists or vectors</td>
</tr>
</tbody>
</table>

Creating a Sequence

The `seq` command creates a sequence of values by evaluating a specified expression over a range of index values or the operands of an expression. See Table 8.3.

Table 8.3: The seq Command

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
</table>
| `seq(expression, name = initial .. final);` | `> seq(exp(x), x=-2..0);` \[
|                         | `e^2, e^1, 1` |
Adding and Multiplying Expressions

The `add` and `mul` commands add and multiply sequences of expressions over a range of index values or the operands of an expression. See Table 8.4.

Table 8.4: The add and mul Commands

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
</table>
| `seq(expression, name in expression);` | > `seq(u, u in [Pi/4, Pi^2/2, 1/Pi]);`  
\[
\frac{\pi}{4}, \frac{\pi^2}{2}, \frac{1}{\pi}
\] |
| `add(expression, name = initial .. final);`  
`mul(expression, name = initial .. final);` | > `add(exp(x), x = 2..4);`  
\[e^2 + e^3 + e^4\]  
> `mul(2*x, x = 1 .. 10);`  
3715891200 |
| `add(expression, name in expression);`  
`mul(expression, name in expression);` | > `add(u, u in [Pi/4, Pi/2, Pi]);`  
\[
\frac{7\pi}{4}
\]  
> `mul(u, u in [Pi/4, Pi/2, Pi]);`  
\[
\frac{\pi^3}{8}
\] |

The endpoints of the index range (initial and final) in the `add` and `mul` calling sequence must evaluate to numeric constants. For information on symbolic sums and products, refer to the `?sum` and `?product` help pages.
Selecting Expression Operands

The `select`, `remove`, and `selectremove` commands apply a boolean-valued procedure or command to the operands of an expression. For information on operands, refer to the `?op` help page.

- The `select` command returns the operands for which the procedure or command returns `true`.
- The `remove` command returns the operands for which the procedure or command returns `false`.
- The `selectremove` command returns two expressions of the same type as the input expression.
  - The first consists of the operands for which the procedure or command returns `true`.
  - The second consists of the operands for which the procedure or command returns `false` or `FAIL`.

See Table 8.5.

For information on Maple procedures, see *Procedures* (page 338).

Table 8.5: The select, remove, and selectremove Commands

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>select(proc_cmd, expression);</code></td>
<td><code>&gt; select(issqr, {198331, 889249, 11751184, 9857934});</code></td>
</tr>
<tr>
<td></td>
<td>{889249, 11751184}</td>
</tr>
<tr>
<td><code>remove(proc_cmd, expression);</code></td>
<td><code>&gt; remove(var -&gt; degree(var) &gt; 3, 2*x^3*y - y^3*x + z);</code></td>
</tr>
<tr>
<td></td>
<td>z</td>
</tr>
</tbody>
</table>
Calling Sequence Syntax | Examples
---|---
selectremove(proc_cmd, expression); | > selectremove(x -> evalb(x > round(x)), [sin(0.), sin(1.), sin(3.)]);
 | \[0.1411200081, 0., 0.8414709848\]

For information on optional arguments to the selection commands, refer to the ?select help page.

**Mapping a Command over a Set or List**

The map command applies a name, procedure, or command to each element in a set or list. See Table 8.6.

**Table 8.6: The map Command**

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>map(name_proc_cmd, expression);</td>
<td>&gt; map(f, {a, b, c}); {f(a), f(c), f(b)}</td>
</tr>
<tr>
<td></td>
<td>&gt; map(u -&gt; int(cos(x), x = 0 .. u), [/Pi/4, \Pi/7, \Pi/3.0]); [\sqrt{2}/2, \cos\left(\frac{5\pi}{14}\right), 0.8660254038]</td>
</tr>
</tbody>
</table>

For information on mapping over the operands of other expressions, optional arguments to the map command, and other mapping commands, refer to the ?map help page.

**Mapping a Binary Command over Two Lists or Vectors**

The zip command applies a name or binary procedure or command component-wise to two lists or vectors.
By default, the length of the returned object is that of the shorter list or vector. If you specify a value as the (optional) fourth argument, it is used as the value of the missing elements of the shorter list or vector. In this case, the length of the return value is that of the longer list or vector. See Table 8.7.

Table 8.7: The zip Command

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>zip(proc_cmd, a, b);</td>
<td>&gt; zip(f, [i, j], [k, l]);</td>
</tr>
<tr>
<td>zip(proc_cmd, a, b, fill);</td>
<td><img src="image" alt="Example" /></td>
</tr>
<tr>
<td>zip(AiryAi, [1, 2], [0], 1);</td>
<td></td>
</tr>
</tbody>
</table>

For more information on the zip command, refer to the ?zip help page.

**Additional Information**

For more information on looping commands, refer to the corresponding command help page.
8.4 Procedures

A Maple procedure is a program consisting of Maple statements. Using procedures, you can quickly execute the contained sequence of statements.

Defining and Running Simple Procedures

To define a procedure, enclose a sequence of statements between \texttt{proc(...)} and \texttt{end proc} statements. In general, you assign a procedure definition to a name.

The following procedure returns the square root of 2.

\begin{verbatim}
> p := proc() sqrt(2); end proc;
\end{verbatim}

\begin{verbatim}
p := proc () sqrt(2) end proc
\end{verbatim}

\textbf{Note:} Maple returns the procedure definition.

To improve readability of procedures, it is recommended that you define a procedure using multiple lines, and indent the lines using space characters. To begin a new line (without evaluating the incomplete procedure definition), press \texttt{Shift+Enter}. When you have finished entering the procedure, press \texttt{Enter} to create the procedure.

For example:

\begin{verbatim}
> p := proc()
> sqrt(2);
> end proc:
\end{verbatim}

To run the procedure \texttt{p}, enter its name followed by parentheses (\texttt{( )}).

\begin{verbatim}
> p();
\end{verbatim}

\begin{verbatim}
\sqrt{2}
\end{verbatim}
Procedures with Inputs

You can define a procedure that accepts user input. In the parentheses of the proc statement, specify the parameter names. For multiple parameters, separate the names with commas.

\[
\text{geometric\_mean} := \text{proc}(x, y) \\
\text{\hspace{1cm}} \text{sqrt}(x*y); \\
\text{\hspace{1cm}} \text{end proc:}
\]

When the user runs the procedure, the parameter names are replaced by the argument values.

\[
> \text{geometric\_mean}(13, 17);
\]

\[
\sqrt{221}
\]

\[
> \text{geometric\_mean}(13.5, 17.1);
\]

\[
15.19374871
\]

For more information on writing procedures, including options and local and global variables, refer to the ?procedure help page.

Procedure Return Values

When you run a procedure, Maple returns only the last statement result value computed. Maple does not return the output for each statement in the procedure. It is irrelevant whether you use semicolons or colons as statement separators.

\[
> p := \text{proc}(a, b) \\
\text{\hspace{1cm}} a + b; \\
\text{\hspace{1cm}} a - b; \\
\text{\hspace{1cm}} \text{end proc:}
\]
Displaying Procedure Definitions

Unlike simple Maple objects, you cannot display the value of a procedure by entering its name.

\[ > \text{geometric\_mean}; \]

\text{geometric\_mean}

You must evaluate the name of the procedure using the \text{print} (or \text{eval}) command.

\[ > \text{print(geometric\_mean)}; \]

\text{proc } (x, y) \sqrt{x}*y \text{ end proc}

Displaying Maple Library Procedure Definitions

Maple procedure definitions are a valuable learning tool. To learn how to program in Maple, it is recommended that you examine the procedures available in the Maple library.

By default, the \text{print} command returns only the \text{proc} and \text{end proc} statements and (if present) the description fields of a Maple procedure.

\[ > \text{print(assign)}; \]

\text{proc } (a) \text{ ... end proc}

To display a Maple library procedure definition, first set the value of the \text{interface verboseproc} option to 2. Then re-execute the \text{print} calling sequence. See Figure 8.1.
8.4 Procedures

> interface('verboseproc' = 2):

> print(assign);
proc (a)

  option Copyright (c) 1990 by Waterloo Maple Inc. All rights reserved.,
local;

  if 1 <= nargs and type(a, ('::', 'name', 'function')) then
    a := args[2 .. -1]
  elif nargs = 1 then
    if type(a, ('::', 'name', 'function') = 'anything') then
      'assign/apply_algebraic'(op(a))
    elif type(a, '=') then
      if type(lhs(a), ('list', ('::', 'name', 'function'))) then
        if ncps(lhs(a)) = ncps(rhs(a)) then
          zip('assign/apply_algebraic', lhs(a), rhs(a))
        else
          error "ambiguous multiple assignment"
        end if
      else
        error "invalid arguments"
      end if
    elif type(a, ('list', 'set')) then
      map(procname, a)
    else
      error "invalid arguments"
    end if
  else
    seq(procname(i), i = args)
  end if;
NULL
end proc

Figure 8.1: Displaying assign Procedure
**Modules**

Maple procedures associate a sequence of commands with a single command. The module, a more complex programming structure, allows you to associate related procedures and data.

A key feature of modules is that they export variables. This means that the variables are available outside the module in which they are created. Most Maple packages are implemented as modules. The package commands are exports of the module.

For more information on modules, refer to the `?module` help page.
9 Maplets

A Maplet is a graphical user interface that provides interactive access to the Maple engine through buttons, text regions, slider bars, and other visual interfaces. You can design custom Maplet applications to use and share with colleagues or students, or you can take advantage of the built-in Maplets that cover numerous academic and specialized topics. For information on some of the built-in Maplets, see Assistants and Tutors (page 26), Teaching and Learning with Maple (page 178), or Ordinary Differential Equations (ODEs) (page 88). Other methods of interaction with Maple are described in the Maple Getting Started Guide and throughout this book.

9.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simple Maplet - Illustrating a simple Maplet</td>
<td>• Define and Run a Simple Maplet</td>
</tr>
<tr>
<td>Using Maplets - Methods for launching a Maplet</td>
<td>• Maplet File</td>
</tr>
<tr>
<td></td>
<td>• Maple Document</td>
</tr>
<tr>
<td>Authoring Maplets - Methods for authoring and saving a Maplet</td>
<td>• Maplet Builder</td>
</tr>
<tr>
<td></td>
<td>• Maplets Package</td>
</tr>
<tr>
<td></td>
<td>• Saving</td>
</tr>
</tbody>
</table>

9.2 Simple Maplet

A Maplet application can be defined using the commands in the Maplets[Elements] package and then launched using the Maplets[Display] command. The following commands define and run a very simple Maplet application that contains the text string "Hello World".

```maple
> with(Maplets[Elements]):
```
> MySimpleMaplet:= Maplet(["Hello World"]):

> Maplets[Display](MySimpleMaplet):

Figure 9.1: A Simple Maplet

For more information on creating Maplets, including an overview of the point-and-click Maplet Builder Assistant, see Authoring Maplets (page 345).

9.3 Using Maplets

Maplet applications are launched by executing Maplet code. Maplet code can be saved in a Maplet (.maplet) file or Maple document (.mw).

Maplet File

To launch a Maplet application saved as a Maplet file:

- In Windows, double-click the file from a Windows file browser.
- In UNIX and on Macintosh, use the command-line interface. At the command-line, enter `maple -q maplet_filename`.

To view and edit the Maplet code contained within the .maplet file:

1. Start Maple.
2. From the File menu, select Open. Maple displays the Open dialog.
3. In the Files of Type drop-down list, select .maplet.
4. Navigate to the location of the .maplet file and select the file.
5. Click Open.
Maple Document

To launch a Maplet application for which the Maple code is contained in a Maple document, you need to execute the Maplet code. To display the Maplet application, you must use the `Maplets[Display]` command. **Note:** The Maplet code may be quite large if the Maplet application is complex. In this case, execute the document to ensure user-defined procedures that are referenced in the Maplet application are also defined.

**Typical procedure:**

1. If present, evaluate user-defined procedures.

   `Myproc:=proc...`


   `with( Maplets[Elements] );`

3. Evaluate the Maplet definition.

   `Maplet_name:=Maplet( Maplet_definition );`

4. Display the Maplet application.

   `Maplets[Display]( Maplet_name );`

**Important:** When a Maplet application is running, you cannot interact with the Maple document.

9.4 Authoring Maplets

When authoring Maplets, you can use the **Maplet Builder** (GUI-based) or the **Maplets** package (syntax-based). The **Maplet Builder** allows you to drag and drop buttons, sliders, text regions, and other elements to define the Maplet application and set the element properties to perform an action upon selection or update of the element. The **Maplet Builder** is designed to create...
simple Maplets. The **Maplets** package offers more capabilities, control and options when designing complicated Maplet applications.

Designing a Maplet application is similar to constructing a house. When building a house, you first construct the skeletal structure (that is, foundation, floors, and walls) and then proceed to add the windows and doors. Constructing a Maplet is no different. First define the rows and columns of the Maplet application and then proceed to add the body elements (for example, buttons, text fields, and plotter regions).

**Maplet Builder**

To start the **Maplet Builder**:

- From the **Tools** menu, select **Assistants**, and then **Maplet Builder**.

![Maplet Builder Interface](image)

**Figure 9.2: Maplet Builder Interface**
The **Maplet Builder** is divided into four different panes.

- The **Palette** pane displays palettes, which contain Maplet elements, organized by category. For a description of the elements, see the `?MapletBuilder/Palette` help page. The **Body** palette contains the most popular elements.

- The **Layout** pane displays the visual elements of the Maplet.

- The **Command** pane displays the commands and corresponding actions defined in the Maplet.

- The **Properties** pane displays the properties of an instance of a defined element in the Maplet.
Design a Maplet Using the Maplet Builder

In this example, shown in Figure 9.3, the Maplet user enters a function and plots the result.

![Maplet Image]

**Figure 9.3: Image of the Maplet**

![Body Elements]

**Figure 9.4: Body Elements Used When Defining This Maplet**
Define the number of rows in the Maplet

1. In the Properties pane:
   
   a. In the drop-down list, select **BoxColumn1**.
   
   b. Change the **numrows** field to 2.

![Figure 9.5: Define the Number of Rows in the Maplet](image-url)
Add a plot region to row 1

1. From the **Body** palette, drag the **Plotter** element to the first row in the **Layout** pane.

Figure 9.6: Add a Plot to Row 1
Add columns to row 2

1. In the **Properties** pane:
   a. In the drop-down list, select **BoxRow2**.
   b. Change the **numcolumns** field to **3**.

![Figure 9.7: Add Columns to Row 2](image-url)
Add a label to row 2

1. From the **Body** palette, drag the **Label** element to the left column in the **Layout** pane.

2. In the **Properties** pane:
   
a. In the drop-down list, select **Label1**.
   
b. Change the **caption** field to **Enter a function of x**.
Add a text region to row 2

1. From the **Body** palette, drag the **TextField** element to the middle column. The **TextField** element allows the Maplet user to enter input that can be retrieved in an action.

2. If necessary, resize the Maplet Builder to display the entire **Layout** pane.

---

**Figure 9.9: Add a Text Region to Row 2**
Add a button to row 2

1. From the **Body** palette, drag the **Button** element to the right column in the **Layout** pane.
2. In the **Properties** pane:
   
   a. In the drop-down list, select **Button1**.
   
   b. Change the **caption** field to **Plot**.
   
   c. In the **onclick** property drop-down list, select `<Evaluate>`.

![Figure 9.10: Add a Button to Row 2](image-url)
3. In the **Evaluate Expression** dialog that displays, the **Target** drop-down list contains the defined elements to which you can send information, in this case, **Plotter1** and **TextField1**. The **List** group box, located below the **Expression** group box, displays the defined elements to which you can retrieve information, in this case, **TextField1**.

   a. In the **Target** drop-down list, select **Plotter1**.

   b. In the **Command Form** tab, enter `plot(TextField1, x=-10..10)` in the **Expression** group box. (**Note:** Do not include a semicolon (;) at the end of the plot command). You can also double-click **TextField1** in the **List** group box to insert this element in the command syntax.

   c. Click **Ok**.
Run the Maplet

1. From the **File** menu, select **Run**. You are prompted to save the Maplet. Maplets created with the **Maplet Builder** are saved as `.maplet` files.

2. Click **Yes** and navigate to a location to save this Maplet.

For further information on the **Maplet Builder**, see the `?MapletBuilder` help page. For more examples of designing Maplets using the **Maplet Builder**, see `?MapletBuilder/examples`.

Maplets Package

When designing a complicated Maplet, the **Maplets** package offers greater control. The **Maplets[Elements]** subpackage contains the elements available when designing a Maplet application. After you define the Maplet, use the **Maplets[Display]** command to launch the Maplet.
Example 1 - Design a Maplet Using the Maplets Package

To introduce the structure of designing Maplets using the Maplets package, this example illustrates the equivalent syntax for the Design a Maplet Using the Maplet Builder (page 348).

Load the Maplets[Elements] package.

> with(Maplets[Elements]):

Define the Maplet application. To suppress the display of the data structure associated with the Maplet application, end the definition with a colon.
> PlottingMaplet:=Maplet(
    BoxLayout(
        BoxColumn(
            # First Box Row
            BoxRow(
                # Define a Plot region
                Plotter('reference' = Plotter1)
            ),
            # Second Box Row
            BoxRow(
                # Define a Label
                Label("Enter a function of x "),
                # Define a Text Field
                TextField('reference' = TextField1),
                # Define a Button
                Button(caption="Plot", Evaluate(value = 'plot(TextField1, x = -10..10)', 'target' = Plotter1))
            )
        )
    )
):
Example 2 - Accessing User-Defined Procedures

When designing a Maplet, you can access user-designed procedures and send information bi-directionally to the Maplet. In this example, shown in Figure 9.12, the user enters a function in a MathML editor region, optionally selects a color from a color dialog, and plots the result.

Figure 9.12: Image of the Maplet
User-Defined Procedure and Maplet Code

Define a procedure to be accessed in the Maplet.

```maple
> GetColor:=proc()
    local R, G, B, result;
    use Maplets[Tools] in

    # Convert the color value defined in the Color dialog
    result:=Get(ColorDialog1);
    # The result format is "#RRGGBB" in hexadecimal(base 16)
    # Convert to values in the range 0..1
    R:=convert(result[2..3], 'decimal', 16)/255;
    G:=convert(result[4..5], 'decimal', 16)/255;
    B:=convert(result[6..7], 'decimal', 16)/255;

    # Plot the function entered in the MathMLEditor region
    plot(MathML:-Import(Get(MathMLEditor1)), x=0..10,
         color=COLOR(RGB, R, G, B));

    end use:
end proc:
```

Load the Elements package.

```maple
> with(Maplets[Elements]):
```

Define the Maplet application.
Display the Maplet

> Maplets[Display](PlottingMaplet2);

For more information on the Maplets package, refer to the ?MapletsPackage help page. For more examples of designing Maplets using the Maplets package, see the ?Maplets/Roadmap help page.
Saving

When saving a Maplet, you can save the document as an .mw file or you can export the document as a .maplet file.

Maple Document

To save the Maplet code as an .mw file:

1. From the File menu, select Save.
2. Navigate to the save location.
3. Enter a filename.
4. Click Save.

If the document contains only Maplet code, it is recommended that you export the document as a .maplet file.

Maplet File

To export the Maplet code as a .maplet file:

1. From the File menu, select Export As.
2. In the Files of Type drop-down list, select Maplet.
3. Navigate to the export location.
4. Enter the filename.
5. Click Save.
10 Input, Output, and Interacting with Other Products

10.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Writing to Files - Saving to Maple file formats | • Saving Data to a File  
• Saving Expressions to a File |
| Reading from Files - Opening Maple files | • Reading Data from a File  
• Reading Expressions from a File |
| Exporting to Other Formats - Exporting documents in file formats supported by other software | • Exporting Documents  
• MapleNet  
• Maple T.A. |
| Connectivity - Using Maple with other programming languages and software | • Translating Maple Code to Other Programming Languages  
• Accessing External Products from Maple  
• Accessing Maple from External Products |

10.2 Writing to Files

Maple supports file formats in addition to the standard .mw file format.

After using Maple to perform a computation, you can save the results to a file for later processing with Maple or another program.

Saving Data to a File

If the result of a Maple calculation is a long list or a large array of numbers, you can convert it to Matrix form and write the numbers to a file using the ExportMatrix command. This command writes columns of numerical data
to a file, allowing you to import the numbers into another program. To convert a list or a list of lists to a Matrix, use the \texttt{Matrix} constructor. For more information, refer to the \texttt{?Matrix} help page.

\[
L := \begin{bmatrix}
-81 & -98 & -76 & -4 & 29 \\
-38 & -77 & -72 & 27 & 44 \\
-18 & 57 & -2 & 8 & 92 \\
87 & 27 & -32 & 69 & -31 \\
33 & -93 & -74 & 99 & 67
\end{bmatrix}
\]

\texttt{ExportMatrix("matrixdata.txt", L)} :

If the data is a Vector or any object that can be converted to type Vector, use the \texttt{ExportVector} command. To convert lists to Vectors, use the \texttt{Vector} constructor. For more information, refer to the \texttt{?Vector} help page.

\texttt{R := [3, 3.1415, -65, 0]}

\[
R := [3, 3.1415, -65, 0]
\]

\texttt{V := Vector(R)}

\[
V := \begin{bmatrix}
3 \\
3.1415 \\
-65 \\
0
\end{bmatrix}
\]

\texttt{ExportVector("vectordata.txt", V)} :

You can extend these routines to write more complicated data, such as complex numbers or symbolic expressions. For more information, refer to the \texttt{?ExportMatrix} and \texttt{?ExportVector} help pages.

For more information on matrices and vectors, see \textit{Linear Algebra (page 133)}. 
Saving Expressions to a File

If you construct a complicated expression or procedure, you can save them for future use in Maple. If you save the expression or procedure in the Maple internal format, Maple can retrieve it more efficiently than from a document. Use the `save` command to write the expression to a `.m` file. For more information on Maple internal file formats, refer to the `?file` help page.

\[
qbinomial := (n, k) \rightarrow \prod_{i=n-k+1}^{n} \frac{(1-q^i)}{\prod_{j=1}^{k} (1-q^j)}
\]

In this example, small expressions are used. In practice, Maple supports expressions with thousands of terms.

\[
expr := qbinomial(10, 4)
\]

\[
expr := \frac{(1-q^7)(1-q^8)(1-q^9)(1-q^{10})}{(1-q)(1-q^2)(1-q^3)(1-q^4)}
\]

\[
expr := (q^6 + q^5 + q^4 + q^3 + q^2 + q + 1)(q^4 + 1)(q^6 + q^3 + 1)(q^8 + q^6 + q^4 + q^2 + 1)
\]

You can save these expressions to the file `qbinom.m`.

\[
\text{save } qbinomial, expr, nexpr, "qbinom.m"
\]

Clear the memory using the `restart` command and retrieve the expressions using the `read` command.

\[
\text{restart}
\]
> read "qbinom.m"

> expr

\[
\frac{(1 - q^7)(1 - q^8)(1 - q^9)(1 - q^{10})}{(1 - q)(1 - q^2)(1 - q^3)(1 - q^4)}
\]

For more information on writing to files, refer to the help page.

### 10.3 Reading from Files

The most common reason for reading files is to load data, for example, data generated in an experiment. You can store data in a text file, and then read it into Maple using the **Import Data Assistant**.

#### Reading Data from a File

**Import Data Assistant**

If you generate data outside Maple, you must read it into Maple before manipulating it. This data can be an image, a sound file, or columns of numbers in a text file. You can import this external data into Maple using the **Import Data Assistant**.

**To launch the Import Data Assistant:**

- From the **Tools** menu, select **Assistants**, and then **Import Data**.
- Using the **Select Data Source** dialog, select the data file to import.
Figure 10.1: Import Data Assistant (Detail)

From the main window, you can preview the selected file, and specify the source format, source form, and behavior on close. You can also select a different file to be imported. Additional help is available from the Help menu of the Import Data window.

ImportMatrix Command

The Import Data Assistant provides a graphical interface to the Import-Matrix command. For more information, including options not available in the assistant, refer to the ?ImportMatrix help page.

Reading Expressions from a File

You can write Maple programs in a text file using a text editor, and then import the file into Maple. You can paste the commands from the text file into your document or you can use the read command.
When you read a file with the `read` command, Maple treats each line in the file as a command. Maple executes the commands and displays the results in your document but it does not, by default, insert the commands from the file in your document.

For example, the file `ks.tst` contains the following Maple commands.

\[
S := n -> \sum_{\beta=1}^{n} \binom{n}{\beta} \left( \frac{(2\beta)!}{2^\beta} - \beta! \beta \right);
\]

\[S(19);\]

When you read the file, Maple displays the results but not the commands.

> `read "ks.tst"`

\[
S := n \rightarrow \sum_{\beta=1}^{n} \binom{n}{\beta} \left( \frac{(2\beta)!}{2^\beta} - \beta! \beta \right)
\]

1024937361666644598071114328769317982974

If you set the `interface echo` option to 2, Maple inserts the commands from the file into your document.

> `interface(echo = 2) ;`

> `read "ks.tst"`

> \[
S := n -> \sum_{\beta=1}^{n} \binomial{n}{\beta} \left( \frac{(2\beta)!}{2^\beta} - \beta! \beta \right)
\]
> S(19);
1024937361666644598071114328769317982974

For more information, refer to the \texttt{?read} and \texttt{?interface} help pages.

## 10.4 Exporting to Other Formats

### Exporting Documents

You can save your documents by selecting \texttt{Save} or \texttt{Save As} from the \texttt{File} menu. By selecting \texttt{Export As} from the \texttt{File} menu, you can also export a document in the following formats: HTML, LaTeX, Maple input, Maplet application, Maple text, plain text, and Rich Text Format. This allows you to access your work outside Maple.

### HTML

The \texttt{.html} file that Maple generates can be loaded into any HTML browser. Exported mathematical content can be displayed in one of the following formats: GIF, MathML 2.0 Presentation, MathML 2.0 Content, or Maple Viewer, and is saved in a separate folder. MathML is the Internet standard, sanctioned by the World Wide Web Consortium (W3C), for the communication of structured mathematical formulae between applications. For more information about MathML, refer to the \texttt{?MathML} help page.

Maple documents that are exported to HTML translate into multiple documents when using frames. If the frames feature is not selected, Maple creates only one page that contains the document contents.

### LaTeX

The \texttt{.tex} file generated by Maple is ready for processing by LaTeX. All distributions of Maple include the necessary style files. By default, the LaTeX style files are set for printing the \texttt{.tex} file using the \texttt{dvips} printer driver. You can change this behavior by specifying an option to the \texttt{\usepackage} LaTeX

command in the preamble of your .tex file. For more information, refer to the ?exporttoLaTeX help page.

**Maple Input**

You can export a Maple document as Maple input so that it can be loaded using the Maple Command-line version.

**Important:** When exporting a document as Maple input for use in Command-line Maple, your document must contain explicit semicolons in 1-D Math input. If not, the exported .mpl file will not contain semicolons, and Command-line Maple will generate errors.

**Maplet Application**

The Export as Maplet facility saves a Maple document as a .maplet file, so that you can run it using the command-line interface or the MapletViewer. The MapletViewer is an executable program that can launch saved Maplet applications. It displays and runs Maplet applications independently of the Maple Worksheet interface.

**Important:** When exporting a document as a Maplet Application for use in Command-line Maple or the MapletViewer, your document must contain explicit semicolons. If not, the exported .maplet file will not contain semicolons, and Command-line Maple and the MapletViewer will generate errors.

For information on using the MapletViewer, see *Using Maplets* (page 344).

**Maple Text**

Maple text is marked text that retains the distinction between text, Maple input, and Maple output. Thus, you can export a document as Maple text, send the text file by email, and the recipient can import the Maple text into a Maple session and regenerate the computations in the original document.

**Plain Text**

Export a Maple document as plain text so that you can open the text file in another application.
Rich Text Format (RTF)

The .rtf file generated by Maple can be loaded into any word processor that supports RTF.

Summary of Translation

Table 10.1: Summary of Content Translation When Exporting to Different Formats

<table>
<thead>
<tr>
<th>Content</th>
<th>HTML</th>
<th>LaTeX</th>
<th>Maple Input</th>
<th>Maplet Application</th>
<th>Maple Text</th>
<th>Plain Text</th>
<th>Rich Text Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Maintained</td>
<td>Maintained</td>
<td>Preceded by #</td>
<td>Preceded by #</td>
<td>Preceded by #</td>
<td>Maintained</td>
<td>Maintained</td>
</tr>
<tr>
<td>1-D Math</td>
<td>Maintained</td>
<td>Maintained</td>
<td>Maintained</td>
<td>Preceded by &gt;</td>
<td>Preceded by &gt;</td>
<td>Static image</td>
<td></td>
</tr>
<tr>
<td>2-D Math</td>
<td>GIF or MathML</td>
<td>1-D Math or LaTeX 2e</td>
<td>1-D Math (if possible)</td>
<td>1-D Math (if possible)</td>
<td>1-D Math or character-based typesetting</td>
<td>1-D Math or character-based typesetting</td>
<td>Static image</td>
</tr>
<tr>
<td>Plot</td>
<td>GIF</td>
<td>Postscript file</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Static image</td>
</tr>
<tr>
<td>Animation</td>
<td>Animated GIF</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
</tr>
<tr>
<td>Hidden content</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
</tr>
<tr>
<td>Manually inserted page break</td>
<td>Not supported</td>
<td>Not supported</td>
<td>Not supported</td>
<td>Not supported</td>
<td>Not supported</td>
<td>RTF page break object</td>
<td></td>
</tr>
<tr>
<td>Content</td>
<td>HTML</td>
<td>LaTeX</td>
<td>Maple Input</td>
<td>Maplet Application</td>
<td>Maple Text</td>
<td>Plain Text</td>
<td>Rich Text Format</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>---------------</td>
<td>--------------</td>
<td>--------------------------</td>
<td>--------------------</td>
<td>------------</td>
<td>------------</td>
<td>------------------</td>
</tr>
<tr>
<td>Hyperlink</td>
<td>Links to help pages become plain text. Links to documents are renamed and converted to HTML links</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
</tr>
<tr>
<td>Embedded image or sketch output</td>
<td>GIF</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Static image</td>
</tr>
<tr>
<td>Spreadsheet</td>
<td>HTML table</td>
<td>LaTeX tables</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>RTF table</td>
</tr>
<tr>
<td>Document style</td>
<td>Approximated by HTML style attributes</td>
<td>LaTeX environments and sections, LaTeX 2e macro calls</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>RTF style</td>
</tr>
</tbody>
</table>

**MapleNet**

**Overview of MapleNet**

Using MapleNet, you can deploy Maple content on the Web. Powered by the Maple computation engine, MapleNet allows you to embed dynamic formulas, models, and diagrams as **live** content in Web pages. The MapleNet software is not included with the Maple software. For more information on MapleNet, visit [http://www.maplesoft.com/maplenet](http://www.maplesoft.com/maplenet).
MapleNet Documents and Maplets

After you upload your Maple documents to the MapleNet server, it can be accessed by anyone in the world using a Web browser. Even if viewers do not have a copy of Maple installed, they can view documents and Maplets, manipulate 3-D plots, and execute code at the click of a button.

Custom Java™ Applets and JavaServer Pages™ Technology

MapleNet provides a programming interface to the Maple math engine so commands can be executed from a Java™ applet or using JavaServer Pages™ technology. Embed MapleNet into your Web application, and let Maple handle the math and visualization.

Maple T.A.

Overview of Maple T.A.

Maple T.A. is a Web-based automated testing system, based on the Maple engine. Instructors can use pre-written questions or create custom question banks and then choose from these questions to form quizzes and assignments. Maple T.A. automatically grades responses as students complete assignments and tests. For more information, visit http://www.maplesoft.com/mapleta.

Exporting Assignments to Maple T.A.

You can use Maple to create graded questions for use in Maple T.A. For information on creating and testing questions, see Creating Graded Assignments (page 271). Using the Maple T.A. export feature, you can create and test Maple T.A. content.

To export the document:

1. From the File menu, select Export As.
2. In the Export As dialog, specify a filename and the Maple T.A. (.zip) file type. The .zip file containing your questions and assignment can be uploaded to Maple T.A. as a course module.
Any document content outside Maple T.A. sections (indicated by green section markers) is ignored by the export process.

For more details, refer to the `?exporttoMapleTA` help page.

### 10.5 Connectivity

#### Translating Maple Code To Other Programming Languages

**Code Generation**

The `CodeGeneration` package is a collection of commands and subpackages that enable the translation of Maple code to other programming languages. Languages currently supported include C, Fortran77, Java, MATLAB®, and Visual Basic®.

For details on Code Generation, refer to the `?CodeGeneration` help page.

#### Accessing External Products from Maple

**External Calling**

External calling allows you to use compiled C, Fortran77, or Java code in Maple. Functions written in these languages can be linked and used as if they were Maple procedures. With external calling you can use pre-written optimized algorithms without the need to translate them into Maple commands. Access to the NAG library routines and other numerical algorithms is built into Maple using the external calling mechanism.

External calling can also be applied to functions other than numerical algorithms. Routines exist that accomplish a variety of non-mathematical tasks. You can use these routines in Maple to extend its functionality. For example, you can link to controlled hardware via a serial port or interface with another program. The Database Integration Toolbox uses external calling to allow you to query, create, and update databases in Maple. For more information, visit [http://www.maplesoft.com/products/toolboxes](http://www.maplesoft.com/products/toolboxes).
For more information on using external calling, refer to the \texttt{?ExternalCalling} help page.

**Mathematica Translator**

The \texttt{MmaTranslator} package provides translation tools for converting Mathematica\textregistered\ expressions, command operations, and notebooks to Maple. The package can translate Mathematica input to Maple input and Mathematica notebooks to Maple documents. The \texttt{Mma} subpackage contains commands that provide translation for Mathematica commands when no equivalent Maple command exists. In most cases, the command achieves the translation through minor manipulations of the input and output of similar Maple commands.

**Note:** The \texttt{MmaTranslator} package does not convert Mathematica programs.

There is a Maplet interface to the \texttt{MmaTranslator} package. For more information, refer to the \texttt{?MmaToMaple} help page.

**Matlab Package**

The \texttt{Matlab} package enables you to call selected MATLAB functions from a Maple session, provided you have MATLAB installed on your system.

For more information, refer to the \texttt{?Matlab} help page.

**Accessing Maple from External Products**

**Microsoft Excel Add-In**

Maple is available as an add-in to Microsoft Excel 2000, Excel 2003, and Excel XP for Windows, and provides the following features.

- Access to Maple commands from Excel
- Ability to copy and paste between Maple and Excel
- Access to a subset of the Maple help pages
Maple Function Wizard to step you through the creation of a Maple function call

To enable the Maple Excel Add-in in Excel 2000, Excel 2003, or Excel XP:

1. From the Tools menu, choose Add-Ins.
2. If the Maple Excel Add-in is not listed:
   - Click Browse and navigate to the directory in which Maple is installed.
   - In the Excel directory, select the WMIMPLEX.xla file.
   - Click OK.
3. Select the Maple Excel Add-in check box.
4. Click OK.

More information is available in the Using Maple in Excel online help file within Excel.

To view this help file:

1. Enable the add-in.
2. From the View menu, select Toolbars, and then Maple.
3. On the Maple toolbar, click the Maple help icon 📖.

OpenMaple

OpenMaple is a suite of functions that allows you to access Maple algorithms and data structures in your compiled C, Java, or Visual Basic programs. (This is the reverse of external calling, which allows access to compiled C, Fortran77, and Java code from Maple.)

To run your application, Maple must be installed. You can distribute your application to any licensed Maple user. For additional terms and conditions on the use of OpenMaple, refer to extern/OpenMapleLicensing.txt in your Maple installation.
For more details on using OpenMaple functions, refer to the ?OpenMaple help page.
Index

Symbols
! toolbar icon, 10
!!! toolbar icon, 10
", 297
%H, 146
%T, 146
&x, 146
', 57, 317
(), 338
->, 56
., 144
1-D Math, 38
 switching to 2-D, 38
2-D Math, 37
 converting to 1-D, 39
 shortcuts, 6
 switching to 1-D, 38
:; 38–39
::, 116
:=, 55
;:, 38–39
<> , 136
<default>, 40, 317
>, 37
[], 142, 286, 288
^, 5, 76
 entering, 76
_, 58
 entering, 58
_ENVAllSolutions environment variable, 82
_ZN~, 82
` , 58
{}
, 287
|, 136
~, 82, 116
A
about command, 117
abs command, 73
absolute value, 73
add
 word to your dictionary, 279
add command, 334
additionally command, 117
algebra, 124
 linear, 133
 polynomial, 124
algsubs command, 312
alignment format, 236
all content, 53
American spelling
 spellcheck, 276
and operator, 323
angle brackets, 136
angles, 308
animations
 creating, 222
 customizing, 228
Applications
 Units Calculator, 98
applications, 33
apply
 character styles, 239
document blocks, 248
paragraph styles, 242
approximation, 68
least-squares, 149
numeric, 313
arguments, 339
arithmetic, 9
  finite-precision, 67
  interval, 110
  matrix and vector, 143
  modular, 73, 75
  polynomial, 124
Arrays, 289
  large, 290
arrow operator, 56
assign command, 87
assigned command, 317
assignment operator (:=), 55
Assistants, 26, 121
  Curve Fitting, 132
  Data Analysis, 171
  Import Data, 366
  menu access, 26
  ODE Analyzer, 88
  Optimization, 167
  Plot Builder, 28, 49, 189
  Unit Converter, 308
assuming command, 116
  adding assumptions, 117
  and procedure variables, 119
  imposing multiple assumptions, 117
  removing assumptions, 118
  setting relationships between variables, 116
  setting variable properties, 116
  testing property, 117
  using with assuming command, 119
  viewing assumptions, 117
assuming command, 116, 118, 162, 307
  additionally option, 119
  and procedure variables, 119
  applying to all names, 119
  using with assume command, 119
Attributes submenu
  character, 235
  paragraph, 236
auto-execute, 273
  repeating, 273
  security levels, 273
Avogadro constant, 105
B
  bar chart, 175
  basis, 149
    vector space, 148
  binary numbers, 74
  Bohr radius, 105
  bold format, 233
  bookmarks
    using, 264
  boolean expressions, 315, 322, 330
  brackets
    angle, 136
  break statement, 332
  browser
    Matrix, 137, 290
    Task, 51
  bullets
    format, 236
    list, 262
  button
    embedding, 268
  by clause, 326
excluding, 327
negative, 328

C
calculus, 151
  multivariate, 164
  Student package, 166
of variations, 166
packages, 164
study guides, 179
teaching, 166, 179
vector, 164
  Student package, 166
canvas
  inserting, 274
canvas style
  sketch pad, 275
caret
  entering, 76
central tendency, 110
character styles
  creating, 240
  description, 239
Cholesky decomposition, 147
choose styles dialog, 245
Classic Worksheet, xiii
tables, 258
coeff command, 130
coefficients
  polynomials, 130
coeffs command, 131
collect command, 130
colon, 38–39
color
  of plots, 219
combine command, 306
  errors option, 113
command completion, 7
  shortcut, 7
Command-line version, xiii
commands, 39
  and task templates, 51
displaying procedures, 340
  iterative, 333
  list, 122
  mapping over set or list, 336
package, 41
top-level, 40
Common Symbols palette, 11
compatibility
  worksheet, 283
complex expressions, 314
comploy command, 132
components
  adding GUI elements, 268
  palette, 268
  properties, 269
computations
  assistants, 48
  commands, 39
  context menus, 46
  errors, 70
    avoiding, 70
  integers, 71
  interrupting, 332
linear algebra, 143
mathematics, 121
numeric, 66
palettes, 44
performing, 65, 121
Real number system, 114
symbolic, 66
syntax-free, 19, 31  
task templates, 51  
tutors, 48  
under assumptions, 116  
  single evaluation, 118  
updating, 9  
  with uncertainty, 112  
  with units, 101  
conditional execution, 322  
constants, 10  
content command, 132  
context  
  of unit, 97  
context menus, 20, 46, 121, 146, 298  
  customizing animations, 228  
equation, 78  
  integer, 46, 71  
  Plot Builder, 28  
convert command, 307  
  base option, 74, 331  
  degrees option, 308  
  mathematical functions, 308  
  polynom option, 160  
  set option, 308  
  temperature option, 99  
  units option, 98, 308  
copy, 236  
correlation, 112  
coulditbe command, 118  
covariance, 112  
cross product, 146  
Curl command, 165  
Curve Fitting  
  Assistant, 132  
polynomialInterpolation command, 132  
cut and paste  
  in tables, 254

D
  D operator, 156  
  Data Analysis Assistant, 171  
  data structures, 10, 285  
    creating, 285  
  Database Integration Toolbox, 374  
  datatype option, 140  
  default content, 53  
  default Maple style set, 247  
degree  
  command, 131  
  polynomials, 130  
denom command, 302  
derivatives, 153  
  directional, 157  
  partial, 154  
  Tutor, 179  
dictionary, 33, 178  
dictionary topic  
    adding hyperlink to, 281  
diff command, 89, 155  
derivative equations  
    ordinary, 88  
    partial, 92  
differentiation, 153  
    with uncertainty, 112  
    with units, 102  
Differentiation Methods Tutor, 180  
Digits environment variable, 69  
dimension, 96, 147  
  base, 96
Directional Derivative Tutor, 157
discrim command, 132
display
  bookmark, 264
  hidden formatting attributes, 238
distribution
  probability, 171
divide command, 126
divisors, 73
document blocks, 31, 247
Document mode, 1
  summary, 30
double colon operator, 116
dsolve command, 92
dsimplify command, 5
email
  adding hyperlink to, 280
embedded components, 268
end do keywords, 326, 328, 330
end if keywords, 322
end proc keywords, 338
environment variables
  _EnvAllSolutions, 82
  Digits, 69
  Order, 160
equation labels, 59
displaying, 59
features, 62
numbering schemes, 61
references to, 59
versus names, 62
with multiple outputs, 61
equations
  solving, 78
    for real solutions, 114
    numerically, 83
    symbolically, 80
    transcendental, 82
errors
  quantities with, 110
Euclidean algorithm, 132
eval command, 311, 340
evalb command, 315
evalc command, 314
evalf command, 69, 83, 108, 111, 313
  with Int command, 163
  with Limit command, 153
evaln command, 317
evaluation
  boolean expressions, 315
  complex expressions, 314
delaying, 317
levels of, 316
Maple expressions, 310
of expression at a point, 310
output below, 8, 21, 31
output inline, 8, 21, 31
updated computations, 9

exact
  computation, 67
  numbers, 66
quantities
  converting to floating-point, 69
example worksheets, 33
execution group, 38
  auto-execute, 272
expand
  command, 306
  document block, 250
  execution group, 251
  series, 159
exponents
  entering, 5
export, 342
  to HTML, 369
  to LaTeX, 369
  to Maple input, 370
  to Maple T.A., 373
  to Maple text, 370
  to Maplet application, 370
  to other formats, 369
  to plain text, 370
  to Rich Text Format, 371
  worksheets, 369
Expression palette, 12
expression sequences, 80, 286
  creating, 333
expressions, 10, 285
  adding, 334
  evaluating, 310
  manipulating, 304
  multiplying, 334
  versus functional operators, 293

F
factor
  integers, 71
  polynomials, 131
  QR factorization, 149
factor command, 131, 305
factored normal form, 309
factorial command, 73
FAIL, 323, 330
false, 323, 330
Faraday constant, 105
files
  image formats, 265
  reading from, 366
  writing to, 363
fill option, 140
finite fields, 75
  solving equations, 94
finite rings, 75
floating-point
  computation, 68
    accuracy, 70
    hardware, 70
    significant digits, 69
  numbers, 67
  rational approximation, 47
Flux command, 165
font color, 233
foot-pound-second (FPS) system, 25, 97
for/from loops, 326
for/in loops, 328
formal power series solutions, 92
format lists
  using paragraph styles, 263
Format menu
  bookmarks, 264
document blocks, 248
  quick formatting, 233
frac command, 118
fractions
  approximating, 22
  entering, 5
frequency plot, 175
Frobenius form
  matrix, 148
from clause, 326
  excluding, 327
fsolve command, 83
full evaluation, 316, 319
Function Composition Tutor, 27
FunctionAdvisor command, 41, 121
functional operators, 14, 292
  differentiating, 156
  plotting, 295
  versus expressions, 293
functions
  converting between, 308
  defining, 14
  defining as functional operators, 292

G
Gaussian elimination, 149
Gaussian integers, 77
GaussInt package, 77
gcd command, 132
gcdex command, 132
Getting Started Guide, 32
Global Optimization Toolbox, 166
global variables, 339
glossiness
  of 3-D plots, 219
go to
  bookmark, 265
gradient, 182
Gradient Tutor, 181
Graphing Tutor
  Maplesoft, xiii
greatest common divisor, 73, 132

H
has command, 300
hastype command, 299
HazardRate command, 174
help
  dictionary, 33
  examples, 33
  pages, 33
  quick, 32
  quick reference card, 32
  task templates, 33
help page
  adding hyperlink to, 281
Hermitian transpose
  matrix and vector, 146
Hessenberg form, 149
hexadecimal numbers, 74
hidden formatting attributes, 238
hide
worksheet content, 266
highlight color, 233
Hilbert Matrix, 149
histogram, 175
hyperlinks
  in worksheet, 279

I
i
  entering, 18, 77
if statement, 322
ifactor command, 71, 73, 306
igcd command, 73
images
  adding hyperlink to, 280
  file format, 265
  inserting, 265
imaginary unit
  entering, 18, 77
implies operator, 323
Import Data Assistant, 366
indent
  format, 236
  list, 262
indeterminates, 303
indets command, 303
indices, 40, 142
inequations
  solving, 78
  for real solutions, 114
  symbolically, 80
infinite loops, 332
infolevel command, 93
input
  1-D Math, 38
  2-D Math, 37
prompt, 37
  separating, 39
  setting default mode, 38
insert
  bookmark, 264
  hyperlink, 280
  images, 265
  row and columns in tables, 253
  section, 237
  sketch pad, 274
  table, 252
instructor resources, 178
Int command, 163
int command, 162
integers
  commands, 73
  computations, 71
  context menu, 46
  factoring, 71
  Gaussian, 77
  modulo m, 75
  solving equations, 93
  solving modular equations, 94
integration, 12, 18, 20, 44, 161
  definite, 162
  functional operators, 296
  indefinite, 161
  iterated, 164
  line, 164, 184
  numeric, 163
  surface, 164
  with units, 102
Interactive Plot Builder Assistant, 28, 49
  creating animations, 223
  creating plots, 189
customizing animations, 228
customizing plots, 215
interface command
 rtablesize option, 139
 verboseproc option, 340
international system (SI), 97
InterquartileRange command, 173
interval arithmetic, 110
iquo command, 73
iroot command, 73
is command, 117
isprime command, 73
isqrt command, 73
italic format, 233

J
 j
 entering, 77
Jordan form, 147

L
 labels, 59
last name evaluation, 317
Layout palette, 11
lcm command, 132
lcoeff command, 130
ldegree command, 131
least-squares, 149
left single quotes, 58
left-hand side, 301
levels of evaluation, 316
lexicographic order, 128
lhs command, 301
Limit command, 153
limit command, 152
limits, 151
multidimensional, 152
line break, 236
line integrals, 184
linear algebra, 133
computations, 143
efficiency, 139, 150
LinearAlgebra package, 148
teaching, 150, 179
linear systems
 solving, 94, 149
LinearAlgebra package, 146
commands, 148
numeric computations, 150
LinearSolve command, 94
lists, 142, 288
 formatting, 262
returning solutions as, 80
local variables, 339
logical operators, 323
loops, 325
general, 331
infinite, 332

M
Macintosh
 command/symbol completion, 7
manuals
 Getting Started Guide, 32
 online, 32
map command, 336
Maple Application Center, 122, 178
Maple Getting Started Guide, 32
Maple Student Center, 179
Maplesoft Graphing Calculator, xiii
Maplesoft Web site, 32, 121
Maplet Builder
launching, 346  
Maplet authoring, 346
Maplets  
adding hyperlink to, 281  
authoring, 345  
Maplet Builder, 346  
Maplets package, 356  
launching  
Maple worksheet, 345  
Maplet file type, 344  
Maplets package  
Display command, 356  
Elements subpackage, 356  
Maplet authoring, 356  
saving  
Maple worksheet, 362  
maplet file, 362  
using, 344
markers  
bookmarks, 264  
displaying, 238  
for document blocks, 247
Math mode, 4  
shortcuts, 6
mathematical functions  
list, 41
mathematics  
computations, 121  
teaching and learning, 178
matrices, 291  
arithmetic, 143  
context menus, 146  
data type, 139, 141  
defining, 133  
efficiency, 139  
filling, 141
Hermitian transpose, 146
image, 139
large, 137
multiplication, 144
operations, 146
random, 140
scalar multiplication, 145
selecting submatrices, 143
shape, 139, 141
transpose, 146
type, 139
Matrix  
Browser, 136–137, 290  
constructor, 141  
data structure, 133  
palette, 12, 94, 133, 139
max command, 73
maximize, 166
maximum, 73
Mean command, 173
merge  
table cells, 254
min command, 73
minimal content, 53
minimize, 166
minimum, 73
mod command, 73
mod operator, 75
modes  
Document, 1
Math, 4
switching between, 4
Text, 4
Worksheet, 1
modify  
character styles, 241
table, 253
modp command, 75
mods command, 75
modular arithmetic, 73, 75
modules, 342
MPS(X) files, 171
msolve command, 94
mul command, 334
multiplication
  implied, 6

N
names, 10, 55
  adding assumptions, 116
  and symbols, 16
  assigned, 317
  assigning values to, 55
  logical, 323
  previously assigned, 318
  protected, 57
  removing assumptions, 118
  reserved, 57
  unassigning, 57, 118, 319
  valid, 58
  versus equation labels, 62
  with assumptions, 116
new style set, 245
nops command, 303
norm command, 132, 147
normal command, 309
normal form, 309
not operator, 323
numbered list, 262
numbers, 10
  exact, 66
  floating-point, 67
  non-base 10, 74
numer command, 302
numeric
  approximation, 313
  computation, 67
numtheory[divisors] command, 73

O
ODE Analyzer Assistant, 88
operands, 303
  selecting, 335
operators, 10
  functional, 292
  logical, 323
  relational, 322
optimization, 166
  efficiency, 169
  plotting, 168
  point-and-click interface, 167
Optimization Assistant, 167
  Plotter, 168
Options dialog, 53
or operator, 323
Order environment variable, 160
ordinary differential equations
  plotting solution, 91
  solving, 88
orthogonal matrix, 149
output
  suppressing, 38
  updating, 31

P
packages, 40
  list, 122
  loading, 42
unloading, 43, 58
warnings, 43
page break, 236
palettes, 11, 20, 44, 121, 298, 311
   Common Symbols, 11
docks, 15
   adding palettes, 15
expanding, 15
Expression, 12
finding items, 15
inserting items, 12
Layout, 11
Matrix, 12, 133, 139
moving, 15
Symbol Recognition, 15
Units, 24, 99
viewing, 15
paragraph styles
   creating, 243
description, 239
format lists, 263
parameters, 339
parametric solutions, 83
partial differential equations
   solving, 92
paste, 237
PDEs, 92
pdsolve command, 92
pencil
   sketch pad, 275
pi
   inserting, 12
pie chart, 175
piecewise command, 172
placeholders, 12
Planck constant, 105
Plot Builder Assistant, 28, 49
plot command, 160
plot3d command, 295
plots
   analyzing, 222
   pan, 222
   point probe, 222
   rotate, 222
   scale, 222
code for color plates, 230
creating, 188
context menu, 203
displaying multiple plots, 213
insert plot, 206
Interactive Plot Builder, 28, 49, 189
plot command, 207
plot3d command, 207
plots package, 210
creating animations
   animate command, 224
   Interactive Plot Builder, 223
customizing, 215
context menu, 216
Interactive Plot Builder, 215
plot options, 219
plot3d options, 219
customizing animations, 228
command-line options, 229
context menu, 228
Interactive Plot Builder, 228
exporting, 230
functional operators, 295
gradient, 183
line integral, 184
ODEs
numeric solution, 90
symbolic solution, 91
optimization problem, 168
playing animations, 226
plots package
  animate command, 224
  contourplot command, 213
display command, 214
matrixplot command, 211
pointplot command, 210
series, 160
statistics, 175
viewing animations
  animate context bar, 226
polynomial equations
  solving, 82
    numerically, 84
polynomials
  algebra, 124
  arithmetic, 124
  coefficients, 130
  collecting terms, 130
degree, 130
division, 124, 126
efficient arithmetic, 133
expanding, 125
factoring, 131
implied multiplication, 126
numeric
  algebraic manipulation, 133
  operations, 132
  sorting, 126
    pure lexicographic, 128
total degree, 127
PolynomialTools package, 133
IsSelfReciprocal command, 132
powers
  entering, 5
precalculus
  teaching, 179
precision, 69
prem command, 132
previously assigned, 318
primality testing, 73
primpart command, 132
print
  command, 340
table, 257
probability distribution, 171
proc key word, 338
procedures, 338
  and assumptions, 119
calling, 338
defining, 338
displaying, 340
inputs, 339
multiple lines, 338
output, 339
using, 338
product command, 334
products
  entering, 5
  implied, 6
programs, 321
  modules, 342
  procedures, 338
prompt
  input, 37
properties
  testing, 117
protected names, 57
Q
QPSolve command, 170
QR factorization, 149
quadratic programs, 170
quantities with uncertainty, 111
  accessing error, 111
  accessing value, 111
  computing with, 112
  constructing, 111
  element properties, 112
  rounding the error, 112
  scientific constants, 112
  with units, 112
quick
  character formatting, 233
  help, 32
  paragraph formatting, 235
  reference card, 32
quit statement, 332
quo command, 124
quotes
  double, 297
  left single, 58
  right single, 57, 317
  unevaluation, 317
quotient
  integer, 73
R
random
  matrices, 140
  variables, 171
randpoly command, 132
range
  in plots, 217
  operator, 142
  rank, 147
rational expressions
  entering, 5
read
  from files, 366
recurrence relation
  solving, 95
reference
  equation labels, 59
  names, 55
relational operators, 322
rem command, 124
remainder
  integer, 73
remove command, 335
repetition statements, 325
reserved names, 57
restart command, 58
resultant command, 132
return
  statement, 332
  values, 339
rhs command, 301
right single quotes, 57, 317
right-hand side, 301
RootOf structure, 82
roots
  command, 132
  of equations, 83
row vector
  creating, 141
rsolve command, 95
S
scatter plot, 175
scientific constants, 104
list, 104
name, 105
symbol, 105
uncertainty, 109
units, 108
using, 105
value, 108
value and units, 109
ScientificConstants package, 104
extensibility, 110
objects, 107
ScientificErrorAnalysis package, 110
extensibility, 113
objects, 111
sections
in worksheet, 237
security levels
auto-execute, 273
security tab
options dialog, 273
select command, 335
selectremove command, 335
semicolon, 38–39
seq command, 333
series, 159
command, 159
plotting, 160
Taylor, 159
type, 160
sets, 287
shape option, 140
show
worksheet content, 266
show contents dialog
using, 267
significant digits, 69
simplify command, 304, 312
sketch pad
canvas style, 238
gridline, 276
slider
embedding, 268
solutions
assigning as expression, 87
assigning as function, 87
details, 93
formal, 92
formal power series, 92
integers, 93
real, 114
series, 92
verifying, 86
solve
equations, 78
for real solutions, 114
numerically, 83
symbolically, 80
inequations, 78
for real solutions, 114
symbolically, 80
integer equations, 93
linear system, 94, 149
modular integer equations, 94
ODEs, 88
PDEs, 92
recurrence relation, 95
transcendental equations, 82
solve command, 80, 288
finding all solutions, 82
finding parametric solutions, 83
real solutions, 114
solving procedures, 83
sort
  lists, 310
  polynomials, 126, 310
sort command, 126, 310
  plex option, 128
spacing format, 236
spellcheck, 276
  American spelling, 276
  dictionary, 279
sqrfree command, 133
square roots
  entering, 7, 17
standard content, 53
Standard Units environment, 101
Standard Worksheet, xiii
statements
  multiple lines, 338
Statistics package, 171
  continuous distributions, 171
  discrete distributions, 171
  plots, 175
strings, 297
StringTools package, 297
Student package, 158, 178–179
  calculus subpackages, 166
  LinearAlgebra subpackage, 150
  Maplets, 178
  Tutors, 178
student resources, 178
study guides, 179
style set management, 245
subscripts
  entering, 6
  format, 233
substitute, 310
sum command, 334

superscript format, 233
Sylvester matrix, 149
symbol completion, 7
  shortcut, 7
symbolic
  computation, 66
  objects, 67
symbols
  entering, 16
  finding, 15
  names, 16
system of units, 97
  controlling, 102
systeme international (SI), 25, 97

T
Tab
  icon, 44
  inserting, 44
  key, 12, 44
tables, 290
  alignment, 255
  and Classic worksheet, 258
  appearance, 255
  borders, 255
  contents, 253
  execution order, 257
  physical dimensions, 254
  printing, 257
  using, 252
  visibility of cell content, 256
Task Browser, 51
task templates, 51, 71, 96, 121, 133, 151
  default content, 53
  inserting, 52
taylor command, 159
Taylor series, 159
tcoeff command, 131
teach, 178
temperature conversion, 98
text field
  embedding, 268
Text mode, 4
text regions, 54
third-party products, 122
tilde, 82, 116
to clause, 326
  excluding, 327
Tolerances package, 110
toolbar, 4
toolbox
  Global Optimization, 122
toolboxes
  Database Integration, 374
  Global Optimization, 166
Tools menu
  Assistants and Tutors, 26, 48
  Tasks, 51
Torsion command, 165
total degree, 127
tour, 32
transparency
  of 3-D plots, 220
transpose
  matrices and vectors, 146
true, 323
Tutors, 26, 178–179, 181
  Derivatives, 179
  Differentiation Methods, 180
  Directional Derivative, 157
  Function Composition, 27
  Gradient, 181
    menu access, 27
  type command, 299
  types, 116, 298
    converting, 307
    series, 160
    testing, 299
      subexpressions, 299
  typesetting rule assistant, 238
U
  unapply command, 87
  unassign command, 57
  unassigning names, 57, 319
  uncertainty, 110
    quantities with, 110
  underline format, 233
  unevaluation quotes, 57, 317
  union
    of sets, 288
  Unit Converter Assistant, 308
  units, 24, 96, 308
    adding to expressions, 25
    applying to expression, 99
    computing with, 101
    context, 97
    converting between, 97
    environment, 101
    evaluating with, 25
    in 1-D Math, 101
    inserting, 100
    overview, 96
    prefixes, 101
    system of
      controlling, 102
      systems of, 97
Units Calculator, 97
Units package, 96
  environments, 101
  extensibility, 103
  UseSystem command, 103
  UsingSystem command, 103
Units palettes, 24, 99
universal gravitational constant, 105
UNIX
  command/symbol completion, 7
unwith command, 43
URL
  adding hyperlink to, 282
user-defined style set, 247
V
variables, 10
variance, 112
VariationalCalculus package, 166
Vector
  constructor
    vectorfield attribute, 164
    data structure, 133
  vector fields, 164
  vector spaces
    basis, 148–149
VariationalCalculus package, 166
  Student version, 166
vectors, 291
  arithmetic, 143
  column, 136
  context menus, 146
  cross product, 146
  data type, 140
  defining, 136
  efficiency, 139
  filling, 140
  large, 137
  multiplication, 144
  row, 136, 141
  scalar multiplication, 145
  selecting entries, 142
  shape, 140
  transpose, 146
View menu
  markers, 238
W
Web page
  adding hyperlink to, 282
Web site
  Application Center, 122, 178
  Maplesoft, 32, 121–122
  Student Center, 179
while loops, 329
Windows
  command/symbol completion, 7
with command, 42
worksheet
  adding hyperlink to, 282
Worksheet mode, 1, 35
write
  to files, 363
X
xor operator, 323
Z
zero recognition, 309
zip command, 336